summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-ps/zathura-ps-9999.ebuild')
-rw-r--r--app-text/zathura-ps/zathura-ps-9999.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/app-text/zathura-ps/zathura-ps-9999.ebuild b/app-text/zathura-ps/zathura-ps-9999.ebuild
index 16e0d2d5ba33..52b16b0f9b8d 100644
--- a/app-text/zathura-ps/zathura-ps-9999.ebuild
+++ b/app-text/zathura-ps/zathura-ps-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson
+inherit meson xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
EGIT_BRANCH="develop"
else
- KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://pwmt.org/projects/zathura-ps/download/${P}.tar.xz"
fi
DESCRIPTION="PostScript plug-in for zathura"
@@ -29,3 +29,11 @@ DEPEND="app-text/libspectre
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}