summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-ps')
-rw-r--r--app-text/zathura-ps/Manifest2
-rw-r--r--app-text/zathura-ps/metadata.xml7
-rw-r--r--app-text/zathura-ps/zathura-ps-0.2.7.ebuild (renamed from app-text/zathura-ps/zathura-ps-0.2.6.ebuild)18
-rw-r--r--app-text/zathura-ps/zathura-ps-9999.ebuild18
4 files changed, 29 insertions, 16 deletions
diff --git a/app-text/zathura-ps/Manifest b/app-text/zathura-ps/Manifest
index eba030e6d419..70c1e626dabc 100644
--- a/app-text/zathura-ps/Manifest
+++ b/app-text/zathura-ps/Manifest
@@ -1 +1 @@
-DIST zathura-ps-0.2.6.tar.xz 4336 BLAKE2B 9129ae5c5b6b7452fbee720ded0a69d4ae735811b81ec49485fffc81833e5e0adf0563b005770082adcc17dc90d4650b5bd309154b64377625c2cef86f0b7978 SHA512 6631f9b1c951b6f91f2a5217c3de47176205102206f15b596fb21285dae8d01fd759cfaca1b8a23bf47166dfbc3f8cf6061ce5a4d7a1c3a2b671a3beef5a07bb
+DIST zathura-ps-0.2.7.tar.xz 4488 BLAKE2B 4513173a2f9ca725abf8444516a78fd789286b082a1146ab5d0dee504cdda92962f3e6cef46f24e0307bc5ea6bb6595577fac2dfbd2d4ef0cf8e69d34337baf5 SHA512 86cf4cea8f32e446960c7727745711d6bb6723bb41127ccba335fbdaeb78e9f681ce4104b2be8718a2f19e06aef30d49ae7c90091fa0774b5ffe22303cf37d5f
diff --git a/app-text/zathura-ps/metadata.xml b/app-text/zathura-ps/metadata.xml
index 9e0907fe1628..e0e23d23393f 100644
--- a/app-text/zathura-ps/metadata.xml
+++ b/app-text/zathura-ps/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <name>Mikle Kolyada</name>
- <email>zlogene@gentoo.org</email>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<maintainer status="active">
<email>mlq@pwmt.org</email>
diff --git a/app-text/zathura-ps/zathura-ps-0.2.6.ebuild b/app-text/zathura-ps/zathura-ps-0.2.7.ebuild
index 94dab249fb7a..8ccbde58f647 100644
--- a/app-text/zathura-ps/zathura-ps-0.2.6.ebuild
+++ b/app-text/zathura-ps/zathura-ps-0.2.7.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson
+inherit meson xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
EGIT_BRANCH="develop"
else
- KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
- SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
+ KEYWORDS="amd64 arm ~riscv x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://pwmt.org/projects/zathura-ps/download/${P}.tar.xz"
fi
DESCRIPTION="PostScript plug-in for zathura"
@@ -29,3 +29,11 @@ DEPEND="app-text/libspectre
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/app-text/zathura-ps/zathura-ps-9999.ebuild b/app-text/zathura-ps/zathura-ps-9999.ebuild
index 16e0d2d5ba33..52b16b0f9b8d 100644
--- a/app-text/zathura-ps/zathura-ps-9999.ebuild
+++ b/app-text/zathura-ps/zathura-ps-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson
+inherit meson xdg-utils
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-ps.git"
EGIT_BRANCH="develop"
else
- KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="https://pwmt.org/projects/zathura-ps/download/${P}.tar.xz"
fi
DESCRIPTION="PostScript plug-in for zathura"
@@ -29,3 +29,11 @@ DEPEND="app-text/libspectre
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}