summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/rust-vim')
-rw-r--r--app-vim/rust-vim/Manifest1
-rw-r--r--app-vim/rust-vim/metadata.xml12
-rw-r--r--app-vim/rust-vim/rust-vim-1_beta20150411.ebuild18
3 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/rust-vim/Manifest b/app-vim/rust-vim/Manifest
new file mode 100644
index 000000000000..4b772f0ce0cb
--- /dev/null
+++ b/app-vim/rust-vim/Manifest
@@ -0,0 +1 @@
+DIST rust-mode-vim-1_beta20150411.tar.gz 14834 SHA256 ae10727c14612905f489afea1146bac24a0ea6309a3a3fcf97a048dd1e156eb4 SHA512 f841768909203475a0cd3589a148d334001351fb23976ee28823a9dbde396d89a4f3c5ac07166420c8ddb64692dcc86b98b3afc3579171115a3a2af17b6aa449 WHIRLPOOL c95fc23f40608be817c7fc7467138efaa25a6b24427b79ab0de7daf84e5f32c4f2cd0db1377e2eaa0e40bf83cb765c86f6e04752b142b1779c194ceddc8b7d07
diff --git a/app-vim/rust-vim/metadata.xml b/app-vim/rust-vim/metadata.xml
new file mode 100644
index 000000000000..3554bdb770b5
--- /dev/null
+++ b/app-vim/rust-vim/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hilobakho@gmail.com</email>
+ <name>Mykyta Holubakha</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/rust-vim/rust-vim-1_beta20150411.ebuild b/app-vim/rust-vim/rust-vim-1_beta20150411.ebuild
new file mode 100644
index 000000000000..81d1f6355fad
--- /dev/null
+++ b/app-vim/rust-vim/rust-vim-1_beta20150411.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN="rust-mode-vim"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Vim configuration for Rust"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="https://dev.gentoo.org/~jauhien/distfiles/${MY_P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${MY_P}"