summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/extlib/extlib-1.6.1.ebuild')
-rw-r--r--dev-ml/extlib/extlib-1.6.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/extlib/extlib-1.6.1.ebuild b/dev-ml/extlib/extlib-1.6.1.ebuild
new file mode 100644
index 000000000000..b36a78a73790
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
+SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake opt
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}