summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/extlib')
-rw-r--r--dev-ml/extlib/Manifest2
-rw-r--r--dev-ml/extlib/extlib-1.5.4.ebuild39
-rw-r--r--dev-ml/extlib/extlib-1.6.1.ebuild42
-rw-r--r--dev-ml/extlib/metadata.xml8
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-ml/extlib/Manifest b/dev-ml/extlib/Manifest
new file mode 100644
index 000000000000..1167ddac6f57
--- /dev/null
+++ b/dev-ml/extlib/Manifest
@@ -0,0 +1,2 @@
+DIST extlib-1.5.4.tar.gz 71003 SHA256 df142ba5a04ccbd4b239a124bd0f634989781b4da63e517c05a036fd419cd9cd SHA512 f70ea54c50499dd8be47b1ee001119a6b6b3c8b29995a2bfb93181dc86790727122d330e67147d00d1c8aff02c263dc1ea954ac2f2ad34f76f5e45f5779c2ea7 WHIRLPOOL 499291050623f27e001ef92f9eea94bdaf1abe5fbd91c6bcad445e747e56f670c3250140c24268b08227dace6da99745407b02cbb7f877687b912dc5d85005e6
+DIST extlib-1.6.1.tar.gz 72780 SHA256 88d4b3638cb4da4e04d81ba157e7235e744373c5784cf4b906570d07b890aeca SHA512 9473f474bee99248bdc5e3c56741a191a8f0b89dbf750a4d9e92692b7871c997c584a2dc7e57f55b36b5ddcaf7a11d45b490b117ac15806e35813b82b696f541 WHIRLPOOL 0dc27bad6223de1a1d75684f9caba8708e6c6a80f046c4604fe4bd9da5f860b17be180e3a8d0cdc817e1d99fd6c9feec62a2696b5d78e5706e89ea02460d2d40
diff --git a/dev-ml/extlib/extlib-1.5.4.ebuild b/dev-ml/extlib/extlib-1.5.4.ebuild
new file mode 100644
index 000000000000..8549fd7c9754
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.5.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
+SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+src_compile() {
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}
diff --git a/dev-ml/extlib/extlib-1.6.1.ebuild b/dev-ml/extlib/extlib-1.6.1.ebuild
new file mode 100644
index 000000000000..b36a78a73790
--- /dev/null
+++ b/dev-ml/extlib/extlib-1.6.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Standard library extensions for O'Caml"
+HOMEPAGE="http://code.google.com/p/ocaml-extlib/"
+SRC_URI="http://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+DEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )
+"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc +ocamlopt"
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake opt
+ fi
+
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt
+
+ if use doc; then
+ dohtml doc/*
+ fi
+}
diff --git a/dev-ml/extlib/metadata.xml b/dev-ml/extlib/metadata.xml
new file mode 100644
index 000000000000..4a1e22e112e7
--- /dev/null
+++ b/dev-ml/extlib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="google-code">ocaml-extlib</remote-id>
+ </upstream>
+</pkgmetadata>