summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/PPIx-Regexp')
-rw-r--r--dev-perl/PPIx-Regexp/Manifest2
-rw-r--r--dev-perl/PPIx-Regexp/PPIx-Regexp-0.31.0.ebuild26
-rw-r--r--dev-perl/PPIx-Regexp/PPIx-Regexp-0.33.0.ebuild26
-rw-r--r--dev-perl/PPIx-Regexp/metadata.xml67
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-perl/PPIx-Regexp/Manifest b/dev-perl/PPIx-Regexp/Manifest
new file mode 100644
index 000000000000..c2b1cb67051a
--- /dev/null
+++ b/dev-perl/PPIx-Regexp/Manifest
@@ -0,0 +1,2 @@
+DIST PPIx-Regexp-0.031.tar.gz 152166 SHA256 44f705b2f0a47f8434c4ba84b17989597d65dde813b7b42c5cd7bd5c16699ff2 SHA512 4a55c368c24447dc8a386e58fac7f7acc31725b8b913595eff2cc0dc2f43d7e398474c5b94c8c007c2e9c2ad78f817dca4b39ae53f8b27a13b06aa9c291fa2e3 WHIRLPOOL fc80f560a7f0ee2dfd44eb27db134682f200393bd3a2ec2dcea3cfc8b2bdd73ea97b0b375b1e98304f871762984d6e87a9fdfd1da58b5afe3fba4e5962b86e5f
+DIST PPIx-Regexp-0.033.tar.gz 153667 SHA256 40adf6555cd8a692f79530f74f343d7d9ace53f7e3a2eefbbefebf8e7743d784 SHA512 6367941b3ffc71c7f5ecbbee8ccb8953c6fab1ac7caea5b242e917241335c693bb8e30797c9ee82b52250976de9712abb0173e2490422c243116c25092faf5e1 WHIRLPOOL 58fcc27908249af88c443660f43c0655afd496af275856be853cfd0f23478e3f7b1d7d81013af523b7789e35175f7d11f88ffa868d380d02ec975de03214180a
diff --git a/dev-perl/PPIx-Regexp/PPIx-Regexp-0.31.0.ebuild b/dev-perl/PPIx-Regexp/PPIx-Regexp-0.31.0.ebuild
new file mode 100644
index 000000000000..269f4d081433
--- /dev/null
+++ b/dev-perl/PPIx-Regexp/PPIx-Regexp-0.31.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=WYANT
+MODULE_VERSION=0.031
+inherit perl-module
+
+DESCRIPTION="Represent a regular expression of some sort"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/List-MoreUtils
+ dev-perl/PPI
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+"
+
+SRC_TEST=do
diff --git a/dev-perl/PPIx-Regexp/PPIx-Regexp-0.33.0.ebuild b/dev-perl/PPIx-Regexp/PPIx-Regexp-0.33.0.ebuild
new file mode 100644
index 000000000000..1eb1c1a2beb8
--- /dev/null
+++ b/dev-perl/PPIx-Regexp/PPIx-Regexp-0.33.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=WYANT
+MODULE_VERSION=0.033
+inherit perl-module
+
+DESCRIPTION="Represent a regular expression of some sort"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/List-MoreUtils
+ dev-perl/PPI
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+"
+
+SRC_TEST=do
diff --git a/dev-perl/PPIx-Regexp/metadata.xml b/dev-perl/PPIx-Regexp/metadata.xml
new file mode 100644
index 000000000000..483e0b6a0de1
--- /dev/null
+++ b/dev-perl/PPIx-Regexp/metadata.xml
@@ -0,0 +1,67 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">PPIx-Regexp</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Constant</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Dumper</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Element</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Lexer</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Node</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Node::Range</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Assertion</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::BranchReset</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Capture</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::CharClass</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Code</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Main</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Modifier</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::NamedCapture</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Quantifier</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::RegexSet</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Regexp</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Replacement</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Subexpression</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Switch</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Structure::Unknown</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Support</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Assertion</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Backreference</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Backtrack</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::CharClass</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::CharClass::POSIX</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::CharClass::POSIX::Unknown</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::CharClass::Simple</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Code</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Comment</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Condition</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Control</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Delimiter</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Greediness</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::GroupType</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::GroupType::Assertion</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::GroupType::BranchReset</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::GroupType::Code</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::GroupType::Modifier</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::GroupType::NamedCapture</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::GroupType::Subexpression</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::GroupType::Switch</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Interpolation</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Literal</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Modifier</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Operator</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Quantifier</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Recursion</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Reference</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Structure</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Unknown</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Unmatched</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Token::Whitespace</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Tokenizer</remote-id>
+ <remote-id type="cpan-module">PPIx::Regexp::Util</remote-id>
+ </upstream>
+</pkgmetadata>