summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild')
-rw-r--r--dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild b/dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild
new file mode 100644
index 000000000000..216e47f8341e
--- /dev/null
+++ b/dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"