summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild6
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
index 68c62e65ac14..1e512377b27b 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0_p2.ebuild
@@ -211,6 +211,12 @@ src_compile() {
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+ # support for stack-protector is still new and experimental
+ # for mingw and issues can also be harder to debug + fix for
+ # upstreams using it, if feeling concerned about security
+ # would advise to either not use wine or at least contain it
+ use custom-cflags || filter-flags '-fstack-protector*' #931512
+
# some bashrc-mv users tend to do CFLAGS="${LDFLAGS}" and then
# strip-unsupported-flags miss these during compile-only tests
# (primarily done for 23.0 profiles' -z, not full coverage)
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild
index 4003b26827a8..09f8b50f64a4 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.1.ebuild
@@ -221,6 +221,12 @@ src_compile() {
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+ # support for stack-protector is still new and experimental
+ # for mingw and issues can also be harder to debug + fix for
+ # upstreams using it, if feeling concerned about security
+ # would advise to either not use wine or at least contain it
+ use custom-cflags || filter-flags '-fstack-protector*' #931512
+
# some bashrc-mv users tend to do CFLAGS="${LDFLAGS}" and then
# strip-unsupported-flags miss these during compile-only tests
# (primarily done for 23.0 profiles' -z, not full coverage)