summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kio-ftps/kio-ftps-0.2.ebuild')
-rw-r--r--kde-misc/kio-ftps/kio-ftps-0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-misc/kio-ftps/kio-ftps-0.2.ebuild b/kde-misc/kio-ftps/kio-ftps-0.2.ebuild
new file mode 100644
index 000000000000..56a909dcdd10
--- /dev/null
+++ b/kde-misc/kio-ftps/kio-ftps-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE ftps KIO slave"
+HOMEPAGE="http://kde-apps.org/content/show.php/kio-ftps?content=35875"
+SRC_URI="http://dev.gentoo.org/~johu/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# This is just for some app we can use kio-ftps with
+RDEPEND="|| (
+ $(add_kdeapps_dep konqueror)
+ $(add_kdeapps_dep dolphin)
+)"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # remove all temp files
+ rm -rf *~
+ # fix linking
+ sed -i \
+ -e "s:\${KDE4_KDECORE_LIBS}:\${KDE4_KIO_LIBS}:g" \
+ CMakeLists.txt || die "sed linking failed"
+}