summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kio-ftps')
-rw-r--r--kde-misc/kio-ftps/Manifest1
-rw-r--r--kde-misc/kio-ftps/kio-ftps-0.2.ebuild33
-rw-r--r--kde-misc/kio-ftps/metadata.xml5
3 files changed, 39 insertions, 0 deletions
diff --git a/kde-misc/kio-ftps/Manifest b/kde-misc/kio-ftps/Manifest
new file mode 100644
index 000000000000..d386a182b90d
--- /dev/null
+++ b/kde-misc/kio-ftps/Manifest
@@ -0,0 +1 @@
+DIST kio-ftps-0.2.tar.gz 71332 SHA256 d0c2dd2eba6b102d56ba764a6d354614dcc6aff2a3c69b7d2a3921a40ee90642 SHA512 98b302cb65aea720eda4d186241ddaa34fb9c4b77e74d3592c4e8108eede337636b9f01f3bd7594817a0db03fe30bc121d5d53d2095a13d89369f0156581b02a WHIRLPOOL adfe41b89945ba7923afe2b8d893c5599c06fa6c2c5d0bde8d74f615b95ef8f9967f6394d922bb97884c12901b60afe71def346528415b72c2929bbf33102e15
diff --git a/kde-misc/kio-ftps/kio-ftps-0.2.ebuild b/kde-misc/kio-ftps/kio-ftps-0.2.ebuild
new file mode 100644
index 000000000000..56a909dcdd10
--- /dev/null
+++ b/kde-misc/kio-ftps/kio-ftps-0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE ftps KIO slave"
+HOMEPAGE="http://kde-apps.org/content/show.php/kio-ftps?content=35875"
+SRC_URI="http://dev.gentoo.org/~johu/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# This is just for some app we can use kio-ftps with
+RDEPEND="|| (
+ $(add_kdeapps_dep konqueror)
+ $(add_kdeapps_dep dolphin)
+)"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # remove all temp files
+ rm -rf *~
+ # fix linking
+ sed -i \
+ -e "s:\${KDE4_KDECORE_LIBS}:\${KDE4_KIO_LIBS}:g" \
+ CMakeLists.txt || die "sed linking failed"
+}
diff --git a/kde-misc/kio-ftps/metadata.xml b/kde-misc/kio-ftps/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-misc/kio-ftps/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>