summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/alsamixergui/files')
-rw-r--r--media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-fltk-1.1.patch16
-rw-r--r--media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-gcc34.patch11
-rw-r--r--media-sound/alsamixergui/files/segfault-on-exit.patch11
3 files changed, 38 insertions, 0 deletions
diff --git a/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-fltk-1.1.patch b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-fltk-1.1.patch
new file mode 100644
index 000000000000..a7c121dbc9d1
--- /dev/null
+++ b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-fltk-1.1.patch
@@ -0,0 +1,16 @@
+--- configure.in
++++ configure.in
+@@ -11,11 +11,11 @@
+ AC_PROG_LN_S
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(fltk,numericsort,,AC_MSG_ERROR("missing fltk"))
++AC_CHECK_LIB(fltk,fl_numericsort,,AC_MSG_ERROR("missing fltk"))
+ AM_PATH_ALSA(0.9.0)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_HAVE_HEADERS(stdio.h string.h stdlib.h getopt.h alsa/asoundlib.h FL/Fl.H)
++AC_HAVE_HEADERS(stdio.h string.h stdlib.h getopt.h alsa/asoundlib.h)
+
+ AC_OUTPUT(Makefile src/Makefile)
diff --git a/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-gcc34.patch b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-gcc34.patch
new file mode 100644
index 000000000000..6f37970aa568
--- /dev/null
+++ b/media-sound/alsamixergui/files/alsamixergui-0.9.0.1.2-gcc34.patch
@@ -0,0 +1,11 @@
+--- src/alsamixer.cxx
++++ src/alsamixer.cxx
+@@ -654,7 +654,7 @@
+ if (joined) {
+ #ifdef ALSAMIXER_GUI
+ for (chn = snd_mixer_selem_channel_id_t(0); chn < SND_MIXER_SCHN_LAST;
+- snd_mixer_selem_channel_id_t(int(chn)++))
++ snd_mixer_selem_channel_id_t(int(chn)+1))
+ #else
+ for (chn = 0; chn < SND_MIXER_SCHN_LAST; chn++)
+ #endif
diff --git a/media-sound/alsamixergui/files/segfault-on-exit.patch b/media-sound/alsamixergui/files/segfault-on-exit.patch
new file mode 100644
index 000000000000..6dc2feb8cc58
--- /dev/null
+++ b/media-sound/alsamixergui/files/segfault-on-exit.patch
@@ -0,0 +1,11 @@
+--- src/alsamixer.cxx
++++ src/alsamixer.cxx
+@@ -1869,7 +1869,7 @@
+ if (procWindow) delete procWindow;
+ if (mainWindow) delete mainWindow;
+ mainWindow = 0; procWindow = 0; helpWindow = 0;
+- return 0;
++ mixer_abort (ERR_NONE, "", 0);
+ #endif /* #ifdef ALSAMIXER_GUI */
+ break;
+ case 13: /* Return */