summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/deadbeef')
-rw-r--r--media-sound/deadbeef/Manifest2
-rw-r--r--media-sound/deadbeef/deadbeef-1.8.8-r1.ebuild191
-rw-r--r--media-sound/deadbeef/deadbeef-1.9.6-r1.ebuild (renamed from media-sound/deadbeef/deadbeef-1.8.8-r2.ebuild)76
-rw-r--r--media-sound/deadbeef/files/deadbeef-1.9.6-drop-Werror.patch35
-rw-r--r--media-sound/deadbeef/files/deadbeef-1.9.6-fix-desktop-launcher.patch32
-rw-r--r--media-sound/deadbeef/files/deadbeef-1.9.6-update-gettext.patch17
-rw-r--r--media-sound/deadbeef/files/deadbeef-use-ffmpeg-plugin-for-ape-by-default.patch13
-rw-r--r--media-sound/deadbeef/metadata.xml8
8 files changed, 135 insertions, 239 deletions
diff --git a/media-sound/deadbeef/Manifest b/media-sound/deadbeef/Manifest
index 0ca8958aee29..ad732eded48d 100644
--- a/media-sound/deadbeef/Manifest
+++ b/media-sound/deadbeef/Manifest
@@ -1 +1 @@
-DIST deadbeef-1.8.8.tar.bz2 5083407 BLAKE2B 69fd2cbaf131b3e44b426163ce6a83479bb1aff0e088c4beea09d747750f6f20b1e297eab1dd1ae0446d2af0aaf28fe0cc7c9f9e3e73fe031d369ba2f5d809ca SHA512 399f0e70eca5e102a9e73ff03199c89c6f28f3e0da96e793316d1af83f00e71f09f6cc81a3fd0b0f0d52fe9e0195a3b9ffb0cf7e7708c3ea7085f33a5ec08b47
+DIST deadbeef-1.9.6.tar.bz2 5182123 BLAKE2B 2cf515dbc3175e04319075462e88d18ee2fae06e8b317d1cc0c958ac23498217bb0a02e0201f47a39dfd4c0092ba568b8aebe4c37c99b439d2dcc18a7848ba2e SHA512 6e507399f7452a66c5591e09d4309f2aab676992d048625c9b4d801ea40af6ce79862fb497e8c94efdf3a13572c964dca717b42f1c946f5ec4695dc38c1db572
diff --git a/media-sound/deadbeef/deadbeef-1.8.8-r1.ebuild b/media-sound/deadbeef/deadbeef-1.8.8-r1.ebuild
deleted file mode 100644
index 60f97c9006e4..000000000000
--- a/media-sound/deadbeef/deadbeef-1.8.8-r1.ebuild
+++ /dev/null
@@ -1,191 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools xdg flag-o-matic plocale
-
-DESCRIPTION="DeaDBeeF is a modular audio player similar to foobar2000"
-HOMEPAGE="https://deadbeef.sourceforge.io/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="
- GPL-2
- LGPL-2.1
- wavpack? ( BSD )
-"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aac alsa cdda converter cover dts ffmpeg flac +hotkeys lastfm mp3 musepack nls notify nullout opus oss pulseaudio shellexec +supereq threads vorbis wavpack"
-
-REQUIRED_USE="
- || ( alsa oss pulseaudio nullout )
-"
-
-DEPEND="
- x11-libs/gtk+:3
- net-misc/curl:0=
- dev-libs/jansson:=
- aac? ( media-libs/faad2 )
- alsa? ( media-libs/alsa-lib )
- cdda? (
- dev-libs/libcdio:0=
- media-libs/libcddb
- dev-libs/libcdio-paranoia:0=
- )
- cover? ( media-libs/imlib2[jpeg,png] )
- dts? ( media-libs/libdca )
- ffmpeg? ( media-video/ffmpeg )
- flac? (
- media-libs/flac
- media-libs/libogg
- )
- mp3? ( media-sound/mpg123 )
- musepack? ( media-sound/musepack-tools )
- nls? ( virtual/libintl )
- notify? (
- sys-apps/dbus
- dev-libs/libdispatch
- )
- opus? ( media-libs/opusfile )
- pulseaudio? ( media-sound/pulseaudio )
- vorbis? ( media-libs/libvorbis )
- wavpack? ( media-sound/wavpack )
- lastfm? ( dev-libs/libdispatch )
-"
-
-RDEPEND="${DEPEND}"
-BDEPEND="
- dev-util/intltool
- sys-devel/gettext
- sys-devel/clang
- sys-devel/llvm
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/deadbeef-use-ffmpeg-plugin-for-ape-by-default.patch"
-)
-
-src_prepare() {
- default
-
- drop_from_linguas() {
- sed "/${1}/d" -i "${S}/po/LINGUAS" || die
- }
-
- drop_and_stub() {
- rm -rf "${1}"
- mkdir "${1}"
- cat > "${1}/Makefile.in" <<-EOF
- all: nothing
- install: nothing
- nothing:
- EOF
- }
-
- plocale_for_each_disabled_locale drop_from_linguas || die
-
- eautopoint --force
- eautoreconf
-
- # Get rid of bundled gettext.
- drop_and_stub "${S}/intl"
-
- # Plugins that are undesired for whatever reason, candidates for unbundling and such.
- for i in adplug alac dumb ffap mms gme mono2stereo psf sc60 shn sid soundtouch wma; do
- drop_and_stub "${S}/plugins/${i}"
- done
-
- rm -rf "${S}/plugins/rg_scanner/ebur128"
-}
-
-src_configure () {
- if ! tc-is-clang; then
- AR=llvm-ar
- CC=${CHOST}-clang
- CXX=${CHOST}-clang++
- NM=llvm-nm
- RANLIB=llvm-ranlib
-
- strip-unsupported-flags
- fi
-
- export HOST_CC="$(tc-getBUILD_CC)"
- export HOST_CXX="$(tc-getBUILD_CXX)"
- tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
-
- local myconf=(
- "--disable-static"
- "--disable-staticlink"
- "--disable-portable"
- "--disable-rpath"
-
- "--disable-libmad"
- "--disable-gtk2"
- "--disable-adplug"
- "--disable-coreaudio"
- "--disable-dumb"
- "--disable-alac"
- "--disable-ffap"
- "--disable-gme"
- "--disable-mms"
- "--disable-mono2stereo"
- "--disable-psf"
- "--disable-rgscanner"
- "--disable-sc68"
- "--disable-shn"
- "--disable-sid"
- "--disable-sndfile"
- "--disable-soundtouch"
- "--disable-src"
- "--disable-tta"
- "--disable-vfs-zip"
- "--disable-vtx"
- "--disable-wildmidi"
- "--disable-wma"
-
- "$(use_enable alsa)"
- "$(use_enable oss)"
- "$(use_enable pulseaudio pulse)"
- "$(use_enable mp3)"
- "$(use_enable mp3 libmpg123)"
- "$(use_enable nls)"
- "$(use_enable vorbis)"
- "$(use_enable threads)"
- "$(use_enable flac)"
- "$(use_enable supereq)"
- "$(use_enable cdda)"
- "$(use_enable cdda cdda-paranoia)"
- "$(use_enable aac)"
- "$(use_enable cover artwork)"
- "$(use_enable cover artwork-imlib2)"
- "$(use_enable cover artwork-network)"
- "$(use_enable dts dca)"
- "$(use_enable ffmpeg)"
- "$(use_enable converter)"
- "$(use_enable musepack)"
- "$(use_enable notify)"
- "$(use_enable nullout)"
- "$(use_enable opus)"
- "$(use_enable pulseaudio pulse)"
- "$(use_enable shellexec)"
- "$(use_enable shellexec shellexecui)"
- "$(use_enable lastfm lfm)"
- "$(use_enable wavpack)"
-
- "--enable-gtk3"
- "--enable-vfs-curl"
- "--enable-shared"
- "--enable-m3u"
- "--enable-pltbrowser"
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- find "${ED}" -name '*.la' -delete || die
-}
diff --git a/media-sound/deadbeef/deadbeef-1.8.8-r2.ebuild b/media-sound/deadbeef/deadbeef-1.9.6-r1.ebuild
index f47011fdec0b..685c774b15c0 100644
--- a/media-sound/deadbeef/deadbeef-1.8.8-r2.ebuild
+++ b/media-sound/deadbeef/deadbeef-1.9.6-r1.ebuild
@@ -1,13 +1,14 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools xdg flag-o-matic toolchain-funcs plocale
DESCRIPTION="DeaDBeeF is a modular audio player similar to foobar2000"
HOMEPAGE="https://deadbeef.sourceforge.io/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+SRC_URI="https://sourceforge.net/projects/${PN}/files/travis/linux/${PV}/deadbeef-${PV}.tar.bz2/download
+ -> ${P}.tar.bz2"
LICENSE="
GPL-2
@@ -15,56 +16,64 @@ LICENSE="
wavpack? ( BSD )
"
SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="aac alsa cdda converter cover dts ffmpeg flac +hotkeys lastfm mp3 musepack nls notify nullout opus oss pulseaudio sc68 shellexec +supereq threads vorbis wavpack"
+KEYWORDS="amd64 ~riscv x86"
+IUSE="aac alsa cdda converter cover dts ffmpeg flac +hotkeys lastfm libretro libsamplerate mp3 musepack nls notify +nullout opus oss pulseaudio pipewire sc68 shellexec +supereq vorbis wavpack zip"
REQUIRED_USE="
- || ( alsa oss pulseaudio nullout )
+ || ( alsa oss pulseaudio pipewire nullout )
"
DEPEND="
- x11-libs/gtk+:3
- net-misc/curl:0=
+ >=app-accessibility/at-spi2-core-2.46.0
+ dev-libs/glib:2
dev-libs/jansson:=
+ dev-libs/libdispatch
+ net-misc/curl
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
aac? ( media-libs/faad2 )
alsa? ( media-libs/alsa-lib )
cdda? (
- dev-libs/libcdio:0=
+ dev-libs/libcdio:=
media-libs/libcddb
- dev-libs/libcdio-paranoia:0=
+ media-sound/cdparanoia
)
cover? ( media-libs/imlib2[jpeg,png] )
dts? ( media-libs/libdca )
- ffmpeg? ( media-video/ffmpeg )
+ ffmpeg? ( media-video/ffmpeg:= )
flac? (
- media-libs/flac
+ media-libs/flac:=
media-libs/libogg
)
- mp3? ( media-sound/mpg123 )
+ libsamplerate? ( media-libs/libsamplerate )
+ mp3? ( media-sound/mpg123-base )
musepack? ( media-sound/musepack-tools )
nls? ( virtual/libintl )
- notify? (
- sys-apps/dbus
- dev-libs/libdispatch
- )
- opus? ( media-libs/opusfile )
- pulseaudio? ( media-sound/pulseaudio )
+ notify? ( sys-apps/dbus )
+ opus? ( media-libs/opusfile )
+ pulseaudio? ( media-libs/libpulse )
+ pipewire? ( media-video/pipewire:= )
vorbis? ( media-libs/libvorbis )
wavpack? ( media-sound/wavpack )
- lastfm? ( dev-libs/libdispatch )
+ zip? ( dev-libs/libzip:= )
"
RDEPEND="${DEPEND}"
BDEPEND="
dev-util/intltool
- sys-devel/gettext
sys-devel/clang
+ >=sys-devel/gettext-0.21
sys-devel/llvm
virtual/pkgconfig
"
PATCHES=(
- "${FILESDIR}/deadbeef-use-ffmpeg-plugin-for-ape-by-default.patch"
+ "${FILESDIR}"/${PN}-1.9.6-drop-Werror.patch
+ "${FILESDIR}"/${PN}-1.9.6-update-gettext.patch
+ "${FILESDIR}"/${PN}-1.9.6-fix-desktop-launcher.patch
)
src_prepare() {
@@ -75,9 +84,10 @@ src_prepare() {
}
drop_and_stub() {
- rm -rf "${1}"
- mkdir "${1}"
- cat > "${1}/Makefile.in" <<-EOF
+ einfo drop_and_stub "${1}"
+ rm -r "${1}" || die
+ mkdir "${1}" || die
+ cat > "${1}/Makefile.in" <<-EOF || die
all: nothing
install: nothing
nothing:
@@ -89,7 +99,7 @@ src_prepare() {
eautopoint --force
eautoreconf
- # Get rid of bundled gettext.
+ # Get rid of bundled gettext. (Avoid build failures with musl)
drop_and_stub "${S}/intl"
# Plugins that are undesired for whatever reason, candidates for unbundling and such.
@@ -97,7 +107,7 @@ src_prepare() {
drop_and_stub "${S}/plugins/${i}"
done
- rm -rf "${S}/plugins/rg_scanner/ebur128"
+ rm -r "${S}/plugins/rg_scanner/ebur128" || die
}
src_configure () {
@@ -116,7 +126,6 @@ src_configure () {
tc-export CC CXX LD AR NM OBJDUMP RANLIB PKG_CONFIG
local myconf=(
- "--disable-static"
"--disable-staticlink"
"--disable-portable"
"--disable-rpath"
@@ -137,9 +146,7 @@ src_configure () {
"--disable-sid"
"--disable-sndfile"
"--disable-soundtouch"
- "--disable-src"
"--disable-tta"
- "--disable-vfs-zip"
"--disable-vtx"
"--disable-wildmidi"
"--disable-wma"
@@ -151,14 +158,12 @@ src_configure () {
"$(use_enable mp3 libmpg123)"
"$(use_enable nls)"
"$(use_enable vorbis)"
- "$(use_enable threads)"
"$(use_enable flac)"
"$(use_enable supereq)"
"$(use_enable cdda)"
"$(use_enable cdda cdda-paranoia)"
"$(use_enable aac)"
"$(use_enable cover artwork)"
- "$(use_enable cover artwork-imlib2)"
"$(use_enable cover artwork-network)"
"$(use_enable dts dca)"
"$(use_enable ffmpeg)"
@@ -168,11 +173,15 @@ src_configure () {
"$(use_enable nullout)"
"$(use_enable opus)"
"$(use_enable pulseaudio pulse)"
+ "$(use_enable pipewire)"
"$(use_enable sc68)"
"$(use_enable shellexec)"
"$(use_enable shellexec shellexecui)"
"$(use_enable lastfm lfm)"
+ "$(use_enable libretro)"
+ "$(use_enable libsamplerate src)"
"$(use_enable wavpack)"
+ "$(use_enable zip vfs-zip)"
"--enable-gtk3"
"--enable-vfs-curl"
@@ -188,4 +197,7 @@ src_install() {
default
find "${ED}" -name '*.la' -delete || die
+
+ # if compressed, help doesn't work
+ docompress -x /usr/share/doc/${PF}
}
diff --git a/media-sound/deadbeef/files/deadbeef-1.9.6-drop-Werror.patch b/media-sound/deadbeef/files/deadbeef-1.9.6-drop-Werror.patch
new file mode 100644
index 000000000000..f31e079d942b
--- /dev/null
+++ b/media-sound/deadbeef/files/deadbeef-1.9.6-drop-Werror.patch
@@ -0,0 +1,35 @@
+Remove -Werror
+
+See also: https://devmanual.gentoo.org/ebuild-writing/common-mistakes/index.html#-werror-compiler-flag-not-removed
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -337,7 +337,7 @@ AS_IF([test "${have_iconv}" = "yes"], [
+ AC_DEFINE(HAVE_LIBICONV,1,[Use libiconv instead of glibc iconv])
+ ])
+
+-AX_CHECK_COMPILER_FLAGS(-msse2, HAVE_SSE2=1, [], -Werror)
++AX_CHECK_COMPILER_FLAGS(-msse2, HAVE_SSE2=1, [])
+ AS_IF([test "${HAVE_SSE2}"], [
+ AC_DEFINE(HAVE_SSE2,1,[Support SSE2 instructions])
+ ])
+--- a/plugins/gtkui/Makefile.am
++++ b/plugins/gtkui/Makefile.am
+@@ -94,7 +94,7 @@
+
+ ddb_gui_GTK2_la_LIBADD = $(LDADD) $(GTK2_DEPS_LIBS) $(SM_LIBADD) ../libparser/libparser.la ../../shared/libtrkpropertiesutil.la ../../shared/libeqpreset.la ../../shared/libdeletefromdisk.la ../../shared/libtftintutil.la ../../shared/analyzer/libanalyzer.la ../../shared/scope/libscope.la $(JANSSON_LIBS) $(DISPATCH_LIBS)
+
+-ddb_gui_GTK2_la_CFLAGS = -std=c99 -Werror -DGLIB_DISABLE_DEPRECATION_WARNINGS -DGDK_DISABLE_DEPRECATION_WARNINGS -DGTK_DISABLE_DEPRECATION_WARNINGS $(GTK2_DEPS_CFLAGS) $(SM_CFLAGS) $(JANSSON_CFLAGS) $(DISPATCH_CFLAGS) -I@top_srcdir@/include -DDDB_WARN_DEPRECATED=1
++ddb_gui_GTK2_la_CFLAGS = -std=c99 -DGLIB_DISABLE_DEPRECATION_WARNINGS -DGDK_DISABLE_DEPRECATION_WARNINGS -DGTK_DISABLE_DEPRECATION_WARNINGS $(GTK2_DEPS_CFLAGS) $(SM_CFLAGS) $(JANSSON_CFLAGS) $(DISPATCH_CFLAGS) -I@top_srcdir@/include -DDDB_WARN_DEPRECATED=1
+
+ endif
+
+@@ -105,7 +105,7 @@
+
+ ddb_gui_GTK3_la_SOURCES = $(GTKUI_SOURCES_GTK3)
+ ddb_gui_GTK3_la_LIBADD = $(LDADD) $(GTK3_DEPS_LIBS) $(SM_LIBADD) ../libparser/libparser.la ../../shared/libtrkpropertiesutil.la ../../shared/libeqpreset.la ../../shared/libdeletefromdisk.la ../../shared/libtftintutil.la ../../shared/analyzer/libanalyzer.la ../../shared/scope/libscope.la $(JANSSON_LIBS) $(DISPATCH_LIBS)
+-ddb_gui_GTK3_la_CFLAGS = -std=c99 -Werror -DGLIB_DISABLE_DEPRECATION_WARNINGS -DGDK_DISABLE_DEPRECATION_WARNINGS -DGTK_DISABLE_DEPRECATION_WARNINGS $(GTK3_DEPS_CFLAGS) $(SM_CFLAGS) $(JANSSON_CFLAGS) $(DISPATCH_CFLAGS) -I@top_srcdir@/include -DDDB_WARN_DEPRECATED=1
++ddb_gui_GTK3_la_CFLAGS = -std=c99 -DGLIB_DISABLE_DEPRECATION_WARNINGS -DGDK_DISABLE_DEPRECATION_WARNINGS -DGTK_DISABLE_DEPRECATION_WARNINGS $(GTK3_DEPS_CFLAGS) $(SM_CFLAGS) $(JANSSON_CFLAGS) $(DISPATCH_CFLAGS) -I@top_srcdir@/include -DDDB_WARN_DEPRECATED=1
+ ddb_gui_GTK3_la_OBJCFLAGS = $(GTK3_DEPS_CFLAGS) $(SM_CFLAGS) $(JANSSON_CFLAGS)
+
+ nodist_ddb_gui_GTK3_la_SOURCES = gtkui-gresources.c
diff --git a/media-sound/deadbeef/files/deadbeef-1.9.6-fix-desktop-launcher.patch b/media-sound/deadbeef/files/deadbeef-1.9.6-fix-desktop-launcher.patch
new file mode 100644
index 000000000000..235f5d5935de
--- /dev/null
+++ b/media-sound/deadbeef/files/deadbeef-1.9.6-fix-desktop-launcher.patch
@@ -0,0 +1,32 @@
+Fix QA issue about malformed desktop launcher.
+
+ * QA Notice: This package installs one or more .desktop files that do not
+ * pass validation.
+ *
+ * /usr/share/applications/deadbeef.desktop: error: action group "Desktop Action Next" exists, but there is no matching action "Next"
+ * /usr/share/applications/deadbeef.desktop: error: action group "Desktop Action Prev" exists, but there is no matching action "Prev"
+ * /usr/share/applications/deadbeef.desktop: error: action group "Desktop Action Stop" exists, but there is no matching action "Stop"
+ * /usr/share/applications/deadbeef.desktop: error: file contains group "Desktop Action Toggle Pause", which has an invalid action identifier, only alphanumeric characters and '-' are allowed
+ * /usr/share/applications/deadbeef.desktop: error: value "Play;Pause;Toggle Pause;Stop;Next;Prev;" for key "Actions" in group "Desktop Entry" contains invalid action identifier "Toggle Pause", only alphanumeric characters and '-' are allowed
+ *
+
+--- a/deadbeef.desktop.in
++++ b/deadbeef.desktop.in
+@@ -14,7 +14,7 @@
+ Icon=deadbeef
+ Exec=deadbeef %F
+ Terminal=false
+-Actions=Play;Pause;Toggle Pause;Stop;Next;Prev;
++Actions=Play;Pause;Toggle-Pause;Stop;Next;Prev;
+ MimeType=application/ogg;audio/x-vorbis+ogg;application/x-ogg;audio/mp3;audio/prs.sid;audio/x-flac;audio/mpeg;audio/x-mpeg;audio/x-mod;audio/x-it;audio/x-s3m;audio/x-xm;audio/x-mpegurl;audio/x-scpls;application/x-cue;
+ Categories=Audio;AudioVideo;Player;GTK;
+ Keywords=Sound;Music;Audio;Player;Musicplayer;MP3;
+@@ -35,7 +35,7 @@
+ Name[zh_TW]=暫停
+ Exec=deadbeef --pause
+
+-[Desktop Action Toggle Pause]
++[Desktop Action Toggle-Pause]
+ Name=Toggle Pause
+ Name[zh_CN]=播放/暂停
+ Name[zh_TW]=播放/暫停
diff --git a/media-sound/deadbeef/files/deadbeef-1.9.6-update-gettext.patch b/media-sound/deadbeef/files/deadbeef-1.9.6-update-gettext.patch
new file mode 100644
index 000000000000..48c0f0433eac
--- /dev/null
+++ b/media-sound/deadbeef/files/deadbeef-1.9.6-update-gettext.patch
@@ -0,0 +1,17 @@
+Update to a newer gettext to fix clang issues
+
+See also: https://bugs.gentoo.org/908414
+See also: https://github.com/gentoo/gentoo/pull/32491
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,8 +17,8 @@ AC_SYS_LARGEFILE
+ dnl AC_PROG_LIBTOOL
+ AC_CONFIG_MACRO_DIR([m4])
+ AC_C_BIGENDIAN
+-AM_GNU_GETTEXT
+-AM_GNU_GETTEXT_VERSION([0.18])
++AM_GNU_GETTEXT([external])
++AM_GNU_GETTEXT_REQUIRE_VERSION([0.21])
+ PKG_PROG_PKG_CONFIG
+ AM_PROG_CC_C_O
+ AM_ICONV
diff --git a/media-sound/deadbeef/files/deadbeef-use-ffmpeg-plugin-for-ape-by-default.patch b/media-sound/deadbeef/files/deadbeef-use-ffmpeg-plugin-for-ape-by-default.patch
deleted file mode 100644
index 82a979a5c179..000000000000
--- a/media-sound/deadbeef/files/deadbeef-use-ffmpeg-plugin-for-ape-by-default.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/plugins/ffmpeg/ffmpeg.c b/plugins/ffmpeg/ffmpeg.c
-index da137069a..43cdcb301 100644
---- a/plugins/ffmpeg/ffmpeg.c
-+++ b/plugins/ffmpeg/ffmpeg.c
-@@ -75,7 +75,7 @@
- static DB_decoder_t plugin;
- static DB_functions_t *deadbeef;
-
--#define DEFAULT_EXTS "aa3;oma;ac3;vqf;amr;tak;dsf;dff;wma;3gp;mp4;m4a"
-+#define DEFAULT_EXTS "aa3;oma;ac3;vqf;amr;tak;dsf;dff;wma;3gp;mp4;m4a;ape"
- #define UNPOPULATED_EXTS_BY_FFMPEG \
- "aif,aiff,afc,aifc,amr,asf," \
- "wmv,wma,au,caf,webm," \
diff --git a/media-sound/deadbeef/metadata.xml b/media-sound/deadbeef/metadata.xml
index 8d086b986004..202ef7ecef3f 100644
--- a/media-sound/deadbeef/metadata.xml
+++ b/media-sound/deadbeef/metadata.xml
@@ -2,19 +2,23 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>slashbeast@gentoo.org</email>
- <name>Piotr Karbowski</name>
+ <email>ceamac@gentoo.org</email>
+ <name>Viorel Munteanu</name>
</maintainer>
<upstream>
<remote-id type="github">DeaDBeeF-Player/deadbeef</remote-id>
+ <remote-id type="sourceforge">deadbeef</remote-id>
</upstream>
<use>
<flag name="converter">File format converter</flag>
<flag name="cover">Support for cover art</flag>
<flag name="hotkeys">Keyboard shortcuts support</flag>
<flag name="lastfm">last.fm/AudioScrobbler protocol support</flag>
+ <flag name="libretro">libretro resampling plugin</flag>
+ <flag name="libsamplerate">Support the Secret Rabbit Code resampler</flag>
<flag name="notify">Desktop notifications support</flag>
<flag name="nullout">Dummy output driver</flag>
+ <flag name="pipewire">Pipewire output plugin</flag>
<flag name="sc68">Atari ST and Amiga music player</flag>
<flag name="shellexec">Define custom shell commands that can be called on tracks</flag>
<flag name="supereq">Enable equalizer</flag>