summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-08-10 18:39:11 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-08-10 18:39:11 +0200
commitafdee627b5077b5697b7e9fd001c56a1c84e4c8f (patch)
treeffe419a3950d16fe1214aa350cb21933a0243d4f /media-sound/pamix/pamix-1.1.ebuild
parentdev-perl/Test-Warn: ALLARCHES stable wrt bug #585502 (diff)
downloadgentoo-afdee627b5077b5697b7e9fd001c56a1c84e4c8f.tar.gz
gentoo-afdee627b5077b5697b7e9fd001c56a1c84e4c8f.tar.bz2
gentoo-afdee627b5077b5697b7e9fd001c56a1c84e4c8f.zip
media-sound/pamix: Initial commit (bug #590728).
Thanks to Joshua Jensch for the bug report and the ebuild work. Package-Manager: portage-2.3.0 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-sound/pamix/pamix-1.1.ebuild')
-rw-r--r--media-sound/pamix/pamix-1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-sound/pamix/pamix-1.1.ebuild b/media-sound/pamix/pamix-1.1.ebuild
new file mode 100644
index 000000000000..986dad71c324
--- /dev/null
+++ b/media-sound/pamix/pamix-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+[[ "${PV}" == 9999 ]] && inherit git-r3
+
+DESCRIPTION="A PulseAudio NCurses mixer"
+HOMEPAGE="https://github.com/patroclos/PAmix"
+LICENSE="MIT"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/patroclos/PAmix.git"
+else
+ SRC_URI="https://github.com/patroclos/PAmix/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/PAmix-${PV}"
+fi
+
+RDEPEND="media-sound/pulseaudio
+ sys-libs/ncurses:0=[unicode]"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_unpack() {
+ [[ "${PV}" == 9999 ]] && git-r3_src_unpack
+ default
+}