summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch18
-rw-r--r--net-analyzer/hexinject/hexinject-1.6-r1.ebuild36
2 files changed, 54 insertions, 0 deletions
diff --git a/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch b/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
new file mode 100644
index 000000000000..fbe91199bbfa
--- /dev/null
+++ b/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
@@ -0,0 +1,18 @@
+Author: holgersson <holgersson@posteo.de>
+Date: Fri Oct 20 18:30:00 2017 +0200
+
+Don’t call gcc directly, and respect CFLAGS. As this project
+is plain C I don’t care fore CXXFLAGS here.
+
+--- a/Makefile 2017-10-20 18:15:11.743805540 +0200
++++ b/Makefile 2017-10-20 18:24:55.120009439 +0200
+@@ -1,6 +1,6 @@
+-CC = gcc
+-CFLAGS = -Wall
+-LDFLAGS = -lpcap
++CC ?= gcc
++CFLAGS += -Wall
++LDFLAGS = -lpcap
+
+ all:
+ $(CC) $(CFLAGS) $(LDFLAGS) -o hexinject hexinject.c
diff --git a/net-analyzer/hexinject/hexinject-1.6-r1.ebuild b/net-analyzer/hexinject/hexinject-1.6-r1.ebuild
new file mode 100644
index 000000000000..e36c1803461e
--- /dev/null
+++ b/net-analyzer/hexinject/hexinject-1.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Network packet sniffer and injector"
+HOMEPAGE="http://hexinject.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools experimental"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ experimental? ( dev-lang/tcl )"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6-fix-build-system.patch )
+
+src_configure() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ dobin hexinject
+ use tools && dobin hex2raw prettypacket
+ use experimental && dobin packets.tcl
+ einstalldocs
+}