summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/wireshark-3.2.3.ebuild7
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/wireshark-3.2.3.ebuild b/net-analyzer/wireshark/wireshark-3.2.3.ebuild
index a09e19cba2a7..032bafbb15ba 100644
--- a/net-analyzer/wireshark/wireshark-3.2.3.ebuild
+++ b/net-analyzer/wireshark/wireshark-3.2.3.ebuild
@@ -17,7 +17,7 @@ IUSE="
+dumpcap +editcap http2 kerberos libxml2 lua lz4 maxminddb +mergecap
+minizip +netlink +plugins plugin-ifdemo +pcap +qt5 +randpkt +randpktdump
+reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
- +text2pcap tfshark +tshark +udpdump zlib +zstd
+ test +text2pcap tfshark +tshark +udpdump zlib +zstd
"
S=${WORKDIR}/${P/_/}
@@ -74,6 +74,10 @@ BDEPEND="
qt5? (
dev-qt/linguist-tools:5
)
+ test? (
+ dev-python/pytest
+ dev-python/pytest-xdist
+ )
"
RDEPEND="
${CDEPEND}
@@ -174,6 +178,7 @@ src_configure() {
}
src_test() {
+ cmake_build test-programs
cmake_src_test
}
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 6f9470ca6ee5..86206f1ead23 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -17,7 +17,7 @@ IUSE="
+dumpcap +editcap http2 kerberos libxml2 lua lz4 maxminddb +mergecap
+minizip +netlink +plugins plugin-ifdemo +pcap +qt5 +randpkt +randpktdump
+reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
- +text2pcap tfshark +tshark +udpdump zlib
+ test +text2pcap tfshark +tshark +udpdump zlib
"
S=${WORKDIR}/${P/_/}
@@ -73,6 +73,10 @@ BDEPEND="
qt5? (
dev-qt/linguist-tools:5
)
+ test? (
+ dev-python/pytest
+ dev-python/pytest-xdist
+ )
"
RDEPEND="
${CDEPEND}
@@ -168,6 +172,7 @@ src_configure() {
}
src_test() {
+ cmake_build test-programs
cmake_src_test
}