summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/gazebo')
-rw-r--r--sci-electronics/gazebo/files/boost.patch49
-rw-r--r--sci-electronics/gazebo/files/gv10.patch45
-rw-r--r--sci-electronics/gazebo/gazebo-11.14.0.ebuild4
3 files changed, 97 insertions, 1 deletions
diff --git a/sci-electronics/gazebo/files/boost.patch b/sci-electronics/gazebo/files/boost.patch
new file mode 100644
index 000000000000..56f26387c58c
--- /dev/null
+++ b/sci-electronics/gazebo/files/boost.patch
@@ -0,0 +1,49 @@
+From 6b4d0f0b94cb2d98e6a48970c1c128e9b4f13e47 Mon Sep 17 00:00:00 2001
+From: Steve Peters <scpeters@openrobotics.org>
+Date: Fri, 10 May 2024 15:39:02 +0200
+Subject: [PATCH 1/2] Fix build with boost 1.85.0
+
+Signed-off-by: Steve Peters <scpeters@openrobotics.org>
+---
+ gazebo/common/Console.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gazebo/common/Console.cc b/gazebo/common/Console.cc
+index 6b86bc2d02..bb4dbe3180 100644
+--- a/gazebo/common/Console.cc
++++ b/gazebo/common/Console.cc
+@@ -221,7 +221,7 @@ void FileLogger::Init(const std::string &_prefix, const std::string &_filename)
+ if (boost::filesystem::is_directory(logPath))
+ this->logDirectory = logPath.string();
+ else
+- this->logDirectory = logPath.branch_path().string();
++ this->logDirectory = logPath.parent_path().string();
+ }
+
+ /////////////////////////////////////////////////
+
+From 27c2277a2376f9d82755e975ae8b564d9d6ca6ed Mon Sep 17 00:00:00 2001
+From: Steve Peters <scpeters@openrobotics.org>
+Date: Fri, 10 May 2024 17:43:32 +0200
+Subject: [PATCH 2/2] Fix build error in LogPlay.cc as well
+
+Signed-off-by: Steve Peters <scpeters@openrobotics.org>
+---
+ gazebo/util/LogPlay.cc | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/gazebo/util/LogPlay.cc b/gazebo/util/LogPlay.cc
+index 70cfcc3346..be00820edb 100644
+--- a/gazebo/util/LogPlay.cc
++++ b/gazebo/util/LogPlay.cc
+@@ -414,8 +414,8 @@ common::Time LogPlay::LogEndTime() const
+ /////////////////////////////////////////////////
+ std::string LogPlay::Filename() const
+ {
+- return boost::filesystem::basename(this->dataPtr->filename) +
+- boost::filesystem::extension(this->dataPtr->filename);
++ boost::filesystem::path path(this->dataPtr->filename);
++ return path.stem().string() + path.extension().string();
+ }
+
+ /////////////////////////////////////////////////
diff --git a/sci-electronics/gazebo/files/gv10.patch b/sci-electronics/gazebo/files/gv10.patch
new file mode 100644
index 000000000000..f3ab5eb1e686
--- /dev/null
+++ b/sci-electronics/gazebo/files/gv10.patch
@@ -0,0 +1,45 @@
+From 660ae15f4af1f5ea8d9d50d4a24e4d91a94f9c2d Mon Sep 17 00:00:00 2001
+From: Steve Peters <scpeters@openrobotics.org>
+Date: Tue, 20 Feb 2024 17:25:23 -0800
+Subject: [PATCH] Fix build with graphviz 10.0
+
+Replace TRUE with 1, since the TRUE macro has been removed.
+
+Signed-off-by: Steve Peters <scpeters@openrobotics.org>
+---
+ gazebo/gui/qgv/QGVSubGraph.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/gazebo/gui/qgv/QGVSubGraph.cpp b/gazebo/gui/qgv/QGVSubGraph.cpp
+index 51925aba30..c16b69d065 100644
+--- a/gazebo/gui/qgv/QGVSubGraph.cpp
++++ b/gazebo/gui/qgv/QGVSubGraph.cpp
+@@ -44,13 +44,13 @@ QString QGVSubGraph::name() const
+
+ QGVNode *QGVSubGraph::addNode(const QString &label)
+ {
+- Agnode_t *node = agnode(_sgraph->graph(), NULL, TRUE);
++ Agnode_t *node = agnode(_sgraph->graph(), NULL, 1);
+ if (node == NULL)
+ {
+ qWarning()<<"Invalid sub node :"<<label;
+ return 0;
+ }
+- agsubnode(_sgraph->graph(), node, TRUE);
++ agsubnode(_sgraph->graph(), node, 1);
+
+ QGVNode *item = new QGVNode(new QGVNodePrivate(node), _scene);
+ item->setLabel(label);
+@@ -66,10 +66,10 @@ QGVSubGraph *QGVSubGraph::addSubGraph(const QString &_name, bool cluster)
+ if (cluster)
+ {
+ sgraph = agsubg(_sgraph->graph(),
+- ("cluster_" + _name).toLocal8Bit().data(), TRUE);
++ ("cluster_" + _name).toLocal8Bit().data(), 1);
+ }
+ else
+- sgraph = agsubg(_sgraph->graph(), _name.toLocal8Bit().data(), TRUE);
++ sgraph = agsubg(_sgraph->graph(), _name.toLocal8Bit().data(), 1);
+
+ if (sgraph == NULL)
+ {
diff --git a/sci-electronics/gazebo/gazebo-11.14.0.ebuild b/sci-electronics/gazebo/gazebo-11.14.0.ebuild
index 0a321f61f496..04caee69b302 100644
--- a/sci-electronics/gazebo/gazebo-11.14.0.ebuild
+++ b/sci-electronics/gazebo/gazebo-11.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -65,6 +65,8 @@ CMAKE_BUILD_TYPE=RelWithDebInfo
PATCHES=(
"${FILESDIR}/qwt2.patch"
"${FILESDIR}/cmake.patch"
+ "${FILESDIR}/gv10.patch"
+ "${FILESDIR}/boost.patch"
)
src_configure() {