summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/kicad/files')
-rw-r--r--sci-electronics/kicad/files/kicad-5.1.5-algorithm-header.patch11
-rw-r--r--sci-electronics/kicad/files/kicad-5.1.6-ninja-build.patch45
2 files changed, 0 insertions, 56 deletions
diff --git a/sci-electronics/kicad/files/kicad-5.1.5-algorithm-header.patch b/sci-electronics/kicad/files/kicad-5.1.5-algorithm-header.patch
deleted file mode 100644
index aa118ea6f860..000000000000
--- a/sci-electronics/kicad/files/kicad-5.1.5-algorithm-header.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur kicad-5.1.5-orig/common/lib_tree_model.cpp kicad-5.1.5/common/lib_tree_model.cpp
---- kicad-5.1.5-orig/common/lib_tree_model.cpp 2020-05-11 00:36:36.568301297 +0200
-+++ kicad-5.1.5/common/lib_tree_model.cpp 2020-05-11 00:37:50.472359703 +0200
-@@ -21,6 +21,7 @@
-
- #include <lib_tree_model.h>
-
-+#include <algorithm>
- #include <eda_pattern_match.h>
- #include <lib_tree_item.h>
- #include <make_unique.h>
diff --git a/sci-electronics/kicad/files/kicad-5.1.6-ninja-build.patch b/sci-electronics/kicad/files/kicad-5.1.6-ninja-build.patch
deleted file mode 100644
index baff144fbd85..000000000000
--- a/sci-electronics/kicad/files/kicad-5.1.6-ninja-build.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Naur kicad-5.1.6-orig/pcbnew/CMakeLists.txt kicad-5.1.6/pcbnew/CMakeLists.txt
---- kicad-5.1.6-orig/pcbnew/CMakeLists.txt 2020-05-11 11:27:08.000000000 -0700
-+++ kicad-5.1.6/pcbnew/CMakeLists.txt 2020-05-25 20:57:03.387859088 -0700
-@@ -805,11 +805,7 @@
- add_dependencies( ScriptingModulesPcbnewSoCopy ScriptingPythonDirectoryCreation )
- set( PYMOD_EXT "so" )
- else() # only linux remains among supported platforms
-- add_library( pcbnew_python MODULE $<TARGET_OBJECTS:pcbnew_kiface_objects> )
-- target_link_libraries( pcbnew_python ${PCBNEW_KIFACE_LIBRARIES} )
-- set_target_properties( pcbnew_python PROPERTIES OUTPUT_NAME pcbnew PREFIX "_" SUFFIX ".so" )
-- install( TARGETS pcbnew_python DESTINATION ${PYTHON_DEST} COMPONENT binary )
--
-+ install( FILES ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.kiface DESTINATION ${PYTHON_DEST} COMPONENT binary RENAME "_pcbnew.so" )
- set( PYMOD_EXT "so" )
- endif()
-
-@@ -824,18 +820,16 @@
- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
- )
- else()
--
--
-- # For phase 1, copy _pcbnew.kiface to the python module.
-- add_custom_command( OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
-- DEPENDS pcbnew_kiface
-- COMMAND ${CMAKE_COMMAND} -E copy _pcbnew.kiface _pcbnew.${PYMOD_EXT}
-- COMMENT "Creating python's pcbnew native module _pcbnew.${PYMOD_EXT} for command line use."
-- )
-- add_custom_target(
-- pcbnew_python_module ALL
-- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
-- )
-+ # For phase 1, copy _pcbnew.kiface to the python module.
-+ add_custom_command( OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
-+ DEPENDS pcbnew_kiface
-+ COMMAND ${CMAKE_COMMAND} -E copy _pcbnew.kiface _pcbnew.${PYMOD_EXT}
-+ COMMENT "Creating python's pcbnew native module _pcbnew.${PYMOD_EXT} for command line use."
-+ )
-+ add_custom_target(
-+ pcbnew_python_module ALL
-+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
-+ )
- endif()
-
- endif()