summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/vbs/vbs-1.4.0.ebuild')
-rw-r--r--sci-electronics/vbs/vbs-1.4.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-electronics/vbs/vbs-1.4.0.ebuild b/sci-electronics/vbs/vbs-1.4.0.ebuild
new file mode 100644
index 000000000000..913aebb2565c
--- /dev/null
+++ b/sci-electronics/vbs/vbs-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils
+
+HOMEPAGE="http://www.geda.seul.org/tools/vbs/index.html"
+DESCRIPTION="vbs - the Verilog Behavioral Simulator"
+SRC_URI="http://www.geda.seul.org/dist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="examples"
+KEYWORDS="~amd64 ppc ~x86"
+
+DEPEND=">=sys-devel/flex-2.3
+ >=sys-devel/bison-1.22"
+RDEPEND=""
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc-4.1.patch"
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+ sed -i -e "s/strrchr(n,'.')/const_cast<char*>(strrchr(n,'.'))/" common/scp_tab.cc || die "sed failed"
+}
+
+src_compile() {
+ emake -j1 vbs || die "Compilation failed"
+}
+
+src_install() {
+ dobin vbs
+ cd ..
+ dodoc BUGS CHANGELOG* CONTRIBUTORS COPYRIGHT FAQ README vbs.txt
+ if use examples ; then
+ insinto /usr/share/${PF}/examples
+ doins EXAMPLES/*
+ fi
+}