summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/coinor-bcp')
-rw-r--r--sci-libs/coinor-bcp/Manifest1
-rw-r--r--sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild59
-rw-r--r--sci-libs/coinor-bcp/metadata.xml13
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-libs/coinor-bcp/Manifest b/sci-libs/coinor-bcp/Manifest
new file mode 100644
index 000000000000..e22e8cdb1040
--- /dev/null
+++ b/sci-libs/coinor-bcp/Manifest
@@ -0,0 +1 @@
+DIST Bcp-1.3.8.tgz 7086225 SHA256 db0079ba8adc16ca0a3065b385bf27352a27a9e031e8db52e96b4f883d4352f4 SHA512 c599cc60df37cab32cfbf24522efaababbdd2de6144c316390f5e0481863ffd6aec016f97188a610ae6aca8d4e5b1b8088a35bc81bd3448fadb1727a9e9663dd WHIRLPOOL 4bdc2a99bff6ed5b71a978feb224a1c2624b0519e0149b37fbd97c142c617502e46b8bbb9cf3516ebe4bf56c1c29e9cedf6bdcf52d08433fe2f20c7dfe5541b6
diff --git a/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild b/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
new file mode 100644
index 000000000000..13bc2678c6af
--- /dev/null
+++ b/sci-libs/coinor-bcp/coinor-bcp-1.3.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+MYPN=Bcp
+
+DESCRIPTION="COIN-OR Branch-Cut-Price Framework"
+HOMEPAGE="https://projects.coin-or.org/Bcp/"
+SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
+
+LICENSE="CPL-1.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs test"
+
+RDEPEND="
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-vol:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( sci-libs/coinor-sample )"
+
+S="${WORKDIR}/${MYPN}-${PV}/${MYPN}"
+
+src_prepare() {
+ # needed for the --with-coin-instdir
+ dodir /usr
+ sed -i \
+ -e "s:lib/pkgconfig:$(get_libdir)/pkgconfig:g" \
+ configure || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-dependency-linking
+ --with-coin-instdir="${ED}"/usr
+ $(use_with doc dot)
+ )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test test
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && newdoc doc/man.pdf manual.pdf
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/sci-libs/coinor-bcp/metadata.xml b/sci-libs/coinor-bcp/metadata.xml
new file mode 100644
index 000000000000..733700021f6b
--- /dev/null
+++ b/sci-libs/coinor-bcp/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ BCP is a parallel framework for implementing branch, cut, and price
+ algorithms for solving mixed integer programs (MIPs). BCP provides
+ the user with an object-oriented framework that can be used to
+ develop an efficient problem class specific MIP solver without all
+ the implementational effort. involved with implementing a branch and
+ bound framework from scratch.
+</longdescription>
+</pkgmetadata>