summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/make/Manifest1
-rw-r--r--sys-devel/make/files/make-4.1-fix_null_returns_from_ttyname.patch53
-rw-r--r--sys-devel/make/make-4.1-r1.ebuild46
-rw-r--r--sys-devel/make/make-4.2.1-r2.ebuild57
-rw-r--r--sys-devel/make/make-4.2.1.ebuild50
5 files changed, 0 insertions, 207 deletions
diff --git a/sys-devel/make/Manifest b/sys-devel/make/Manifest
index a83ec28d8dc7..7ce526e76cae 100644
--- a/sys-devel/make/Manifest
+++ b/sys-devel/make/Manifest
@@ -1,2 +1 @@
-DIST make-4.1.tar.bz2 1327342 BLAKE2B 4a93f893d219e2ac16a87f19de018f1d794a1f4c70c2a57dea52ccaa452b288bfbea0e422a880efcb457f666f41a40913a214e0feae4cc7edcebb8ec945bd72c SHA512 3fcaf06660b7a5019937b81ee69fe54cdfe0a24d66286fc5cc6a34fa996d76dfe6fd5bc49ee59b727ae2b24ddca261ada0fdb5873ba2b38dcc63647ad3cdb193
DIST make-4.2.1.tar.bz2 1407126 BLAKE2B fa6d43f5fd46182182a296c58dcd138a1a4568104eda760bbb3c241c023dee216789cf3128e5ac2b416cec76e1ba82d5b5e7852da12e86138a7d0865c85a42b4 SHA512 9cf00869a2f938492554f71d8cb288b5b009b3bd0489ef164f2c8f6532fc37db5c7e20af1dea288536e7c9710ee0bc6e1ddcdfc4928a8540e6e43661741825b8
diff --git a/sys-devel/make/files/make-4.1-fix_null_returns_from_ttyname.patch b/sys-devel/make/files/make-4.1-fix_null_returns_from_ttyname.patch
deleted file mode 100644
index f6be5c9f06af..000000000000
--- a/sys-devel/make/files/make-4.1-fix_null_returns_from_ttyname.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 292da6f6867b75a5af7ddbb639a1feae022f438f Mon Sep 17 00:00:00 2001
-From: Paul Smith <psmith@gnu.org>
-Date: Mon, 20 Oct 2014 05:54:56 +0000
-Subject: * main.c (main): [SV 43434] Handle NULL returns from ttyname().
-
----
-diff --git a/main.c b/main.c
-index b2d169c..0cdb8a8 100644
---- a/main.c
-+++ b/main.c
-@@ -1429,13 +1429,18 @@ main (int argc, char **argv, char **envp)
- #ifdef HAVE_ISATTY
- if (isatty (fileno (stdout)))
- if (! lookup_variable (STRING_SIZE_TUPLE ("MAKE_TERMOUT")))
-- define_variable_cname ("MAKE_TERMOUT", TTYNAME (fileno (stdout)),
-- o_default, 0)->export = v_export;
--
-+ {
-+ const char *tty = TTYNAME (fileno (stdout));
-+ define_variable_cname ("MAKE_TERMOUT", tty ? tty : DEFAULT_TTYNAME,
-+ o_default, 0)->export = v_export;
-+ }
- if (isatty (fileno (stderr)))
- if (! lookup_variable (STRING_SIZE_TUPLE ("MAKE_TERMERR")))
-- define_variable_cname ("MAKE_TERMERR", TTYNAME (fileno (stderr)),
-- o_default, 0)->export = v_export;
-+ {
-+ const char *tty = TTYNAME (fileno (stderr));
-+ define_variable_cname ("MAKE_TERMERR", tty ? tty : DEFAULT_TTYNAME,
-+ o_default, 0)->export = v_export;
-+ }
- #endif
-
- /* Reset in case the switches changed our minds. */
-diff --git a/makeint.h b/makeint.h
-index 6223936..2009f41 100644
---- a/makeint.h
-+++ b/makeint.h
-@@ -436,10 +436,11 @@ extern struct rlimit stack_limit;
- /* The number of bytes needed to represent the largest integer as a string. */
- #define INTSTR_LENGTH CSTRLEN ("18446744073709551616")
-
-+#define DEFAULT_TTYNAME "true"
- #ifdef HAVE_TTYNAME
- # define TTYNAME(_f) ttyname (_f)
- #else
--# define TTYNAME(_f) "true"
-+# define TTYNAME(_f) DEFAULT_TTYNAME
- #endif
-
-
---
-cgit v0.9.0.2
diff --git a/sys-devel/make/make-4.1-r1.ebuild b/sys-devel/make/make-4.1-r1.ebuild
deleted file mode 100644
index b893857aa79d..000000000000
--- a/sys-devel/make/make-4.1-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Standard tool to compile source trees"
-HOMEPAGE="https://www.gnu.org/software/make/make.html"
-SRC_URI="mirror://gnu//make/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="guile nls static"
-
-CDEPEND="guile? ( >=dev-scheme/guile-1.8 )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libintl )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch \
- "${FILESDIR}"/${P}-fix_null_returns_from_ttyname.patch
-}
-
-src_configure() {
- use static && append-ldflags -static
- econf \
- --program-prefix=g \
- $(use_with guile) \
- $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS README*
- if [[ ${USERLAND} == "GNU" ]] ; then
- # we install everywhere as 'gmake' but on GNU systems,
- # symlink 'make' to 'gmake'
- dosym gmake /usr/bin/make
- dosym gmake.1 /usr/share/man/man1/make.1
- fi
-}
diff --git a/sys-devel/make/make-4.2.1-r2.ebuild b/sys-devel/make/make-4.2.1-r2.ebuild
deleted file mode 100644
index c52a434b513b..000000000000
--- a/sys-devel/make/make-4.2.1-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="Standard tool to compile source trees"
-HOMEPAGE="https://www.gnu.org/software/make/make.html"
-SRC_URI="mirror://gnu//make/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="guile nls static"
-
-CDEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libintl )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
- "${FILESDIR}"/${PN}-4.2-default-cxx.patch
- "${FILESDIR}"/${PN}-4.2.1-perl526.patch
- "${FILESDIR}"/${PN}-4.2.1-glob-internals.patch
-)
-
-src_prepare() {
- default
- # This patch requires special handling as it modifies configure.ac
- # which in turn triggers maintainer-mode when being applied the
- # usual way.
- eapply -Z "${FILESDIR}"/${PN}-4.2.1-glob-v2.patch
-}
-
-src_configure() {
- use static && append-ldflags -static
- local myeconfargs=(
- --program-prefix=g
- $(use_with guile)
- $(use_enable nls)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS README*
- if [[ ${USERLAND} == "GNU" ]] ; then
- # we install everywhere as 'gmake' but on GNU systems,
- # symlink 'make' to 'gmake'
- dosym gmake /usr/bin/make
- dosym gmake.1 /usr/share/man/man1/make.1
- fi
-}
diff --git a/sys-devel/make/make-4.2.1.ebuild b/sys-devel/make/make-4.2.1.ebuild
deleted file mode 100644
index 807b071729f2..000000000000
--- a/sys-devel/make/make-4.2.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Standard tool to compile source trees"
-HOMEPAGE="https://www.gnu.org/software/make/make.html"
-SRC_URI="mirror://gnu//make/${P}.tar.bz2"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="guile nls static"
-
-CDEPEND="guile? ( >=dev-scheme/guile-1.8:= )"
-DEPEND="${CDEPEND}
- nls? ( sys-devel/gettext )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libintl )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.82-darwin-library_search-dylib.patch
- "${FILESDIR}"/${PN}-4.2.1-perl526.patch
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
- epatch_user
-}
-
-src_configure() {
- use static && append-ldflags -static
- econf \
- --program-prefix=g \
- $(use_with guile) \
- $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS NEWS README*
- if [[ ${USERLAND} == "GNU" ]] ; then
- # we install everywhere as 'gmake' but on GNU systems,
- # symlink 'make' to 'gmake'
- dosym gmake /usr/bin/make
- dosym gmake.1 /usr/share/man/man1/make.1
- fi
-}