summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/oroborus-desklaunch')
-rw-r--r--x11-misc/oroborus-desklaunch/Manifest1
-rw-r--r--x11-misc/oroborus-desklaunch/files/oroborus-desklaunch-1.1.7-gentoo.diff39
-rw-r--r--x11-misc/oroborus-desklaunch/metadata.xml9
-rw-r--r--x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild36
4 files changed, 85 insertions, 0 deletions
diff --git a/x11-misc/oroborus-desklaunch/Manifest b/x11-misc/oroborus-desklaunch/Manifest
new file mode 100644
index 000000000000..88ce9333cf0b
--- /dev/null
+++ b/x11-misc/oroborus-desklaunch/Manifest
@@ -0,0 +1 @@
+DIST desklaunch_1.1.8.tar.gz 14258 SHA256 8cb14b959f80ab119d9a420494c36d6fa80108d3a5febd98cdd76713a1b73dd3
diff --git a/x11-misc/oroborus-desklaunch/files/oroborus-desklaunch-1.1.7-gentoo.diff b/x11-misc/oroborus-desklaunch/files/oroborus-desklaunch-1.1.7-gentoo.diff
new file mode 100644
index 000000000000..a6d833bcfd3d
--- /dev/null
+++ b/x11-misc/oroborus-desklaunch/files/oroborus-desklaunch-1.1.7-gentoo.diff
@@ -0,0 +1,39 @@
+--- Makefile
++++ Makefile
+@@ -1,29 +1,26 @@
+-CC = gcc
+-CFLAGS = -g -O2 -Wall
+-XROOT = /usr/X11R6
+-INCLUDES = -I$(XROOT)/include
+-LIBS = -lX11 -lXext -lXpm
+-LDPATH = -L$(XROOT)/lib
++INCLUDES = `pkg-config --cflags x11 xext xpm`
++LIBS = `pkg-config --libs x11 xext xpm`
+
+-DESTDIR =
+ PROG = desklaunch
+ PREFIX = $(DESTDIR)/usr
++MANDIR = $(PREFIX)/share/man
+ RCFILE = .$(PROG)rc
+ DEFINES = -DRCFILE=\"$(RCFILE)\" #-DDEBUG
+
+ OBJS = $(PROG).o
++MAN = debian/$(PROG).1
+
+ all: $(PROG)
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) $(LIBS) -o $@
+
+ $(OBJS): %.o: %.c $(HEADERS)
+ $(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
+
+ install: all
+- install $(PROG) $(PREFIX)/bin
+- install -d $(PREFIX)/share/$(PROG)
++ install -D -m 755 $(PROG) $(PREFIX)/bin/$(PROG)
++ install -D -m 644 $(MAN) $(MANDIR)/man1/$(PROG).1
+
+ uninstall:
+ rm -f $(PREFIX)/bin/$(PROG)
diff --git a/x11-misc/oroborus-desklaunch/metadata.xml b/x11-misc/oroborus-desklaunch/metadata.xml
new file mode 100644
index 000000000000..1c8c12910925
--- /dev/null
+++ b/x11-misc/oroborus-desklaunch/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ DeskLaunch is a small utility for creating desktop icons using pixmaps.
+ A simple click will launch the desired application.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild b/x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild
new file mode 100644
index 000000000000..80128379d1c9
--- /dev/null
+++ b/x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_PN=${PN/oroborus-//}
+
+DESCRIPTION="utility for creating desktop icons for Oroborus"
+HOMEPAGE="http://www.oroborus.org"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ !x11-wm/oroborus-extras"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+DOCS=( README debian/changelog debian/example_rc )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.7-gentoo.diff
+}