summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines-xfce')
-rw-r--r--x11-themes/gtk-engines-xfce/Manifest2
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r200.ebuild32
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild46
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild32
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild47
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild46
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild48
-rw-r--r--x11-themes/gtk-engines-xfce/metadata.xml8
8 files changed, 261 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-xfce/Manifest b/x11-themes/gtk-engines-xfce/Manifest
new file mode 100644
index 000000000000..9655dad016a0
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/Manifest
@@ -0,0 +1,2 @@
+DIST gtk-xfce-engine-3.0.1.tar.bz2 369040 SHA256 eb03cf81da1a91e426a2141c092ed7a1634cab29ea2f3546480e901290a7a06d SHA512 0cd701cc485fcf7e112221c550f58078ca63773b0dd8c22d052b55564ad7954c721398735fbcf85b72f2b56ac5c65c1648522c1238fe97c274093d90f80af058 WHIRLPOOL e891fcde19fd6c27d42bbc72e34d0afa35c8050525b6affda587e9c3849bd70463da498012810a3aa99a25ad9129bc532bd93266ed8b0a0e1fe1cd166c5a87d3
+DIST gtk-xfce-engine-3.2.0.tar.bz2 376203 SHA256 875c9c3bda96faf050a2224649cc42129ffb662c4de33add8c0fd1fb860b47ed SHA512 c965e597c1b4aa04f3b474f3c4cea249aa6e753be697d5d3d7a19184adca650fc084f39acbd357f53eaf4180d96d5d3499866367e221ae445de4864fc9487012 WHIRLPOOL 782d44c560004e41433e40af692a99462280248c3dd4c3e1de154e1251b355c570cd27bdd8f3d4d39bc2e269f2348c7782aad931c0e7aa4c14d68c50fe0d52f7
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r200.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r200.ebuild
new file mode 100644
index 000000000000..ce61a04e18c8
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r200.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf
+
+DESCRIPTION="A port of Xfce engine to GTK+ 2.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild
new file mode 100644
index 000000000000..706d8527ac90
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r201.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 2.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ xfconf_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild
new file mode 100644
index 000000000000..5094a6dc0a0f
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf
+
+DESCRIPTION="A port of Xfce engine to GTK+ 3.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-3.2:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk2
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild
new file mode 100644
index 000000000000..05afd3f794bb
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r301.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 3.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.24[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r5
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk2
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ xfconf_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild
new file mode 100644
index 000000000000..e4739805db2f
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 2.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ xfconf_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild
new file mode 100644
index 000000000000..5caeb0276fcc
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 3.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.24[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r5
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk2
+ --enable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ xfconf_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}
diff --git a/x11-themes/gtk-engines-xfce/metadata.xml b/x11-themes/gtk-engines-xfce/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>