summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-15 22:31:15 +0100
committerUlrich Müller <ulm@gentoo.org>2014-02-15 22:31:15 +0100
commitd31433815314d021ce38f275b2cb88ebc55fa43d (patch)
treeff0d31ccd241c08c86ec2b9cfeceb0b31a1beb38 /app-editors/pemacs/pemacs-1.5_pre20130322.ebuild
parentRemove www-client category. (diff)
downloademacs-d31433815314d021ce38f275b2cb88ebc55fa43d.tar.gz
emacs-d31433815314d021ce38f275b2cb88ebc55fa43d.tar.bz2
emacs-d31433815314d021ce38f275b2cb88ebc55fa43d.zip
Initial import. Ebuild based on ersatz-emacs-20060515.ebuild, with modifications by me.
Package-Manager: portage-2.2.8-r1
Diffstat (limited to 'app-editors/pemacs/pemacs-1.5_pre20130322.ebuild')
-rw-r--r--app-editors/pemacs/pemacs-1.5_pre20130322.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-editors/pemacs/pemacs-1.5_pre20130322.ebuild b/app-editors/pemacs/pemacs-1.5_pre20130322.ebuild
new file mode 100644
index 0000000..4bb68fd
--- /dev/null
+++ b/app-editors/pemacs/pemacs-1.5_pre20130322.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hughbarney/pEmacs.git"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
+ inherit git-r3
+else
+ # snapshot from git repo
+ SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+fi
+
+DESCRIPTION="Perfect Emacs, a small footprint Emacs derived from Ersatz Emacs"
+HOMEPAGE="https://github.com/hughbarney/pEmacs"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall" \
+ LFLAGS="${LDFLAGS} $("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ dobin pe
+ doman pe.1
+ dodoc README.md
+}