aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2023-02-28 20:32:37 +0500
committerDenis Reva <denis7774@gmail.com>2023-02-28 20:32:37 +0500
commit484bc1f8f5aef26b13ba15aedd5ab89b384a8f42 (patch)
treef00968c916d60dd699197c4246f1ec9dcb854556 /dev-cpp/parallel-hashmap
parentdev-cpp/parallel-hashmap: updated to 1.3.8 (diff)
downloadguru-484bc1f8f5aef26b13ba15aedd5ab89b384a8f42.tar.gz
guru-484bc1f8f5aef26b13ba15aedd5ab89b384a8f42.tar.bz2
guru-484bc1f8f5aef26b13ba15aedd5ab89b384a8f42.zip
dev-cpp/parallel-hashmap: deleted obsolete version
Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'dev-cpp/parallel-hashmap')
-rw-r--r--dev-cpp/parallel-hashmap/Manifest1
-rw-r--r--dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild45
2 files changed, 0 insertions, 46 deletions
diff --git a/dev-cpp/parallel-hashmap/Manifest b/dev-cpp/parallel-hashmap/Manifest
index 4d6cffc56..38c813229 100644
--- a/dev-cpp/parallel-hashmap/Manifest
+++ b/dev-cpp/parallel-hashmap/Manifest
@@ -1,2 +1 @@
DIST parallel-hashmap-1.3.8.tar.gz 2047306 BLAKE2B b56bd2a8f958f69c400e8b736669f7bbe875823ca28370a6ce0f25a6de995a81b4ff8269f84eea3bbdcd62ec96d2a7613d8d414abcf2da6215e476f81927d4ad SHA512 499f132aa1513942762ae5214e9a37915529d60142439d32276d9e68a446c93ecea66caa32ac00bea683e2c932101cd999c8839a89211e91032f777f236181f7
-DIST parallel-hashmap-1.35.gh.tar.gz 2044770 BLAKE2B 18c4843ebd2ca046e1597a7fc0341440d888c4b39d2355e45b36e02b9f5dcf39baec1826434d70b591e6713fe2ff043a9ec8a68b7b43e0fbb2af176507b738ba SHA512 ffa70a6691784caa8acc6e191b3db4ffdbbc51db86c91118267fac96c178d434f890f773c9b31932eaed15b2cecbd74dcaddacefd0ef9771da0833c90d0f104c
diff --git a/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild b/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
deleted file mode 100644
index 2e46da2b8..000000000
--- a/dev-cpp/parallel-hashmap/parallel-hashmap-1.35.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CMAKE_MAKEFILE_GENERATOR=emake
-
-inherit cmake
-
-DESCRIPTION="Family of header-only, fast and memory-friendly hashmap and btree containers"
-HOMEPAGE="
- https://greg7mdp.github.io/parallel-hashmap/
- https://github.com/greg7mdp/parallel-hashmap
-"
-SRC_URI="https://github.com/greg7mdp/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="examples test"
-
-CDEPEND="dev-libs/cereal"
-DEPEND="test? ( ${CDEPEND} )"
-RDEPEND="${CDEPEND}"
-
-# tests will download gtest, not trivial to use the system one
-# https://github.com/greg7mdp/parallel-hashmap/issues/154
-RESTRICT="test"
-
-src_configure() {
- local mycmakeargs=(
- -DPHMAP_BUILD_EXAMPLES=$(usex examples)
- -DPHMAP_BUILD_TESTS=$(usex test)
- )
-
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- if use examples ; then
- dodoc -r examples
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
-}