aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-04-10 15:42:54 -0400
committerNick Sarnie <sarnex@gentoo.org>2022-04-10 15:54:16 -0400
commit01a5bb0950c9319331c6a3153378da642aadaa58 (patch)
tree9dd36f5ed8ec2775741e3878f67c405f5fd37747
parentapp-emulation/wine-vanilla: EAPI 8 (diff)
downloadwine-01a5bb0950c9319331c6a3153378da642aadaa58.tar.gz
wine-01a5bb0950c9319331c6a3153378da642aadaa58.tar.bz2
wine-01a5bb0950c9319331c6a3153378da642aadaa58.zip
app-emulation/wine-staging: EAPI 8
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
-rw-r--r--app-emulation/wine-staging/wine-staging-7.3.ebuild17
-rw-r--r--app-emulation/wine-staging/wine-staging-7.4.ebuild19
-rw-r--r--app-emulation/wine-staging/wine-staging-7.5.ebuild14
-rw-r--r--app-emulation/wine-staging/wine-staging-7.6.ebuild14
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild14
5 files changed, 45 insertions, 33 deletions
diff --git a/app-emulation/wine-staging/wine-staging-7.3.ebuild b/app-emulation/wine-staging/wine-staging-7.3.ebuild
index 5c6ad86..35870f8 100644
--- a/app-emulation/wine-staging/wine-staging-7.3.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
PLOCALES="ar ast bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
+inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolchain-funcs virtualx wrapper xdg-utils
MY_PN="${PN%%-*}"
MY_PV="${PV/_/-}"
MY_P="${MY_PN}-${MY_PV}"
@@ -61,7 +61,13 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
# or fail due to Xvfb's opengl limitations.
RESTRICT="test"
+BDEPEND="mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
COMMON_DEPEND="
+ ${BDEPEND}
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
@@ -131,10 +137,7 @@ RDEPEND="${COMMON_DEPEND}
# tools/make_requests requires perl
DEPEND="${COMMON_DEPEND}
- sys-devel/flex
>=sys-kernel/linux-headers-2.6
- virtual/pkgconfig
- virtual/yacc
X? ( x11-base/xorg-proto )
staging? (
dev-lang/perl
@@ -275,8 +278,8 @@ pkg_pretend() {
# Verify OSS support
if use oss; then
if ! has_version ">=media-sound/oss-4"; then
- eerror "You cannot build wine with USE=oss without having support from a"
- eerror "FreeBSD kernel or >=media-sound/oss-4 (only available through external repos)"
+ eerror "You cannot build wine with USE=oss without having support from"
+ eerror ">=media-sound/oss-4 (only available through external repos)"
eerror
die
fi
diff --git a/app-emulation/wine-staging/wine-staging-7.4.ebuild b/app-emulation/wine-staging/wine-staging-7.4.ebuild
index cf584a4..35870f8 100644
--- a/app-emulation/wine-staging/wine-staging-7.4.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
PLOCALES="ar ast bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
+inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolchain-funcs virtualx wrapper xdg-utils
MY_PN="${PN%%-*}"
MY_PV="${PV/_/-}"
MY_P="${MY_PN}-${MY_PV}"
@@ -48,7 +48,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="${MY_PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gssapi gstreamer kerberos ldap mingw +mono mp3 netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl staging test +threads +truetype udev +udisks +unwind usb v4l vkd3d vulkan +X +xcomposite xinerama"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos +fontconfig +gecko gphoto2 gssapi gstreamer kerberos ldap mingw +mono mp3 netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl staging test +threads +truetype udev +udisks +unwind usb v4l vkd3d vulkan +X +xcomposite xinerama"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -61,7 +61,13 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
# or fail due to Xvfb's opengl limitations.
RESTRICT="test"
+BDEPEND="mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
COMMON_DEPEND="
+ ${BDEPEND}
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
@@ -131,10 +137,7 @@ RDEPEND="${COMMON_DEPEND}
# tools/make_requests requires perl
DEPEND="${COMMON_DEPEND}
- sys-devel/flex
>=sys-kernel/linux-headers-2.6
- virtual/pkgconfig
- virtual/yacc
X? ( x11-base/xorg-proto )
staging? (
dev-lang/perl
@@ -275,8 +278,8 @@ pkg_pretend() {
# Verify OSS support
if use oss; then
if ! has_version ">=media-sound/oss-4"; then
- eerror "You cannot build wine with USE=oss without having support from a"
- eerror "FreeBSD kernel or >=media-sound/oss-4 (only available through external repos)"
+ eerror "You cannot build wine with USE=oss without having support from"
+ eerror ">=media-sound/oss-4 (only available through external repos)"
eerror
die
fi
diff --git a/app-emulation/wine-staging/wine-staging-7.5.ebuild b/app-emulation/wine-staging/wine-staging-7.5.ebuild
index 1ad582f..35870f8 100644
--- a/app-emulation/wine-staging/wine-staging-7.5.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.5.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
PLOCALES="ar ast bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
+inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolchain-funcs virtualx wrapper xdg-utils
MY_PN="${PN%%-*}"
MY_PV="${PV/_/-}"
MY_P="${MY_PN}-${MY_PV}"
@@ -61,7 +61,13 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
# or fail due to Xvfb's opengl limitations.
RESTRICT="test"
+BDEPEND="mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
COMMON_DEPEND="
+ ${BDEPEND}
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
@@ -117,7 +123,6 @@ RDEPEND="${COMMON_DEPEND}
!app-emulation/wine:0
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
gecko? ( app-emulation/wine-gecko:2.47.2[abi_x86_32?,abi_x86_64?] )
- mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
mono? ( app-emulation/wine-mono:7.1.1 )
perl? (
dev-lang/perl
@@ -132,10 +137,7 @@ RDEPEND="${COMMON_DEPEND}
# tools/make_requests requires perl
DEPEND="${COMMON_DEPEND}
- sys-devel/flex
>=sys-kernel/linux-headers-2.6
- virtual/pkgconfig
- virtual/yacc
X? ( x11-base/xorg-proto )
staging? (
dev-lang/perl
diff --git a/app-emulation/wine-staging/wine-staging-7.6.ebuild b/app-emulation/wine-staging/wine-staging-7.6.ebuild
index d5b2574..db459b0 100644
--- a/app-emulation/wine-staging/wine-staging-7.6.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.6.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
PLOCALES="ar ast bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
+inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolchain-funcs virtualx wrapper xdg-utils
MY_PN="${PN%%-*}"
MY_PV="${PV/_/-}"
MY_P="${MY_PN}-${MY_PV}"
@@ -61,7 +61,13 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
# or fail due to Xvfb's opengl limitations.
RESTRICT="test"
+BDEPEND="mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
COMMON_DEPEND="
+ ${BDEPEND}
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
@@ -117,7 +123,6 @@ RDEPEND="${COMMON_DEPEND}
!app-emulation/wine:0
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
gecko? ( app-emulation/wine-gecko:2.47.2[abi_x86_32?,abi_x86_64?] )
- mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
mono? ( app-emulation/wine-mono:7.2.0 )
perl? (
dev-lang/perl
@@ -132,10 +137,7 @@ RDEPEND="${COMMON_DEPEND}
# tools/make_requests requires perl
DEPEND="${COMMON_DEPEND}
- sys-devel/flex
>=sys-kernel/linux-headers-2.6
- virtual/pkgconfig
- virtual/yacc
X? ( x11-base/xorg-proto )
staging? (
dev-lang/perl
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index d5b2574..db459b0 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
PLOCALES="ar ast bg ca cs da de el en en_US eo es fa fi fr he hi hr hu it ja ko lt ml nb_NO nl or pa pl pt_BR pt_PT rm ro ru si sk sl sr_RS@cyrillic sr_RS@latin sv ta te th tr uk wa zh_CN zh_TW"
PLOCALE_BACKUP="en"
-inherit autotools eapi7-ver estack eutils flag-o-matic gnome2-utils multilib multilib-minimal pax-utils plocale toolchain-funcs virtualx xdg-utils
+inherit autotools estack flag-o-matic multilib-minimal pax-utils plocale toolchain-funcs virtualx wrapper xdg-utils
MY_PN="${PN%%-*}"
MY_PV="${PV/_/-}"
MY_P="${MY_PN}-${MY_PV}"
@@ -61,7 +61,13 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
# or fail due to Xvfb's opengl limitations.
RESTRICT="test"
+BDEPEND="mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
+ sys-devel/flex
+ virtual/yacc
+ virtual/pkgconfig"
+
COMMON_DEPEND="
+ ${BDEPEND}
X? (
x11-libs/libXcursor[${MULTILIB_USEDEP}]
x11-libs/libXext[${MULTILIB_USEDEP}]
@@ -117,7 +123,6 @@ RDEPEND="${COMMON_DEPEND}
!app-emulation/wine:0
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
gecko? ( app-emulation/wine-gecko:2.47.2[abi_x86_32?,abi_x86_64?] )
- mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
mono? ( app-emulation/wine-mono:7.2.0 )
perl? (
dev-lang/perl
@@ -132,10 +137,7 @@ RDEPEND="${COMMON_DEPEND}
# tools/make_requests requires perl
DEPEND="${COMMON_DEPEND}
- sys-devel/flex
>=sys-kernel/linux-headers-2.6
- virtual/pkgconfig
- virtual/yacc
X? ( x11-base/xorg-proto )
staging? (
dev-lang/perl