summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-02-19 09:17:14 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-02-19 09:19:41 +0100
commit0125bec03fffc665846118c388931915c1b60c9b (patch)
tree75402905cec19e2ff1ac7e9102a00768c5ee3399
parentsys-fs/aufs4: Bump to latest aufs release (diff)
downloadgentoo-0125bec03fffc665846118c388931915c1b60c9b.tar.gz
gentoo-0125bec03fffc665846118c388931915c1b60c9b.tar.bz2
gentoo-0125bec03fffc665846118c388931915c1b60c9b.zip
dev-python/numba: Bump
Package-Manager: portage-2.2.27
-rw-r--r--dev-python/numba/Manifest1
-rw-r--r--dev-python/numba/numba-0.23.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/numba/Manifest b/dev-python/numba/Manifest
index e8ac3a4d3258..0ab7c3ef6fcb 100644
--- a/dev-python/numba/Manifest
+++ b/dev-python/numba/Manifest
@@ -2,3 +2,4 @@ DIST numba-0.18.2.tar.gz 786935 SHA256 5988621a8dd3609d252435c8e280bf01e2f25d9eb
DIST numba-0.19.2.tar.gz 871394 SHA256 10bdd84a3a8dfb9b195ad7d3b11c1f52693833820268c64837dc8510e66f1e2e SHA512 9eca230b5d69890680278248365e748b2e8a7e040703e80acaed2c0e1dc3576e102bde3809eceb6e600d90e02685e66419ca3423d332620c034fe9c07995aa67 WHIRLPOOL bfba05b56ff9fa9708b67dad1f514bc35c72ac3bf76e349f2ec20c63f7cb9c1664b106898559220e796ae9cafc7a48dbb5e6e537720d6cd4f6b5ccde4903dc67
DIST numba-0.20.0.tar.gz 895183 SHA256 62dd4eebbd8fef27a8a60b74de2f540b12223939e197877babb13bf06eba5d9f SHA512 d511ed382813471dd2b9f6d99ee7cae4b77375a3c003df44ec2954b0f16c32b0fec76b3c33df46c821f17a4d148afab6c4b2d43429548a5bc81efbebc4fb54e3 WHIRLPOOL 8345bed1965715aace541bfcde33f4a999241fac8f655d80d1bb67db5ae806924fec47e3895b2a61484474fef2d4362d15800aa5be8b1c8f1922eaeb06d432ce
DIST numba-0.22.1.tar.gz 1101843 SHA256 2b0c95cf9c4f6390b1ff0a238499ee4cc32b3695728293e1d888cd3c15803633 SHA512 0514a04e83f800ba4dba97e5b220fd5d530e923e91769881f9df320a0eedcfb1e652fc87a1cda2d80223e38a25f85387a1930259179996bab7b7a731b86864c0 WHIRLPOOL dd554a15ea3783bfe335ed08b538eed6ec7071986ef4ad63e76e51c3d06783b38dccd0fb5b01b720eab130dbb20d8a2fe8cefd4124a6f57aeb10e74c228fad16
+DIST numba-0.23.1.tar.gz 1284771 SHA256 54359b8ef700a70f0d7a9b9aecb2c58867fd23479f556730d8b3422a132d5735 SHA512 833087ac4272d386eca0434855128773284f0f1f7cd85143088d2184781b070bf2922a7e2378ae90ba53382ffb5c547e9c2e34ec35a9423e1cf2ad9706d7c366 WHIRLPOOL 1cc91acb8acd9e14ace0be14c45e5e1abf5fc28440ad463240f8ed5b18708496b166ebb9134df32170551ac6f7e123d1dcb4897434320bb9471338c008b638ab
diff --git a/dev-python/numba/numba-0.23.1.ebuild b/dev-python/numba/numba-0.23.1.ebuild
new file mode 100644
index 000000000000..cbd0b4239074
--- /dev/null
+++ b/dev-python/numba/numba-0.23.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="NumPy aware dynamic Python compiler using LLVM"
+HOMEPAGE="http://numba.pydata.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/llvmlite[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python{2_7,3_3})
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# test phase is pointless since it errors in circa 60% of 1984 tests
+RESTRICT="test"
+
+# Delete intersphinx & entry to set sphinxjp.themecore, which is absent from portage, from conf.py
+PATCHES=( "${FILESDIR}"/${PN}-0.19.2-docbuild.patch )
+
+python_prepare_all() {
+ # Re-set them of doc build to one provided by sphinx
+ if has_version ">=dev-python/sphinx-1.3.1"; then
+ sed -e 's:basicstrap:classic:' -i docs/source/conf.py || die
+ else
+ sed -e 's:basicstrap:default:' -i docs/source/conf.py || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ export CFLAGS
+ fi
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && emake -C docs/ html
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib* || die
+ ${PYTHON} -c "import numba; numba.test()" || die
+}
+
+python_install_all() {
+ # doc needs obsolete sphinxjp package
+# use doc && dodoc docs/Numba.pdf
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}