summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-05-03 18:40:08 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-05-04 07:33:07 -0400
commit0444c1df21634b07573a1d2899e2de49258febb8 (patch)
treeb374568e6e3bbc5cb2f778487573a5873b5a59c8
parentdev-util/drone: Remove old (diff)
downloadgentoo-0444c1df21634b07573a1d2899e2de49258febb8.tar.gz
gentoo-0444c1df21634b07573a1d2899e2de49258febb8.tar.bz2
gentoo-0444c1df21634b07573a1d2899e2de49258febb8.zip
dev-php/symfony-filesystem: new version 3.2.8.
This new version adds a tiny patch to annotate the one test that requires network access. Afterwards, we are able to enable the test suite and skip the network test. The test suite passes, so I've removed the RESTRICT=test that we had. The patch is reflected in upstream (symfony/symfony) pull request 22630. Another small improvement is to spell out the files and directories to be installed, rather than using "." (the whole directory). This avoids installing composer.json and some other junk to the PHP include directory. Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-php/symfony-filesystem/Manifest2
-rw-r--r--dev-php/symfony-filesystem/files/annotate-network-tests.patch27
-rw-r--r--dev-php/symfony-filesystem/symfony-filesystem-3.2.8.ebuild (renamed from dev-php/symfony-filesystem/symfony-filesystem-3.2.6.ebuild)22
3 files changed, 39 insertions, 12 deletions
diff --git a/dev-php/symfony-filesystem/Manifest b/dev-php/symfony-filesystem/Manifest
index 538aed1e1d17..2a19266197ef 100644
--- a/dev-php/symfony-filesystem/Manifest
+++ b/dev-php/symfony-filesystem/Manifest
@@ -1 +1 @@
-DIST symfony-filesystem-3.2.6.tar.gz 16952 SHA256 bb0802964c58753478c422e8a5dc2b5d62201a49127fa7d036bbce40fb603801 SHA512 6f2d9d772cffc77a8861a8bc70938dd5d1b984b5f95d515e93c3705647622e42bdb83a5328c81aed88bd5b2673ee4f1daf4706f0ca99cdab2c47aa0ce9630aae WHIRLPOOL fbdeeefe74225bdaee12ee57a599d74cf6657faaf50ca192a6e4d0d1c5c0db562e29786306768169aa6a961aeb92bbd099425c19a91e3e77f54f3e80f5ea4753
+DIST symfony-filesystem-3.2.8.tar.gz 17361 SHA256 bedb3610c96627c3f7eecdcd248344062181ccfa51b580745c47acf85cbf7d48 SHA512 b9464dec0c5100877bb7178a118ab34e9893307df371e9a9f8df8d69e59b6e14c9f7143e4eaf5b47662f69dce1b5fa975b6bb78e93a5c7455eb44dacfaab82e8 WHIRLPOOL ffdd8ffec5d5217c09e5051b3acc04ea0b72be4c9b214db127ad83c285cdf0b4ed3f2dfb1b21f96821ce5794fb4cc8c1a7cc8e4bc51665eae69f1218a1bbd7e5
diff --git a/dev-php/symfony-filesystem/files/annotate-network-tests.patch b/dev-php/symfony-filesystem/files/annotate-network-tests.patch
new file mode 100644
index 000000000000..38c83753195f
--- /dev/null
+++ b/dev-php/symfony-filesystem/files/annotate-network-tests.patch
@@ -0,0 +1,27 @@
+From cda6fa8801d04b149592c5789c0d060c4ca4e9db Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Wed, 3 May 2017 18:33:56 -0400
+Subject: [PATCH 1/1] Annotate the one network test as being a part of the
+ "network" group.
+
+---
+ Tests/FilesystemTest.php | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/Tests/FilesystemTest.php b/Tests/FilesystemTest.php
+index 1341392..a862fa8 100644
+--- a/Tests/FilesystemTest.php
++++ b/Tests/FilesystemTest.php
+@@ -156,6 +156,9 @@ class FilesystemTest extends FilesystemTestCase
+ $this->assertEquals('SOURCE FILE', file_get_contents($targetFilePath));
+ }
+
++ /**
++ * @group network
++ */
+ public function testCopyForOriginUrlsAndExistingLocalFileDefaultsToCopy()
+ {
+ $sourceFilePath = 'http://symfony.com/images/common/logo/logo_symfony_header.png';
+--
+2.10.2
+
diff --git a/dev-php/symfony-filesystem/symfony-filesystem-3.2.6.ebuild b/dev-php/symfony-filesystem/symfony-filesystem-3.2.8.ebuild
index b45a9caeb1c9..942c49c4b135 100644
--- a/dev-php/symfony-filesystem/symfony-filesystem-3.2.6.ebuild
+++ b/dev-php/symfony-filesystem/symfony-filesystem-3.2.8.ebuild
@@ -11,31 +11,31 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-RESTRICT="test"
-RDEPEND="
- dev-lang/php:*
+RDEPEND="dev-lang/php:*
dev-php/fedora-autoloader"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-php/phpunit )"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
S="${WORKDIR}/filesystem-${PV}"
+# This patch is https://github.com/symfony/symfony/pull/22630
+PATCHES=( "${FILESDIR}/annotate-network-tests.patch" )
+
src_prepare() {
default
if use test; then
- cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+ cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
fi
}
src_install() {
insinto "/usr/share/php/Symfony/Component/Filesystem"
- doins -r . "${FILESDIR}"/autoload.php
- dodoc README.md
+ doins -r Exception
+ doins *.php "${FILESDIR}/autoload.php"
+ dodoc CHANGELOG.md README.md
}
src_test() {
- phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+ phpunit --bootstrap "${S}/autoload-test.php" \
+ --exclude-group network || die 'test suite failed'
}