summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-05-17 19:25:22 +0200
committerPacho Ramos <pacho@gentoo.org>2019-05-17 19:25:22 +0200
commit082d810446cf6194f785dce76d5268e00a14d24e (patch)
tree5ac53af471dee192043104375af85c0e416403fe
parentgnome-extra/gnome-shell-extension-gsconnect: Drop old (diff)
downloadgentoo-082d810446cf6194f785dce76d5268e00a14d24e.tar.gz
gentoo-082d810446cf6194f785dce76d5268e00a14d24e.tar.bz2
gentoo-082d810446cf6194f785dce76d5268e00a14d24e.zip
gnome-extra/gnome-shell-extension-gsconnect: Bump to 24
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gnome-extra/gnome-shell-extension-gsconnect/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-24.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-gsconnect/Manifest b/gnome-extra/gnome-shell-extension-gsconnect/Manifest
index 147f590c01b1..5524a01edc48 100644
--- a/gnome-extra/gnome-shell-extension-gsconnect/Manifest
+++ b/gnome-extra/gnome-shell-extension-gsconnect/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-gsconnect-23.tar.gz 295155 BLAKE2B 15779f9ceaaf0cae3326786eb78a12e7d669d95692c40f233a5c0d93ac44a4787738ce0826048019f27a0fead7de5b4bad1d64410d27646f05122547751f681e SHA512 8c480d1695b0e261a34277604c6fca5445987ae33cf07749b3d96649224f505f1ce2bee249325acbd8d89c23da1a04cea19d668fcc298ef777c55e9b53f85bba
+DIST gnome-shell-extension-gsconnect-24.tar.gz 287521 BLAKE2B 5cf8d3c932c8746a5fd66003233cb83adf71d637199947c01a59e965c60eecb41f5b037d949930753d12ebdbb964b3ff6ae6e05809a6de52e941307c8a659ea2 SHA512 b2ae669dae0d3c8ef4d28ad186a1d61706c005c5e87d58565d6d1544f97d5ca46ee230e60ddd986ee17a6edb411976cdbbb5226b678e6eb097b08afd1b0160c7
diff --git a/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-24.ebuild b/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-24.ebuild
new file mode 100644
index 000000000000..ed8e6f2ac3c5
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-gsconnect/gnome-shell-extension-gsconnect-24.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils meson readme.gentoo-r1
+
+DESCRIPTION="KDE Connect implementation for Gnome Shell"
+HOMEPAGE="https://github.com/andyholmes/gnome-shell-extension-gsconnect"
+SRC_URI="https://github.com/andyholmes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="nautilus"
+
+COMMON_DEPEND="dev-libs/glib:2"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=dev-libs/gjs-1.48
+ >=gnome-base/gnome-shell-3.28
+ gnome-base/gvfs
+ || ( ( net-libs/gnome-online-accounts dev-libs/libgdata ) dev-libs/folks )
+ || ( media-libs/libcanberra media-libs/gsound )
+ nautilus? (
+ dev-python/nautilus-python
+ gnome-base/nautilus[introspection] )
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="For knowing more about how to do the setup, please visit:
+https://github.com/andyholmes/gnome-shell-extension-gsconnect/wiki/Installation"
+
+src_configure() {
+ meson_src_configure \
+ $(meson_use nautilus)
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}