summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-10-24 16:02:53 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-10-24 16:07:58 -0500
commit0884d4a756a9f7bd58c8a213ec395a5b4ae7a58d (patch)
tree77c6e8c955adf7d0766298efecdc430918a55f64
parenthaskell-cabal.eclass: add missing '|| die' on pushd/popd (diff)
downloadgentoo-0884d4a756a9f7bd58c8a213ec395a5b4ae7a58d.tar.gz
gentoo-0884d4a756a9f7bd58c8a213ec395a5b4ae7a58d.tar.bz2
gentoo-0884d4a756a9f7bd58c8a213ec395a5b4ae7a58d.zip
dev-python/botocore: add version 1.3.0
Package-Manager: portage-2.2.23
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.3.0.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 825e611efa8e..75fe3a333c03 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST 1.1.11.tar.gz 1975224 SHA256 b4e6edc12177dd4f720259aa7027bab00fb9db2029e40e77e67c552ef9f41132 SHA512 b0b10299d93314de582cfd21511987fe210df1618c49f6c706c4341a3a635a85cd48d8848a69f83391a227ab5dc3881509a02b4cc47b1e27d18cf353d4de850b WHIRLPOOL 21e662fe7f713a98e5e16225e3860585f0abb8e4a47b5f0ae52262a929a32ce563e1108c80602c9c2136180957c1b8bb4b89d8b9fc84415c155212d326f08b90
DIST botocore-1.2.10.tar.gz 2202147 SHA256 8541895aa2abe2183fa15efe33794db7428fec3302e0c9bf1db13fa1668e2b66 SHA512 5395776f50c5302d2fa75af702ced17da66a4c0435d62aed907f1ceaa93d38acc2d91a250d2153d852239a08d9f7f0bf361523cc89168a6cb81ef6f8a6ec5124 WHIRLPOOL aa4ff7a2aa1a900642782783b85479943bcce85c7df0c056d989d329c0693424110859a1d9d358e0cc5af94be174c96786c2f339e78934c114011606dfce11ec
DIST botocore-1.2.4.tar.gz 2007943 SHA256 6330dec53831e4f961e2503a4d9bfe9e790e1e7ac716f8edc07f1b37ff2765da SHA512 c2d0ee934a0b0a25a617a100528daa2951e6cb5139bd7dc5d550bcffcb777119f141b96e0a60dda1277dc8199acfd33e80d002bd3cc730c011e5dadfc52c6f33 WHIRLPOOL f2ff39099b08808e4684abf0d800c05593d66ae68a68f112abab97a715a4c6248ef6f193816faf481e8bc5a3814b22978c0e06a29e5a4cdfb39e24d112b5ef21
+DIST botocore-1.3.0.tar.gz 2224783 SHA256 b93f113b40b048a1f636f96797c14d2f5b3e5d112e8a030f2b9fa8b15a16d38c SHA512 8aae8d1e3b162969135778c91dedf672e934dce39fffc364c259f1695d28c2910e6e29dc11c264c287328c9d0ba71455ec7e31894fca03a237cb40464b7e47ba WHIRLPOOL 0f0e311223553b70201fad6a0d6f77865bfb7d1800b39ceffbcd8b0463540bbd4380bbc24e83dbdec1e605e94867ecb6bfdddef432a7455297e3f1b4be2d3592
diff --git a/dev-python/botocore/botocore-1.3.0.ebuild b/dev-python/botocore/botocore-1.3.0.ebuild
new file mode 100644
index 000000000000..6927baa78bfe
--- /dev/null
+++ b/dev-python/botocore/botocore-1.3.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}