summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-25 17:02:08 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-25 17:03:40 +0100
commit08f0d6898403dd54888aac2c573235e90409b9a6 (patch)
treea0c271bf017a4f412cac3971629e5cf3d9c3482e
parentmedia-libs/esdl: Drop old (diff)
downloadgentoo-08f0d6898403dd54888aac2c573235e90409b9a6.tar.gz
gentoo-08f0d6898403dd54888aac2c573235e90409b9a6.tar.bz2
gentoo-08f0d6898403dd54888aac2c573235e90409b9a6.zip
sys-apps/duc: Fix compiling against sys-libs/ncurses[tinfo] (bug #636958).
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--sys-apps/duc/duc-9999.ebuild7
-rw-r--r--sys-apps/duc/files/duc-1.4.1-tinfo.patch23
2 files changed, 28 insertions, 2 deletions
diff --git a/sys-apps/duc/duc-9999.ebuild b/sys-apps/duc/duc-9999.ebuild
index b063305e8b89..55fa313bfe3d 100644
--- a/sys-apps/duc/duc-9999.ebuild
+++ b/sys-apps/duc/duc-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit autotools
@@ -42,6 +42,9 @@ DEPEND="
tokyocabinet? ( dev-db/tokyocabinet )
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1-tinfo.patch
+)
src_unpack() {
if [[ "${PV}" == "9999" ]]; then
diff --git a/sys-apps/duc/files/duc-1.4.1-tinfo.patch b/sys-apps/duc/files/duc-1.4.1-tinfo.patch
new file mode 100644
index 000000000000..74f0529d6741
--- /dev/null
+++ b/sys-apps/duc/files/duc-1.4.1-tinfo.patch
@@ -0,0 +1,23 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -138,8 +138,8 @@
+ if test "${enable_ui}" = "yes"; then
+ AC_DEFINE([ENABLE_UI], [1], [Enable ui])
+
+- AC_CHECK_LIB([ncursesw], [tputs],, [
+- AC_CHECK_LIB([ncurses], [tputs],, [
++ AC_CHECK_LIB([ncursesw], [touchwin],, [
++ AC_CHECK_LIB([ncurses], [touchwin],, [
+ AC_MSG_ERROR([
+ The ncurses library was not found, which is needed for ui support. Either install
+ the ncurses development libraries, or compile without ui support (--disable-ui)
+@@ -148,6 +148,9 @@
+ ])
+ fi
+
++AC_SEARCH_LIBS([tputs], [tinfo],, [
++ AC_MSG_ERROR([No library was found providing tputs])
++])
+
+ if test "${enable_x11}" = "yes"; then
+ test "${enable_cairo}" != "yes" && AC_MSG_ERROR([cairo must be enabled for x11])