summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-03-12 00:44:34 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-03-12 00:44:34 +0000
commit08fc7dea9221de3cdc949041cf5362c2312b2061 (patch)
tree69c7f98c3c152fe0be4a015ac64a8e81c9b2f483
parent2022-03-12 00:15:08 UTC (diff)
parentsys-apps/flashrom: remove another 9999-only local use flag (diff)
downloadgentoo-08fc7dea9221de3cdc949041cf5362c2312b2061.tar.gz
gentoo-08fc7dea9221de3cdc949041cf5362c2312b2061.tar.bz2
gentoo-08fc7dea9221de3cdc949041cf5362c2312b2061.zip
Merge updates from master
-rw-r--r--app-forensics/aide/aide-0.17.4-r2.ebuild (renamed from app-forensics/aide/aide-0.17.4-r1.ebuild)4
-rw-r--r--app-forensics/aide/files/aide.conf-r2136
-rw-r--r--app-forensics/aide/files/aide.cron-r2188
-rw-r--r--net-misc/whois/Manifest1
-rw-r--r--net-misc/whois/whois-5.5.12.ebuild81
-rw-r--r--sys-apps/flashrom/metadata.xml1
-rw-r--r--sys-devel/icecream/Manifest2
-rw-r--r--sys-devel/icecream/icecream-1.0.0-r3.ebuild62
-rw-r--r--sys-devel/icecream/icecream-1.4.ebuild80
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-6.03-without-gl-configure.patch12
-rw-r--r--x11-misc/xscreensaver/xscreensaver-6.03.ebuild1
-rw-r--r--x11-terms/xterm/Manifest1
-rw-r--r--x11-terms/xterm/xterm-372.ebuild98
13 files changed, 601 insertions, 66 deletions
diff --git a/app-forensics/aide/aide-0.17.4-r1.ebuild b/app-forensics/aide/aide-0.17.4-r2.ebuild
index 6b3fb2f5f72d..39625b22eff5 100644
--- a/app-forensics/aide/aide-0.17.4-r1.ebuild
+++ b/app-forensics/aide/aide-0.17.4-r2.ebuild
@@ -91,10 +91,10 @@ src_install() {
insinto /etc/${PN}
insopts -m0600
- newins "${FILESDIR}"/aide.conf-r1 aide.conf
+ newins "${FILESDIR}"/aide.conf-r2 aide.conf
dosbin "${FILESDIR}"/aideinit
- dodoc -r contrib/ "${FILESDIR}"/aide.cron
+ dodoc -r contrib/ "${FILESDIR}"/aide.cron-r2
keepdir /var/{lib,log}/${PN}
}
diff --git a/app-forensics/aide/files/aide.conf-r2 b/app-forensics/aide/files/aide.conf-r2
new file mode 100644
index 000000000000..4bce675f7da3
--- /dev/null
+++ b/app-forensics/aide/files/aide.conf-r2
@@ -0,0 +1,136 @@
+# Example configuration file for AIDE
+# See more: man 5 aide.conf
+
+database_in=file:/var/lib/aide/aide.db
+database_out=file:/var/lib/aide/aide.db.new
+
+# Change this to "no" or remove it to not gzip output
+# (only useful on systems with few CPU cycles to spare)
+gzip_dbout=yes
+
+# Default: warning
+#log_level=info
+
+# Default: changed_attributes
+#report_level=added_removed_attributes
+
+report_url=file:/var/log/aide/aide.log
+report_url=stdout
+#report_url=stderr
+
+# Here are all the things we can check - these are the default rules
+#
+# p: permissions
+# ftype: file type
+# i: inode
+# l: link name
+# n: number of links
+# u: user
+# g: group
+# s: size
+# b: block count
+# m: mtime (modification time)
+# a: atime (access time)
+# c: ctime (change time)
+# S: check for growing size
+# I: ignore changed filename
+# ANF: allow new files
+# ARF: allow removed files
+# md5: md5 checksum
+# sha1: sha1 checksum
+# sha256: sha256 checksum
+# sha512: sha512 checksum
+# rmd160: rmd160 checksum
+# tiger: tiger checksum
+# crc32: crc32 checksum
+# R: p+ftype+i+l+n+u+g+s+m+c+md5+X
+# L: p+ftype+i+l+n+u+g+X
+# E: Empty group
+# X: acl+selinux+xattrs+e2fsattrs (if groups are explicitly enabled)
+# >: Growing file p+ftype+l+u+g+i+n+S+X
+
+# Defines formerly set here have been moved to /etc/default/aide.
+
+# Custom rules
+Binlib = p+i+n+u+g+s+b+m+c+md5+sha256+rmd160
+ConfFiles = p+i+n+u+g+s+b+m+c+md5+sha256+rmd160
+Logs = p+i+n+u+g+S
+Devices = p+i+n+u+g+s+b+c+md5+sha256+rmd160
+Databases = p+n+u+g
+StaticDir = p+i+n+u+g
+ManPages = p+i+n+u+g+s+b+m+c+md5+sha256+rmd160
+
+# Next decide what directories/files you want in the database
+
+# Kernel, system map, etc.
+=/boot$ Binlib
+# Configs
+/etc ConfFiles
+!/etc/mtab
+# Binaries
+/bin Binlib
+/sbin Binlib
+/usr/bin Binlib
+/usr/sbin Binlib
+/usr/libexec Binlib
+/usr/local/bin Binlib
+/usr/local/sbin Binlib
+#/usr/games Binlib
+# Libraries
+/lib(64)? Binlib
+/usr/lib(64)? Binlib
+/usr/local/lib(64)? Binlib
+# Log files
+=/var/log$ StaticDir
+#!/var/log/ksymoops
+/var/log/aide/aide.log(.[0-9])?(.gz)? Databases
+/var/log/aide/error.log(.[0-9])?(.gz)? Databases
+#/var/log/setuid.changes(.[0-9])?(.gz)? Databases
+!/var/log/aide
+/var/log Logs
+# Devices
+!/dev/pts
+# If you get spurious warnings about being unable to mmap() /dev/cpu/mtrr,
+# you may uncomment this to get rid of them. They're harmless but sometimes
+# annoying.
+#!/dev/cpu/mtrr
+#!/dev/xconsole
+/dev Devices
+# Other miscellaneous files
+/var/run$ StaticDir
+!/var/run
+# Test only the directory when dealing with /proc
+/proc$ StaticDir
+!/proc
+
+# You can look through these examples to get further ideas
+
+# MD5 sum files - especially useful with debsums -g
+#/var/lib/dpkg/info/([^\.]+).md5sums u+g+s+m+md5+sha1
+
+# Check crontabs
+#/var/spool/anacron/cron.daily Databases
+#/var/spool/anacron/cron.monthly Databases
+#/var/spool/anacron/cron.weekly Databases
+#/var/spool/cron Databases
+#/var/spool/cron/crontabs Databases
+
+# manpages can be trojaned, especially depending on *roff implementation
+#/usr/man ManPages
+#/usr/share/man ManPages
+#/usr/local/man ManPages
+
+# docs
+#/usr/doc ManPages
+#/usr/share/doc ManPages
+
+# check users' home directories
+#/home Binlib
+
+# check sources for modifications
+#/usr/src L
+#/usr/local/src L
+
+# Check headers for same
+#/usr/include L
+#/usr/local/include L
diff --git a/app-forensics/aide/files/aide.cron-r2 b/app-forensics/aide/files/aide.cron-r2
new file mode 100644
index 000000000000..b8a78ba2a856
--- /dev/null
+++ b/app-forensics/aide/files/aide.cron-r2
@@ -0,0 +1,188 @@
+#!/bin/bash
+# Modified: Benjamin Smee
+# Date: Fri Sep 10 11:35:41 BST 2004
+
+# This is the email address reports get mailed to
+MAILTO=root@localhost
+
+# Set this to suppress mailings when there's nothing to report
+QUIETREPORTS=1
+
+# This parameter defines which aide command to run from the cron script.
+# Sensible values are "update" and "check".
+# Default is "check", ensuring backwards compatibility.
+# Since "update" does not take any longer, it is recommended to use "update",
+# so that a new database is created every day. The new database needs to be
+# manually copied over the current one, though.
+COMMAND=update
+
+# This parameter defines how many lines to return per e-mail. Output longer
+# than this value will be truncated in the e-mail sent out.
+LINES=1000
+
+# This parameter gives a grep regular expression. If given, all output lines
+# that _don't_ match the regexp are listed first in the script's output. This
+# allows to easily remove noise from the aide report.
+NOISE="(/var/cache/|/var/lib/|/var/tmp)"
+PATH="/bin:/usr/bin:/sbin:/usr/sbin"
+LOGDIR="/var/log/aide"
+LOGFILE="aide.log"
+CONFFILE="/etc/aide/aide.conf"
+ERRORLOG="aide_error.log"
+MAILLOG="aide_mail.log"
+ERRORTMP=$(mktemp "${ERRORLOG}.XXXXXX")
+
+[ -f /usr/bin/aide ] || exit 0
+
+DATABASE=$(grep "^database=file:/" $CONFFILE | head -n 1 | cut --delimiter=: --fields=2)
+FQDN=$(hostname -f)
+DATE=$(date +"at %Y-%m-%d %H:%M")
+
+# default values
+
+DATABASE="${DATABASE:-/var/lib/aide/aide.db}"
+
+AIDEARGS=""
+
+if [ ! -f "$DATABASE" ]; then
+ /usr/sbin/sendmail $MAILTO <<EOF
+Subject: Daily AIDE report for $FQDN
+From: root@${FQDN}
+To: ${MAILTO}
+Fatal error: The AIDE database does not exist!
+This may mean you haven't created it, or it may mean that someone has removed it.
+EOF
+ exit 0
+fi
+
+aide $AIDEARGS --$COMMAND >"$LOGDIR/$LOGFILE" 2>"$ERRORTMP"
+RETVAL=$?
+
+if [ -n "$QUIETREPORTS" ] && ! [ -s "$LOGDIR/$LOGFILE" ] && ! [ -s "$ERRORTMP" ] ; then
+ # Bail now because there was no output and QUIETREPORTS is set
+ exit 0
+fi
+
+MAILTMP=$(mktemp "${MAILLOG}.XXXXXX")
+
+(cat << EOF
+This is an automated report generated by the Advanced Intrusion Detection
+Environment on $FQDN ${DATE}.
+
+EOF
+
+# include error log in daily report e-mail
+
+if [ "$RETVAL" != "0" ]; then
+ cat > "$LOGDIR/$ERRORLOG" << EOF
+
+*****************************************************************************
+* aide returned a non-zero exit value *
+*****************************************************************************
+
+EOF
+ echo "exit value is: $RETVAL" >> "$LOGDIR/$ERRORLOG"
+else
+ touch "$LOGDIR/$ERRORLOG"
+fi
+< "$ERRORTMP" cat >> "$LOGDIR/$ERRORLOG"
+rm -f "$ERRORTMP"
+
+if [ -s "$LOGDIR/$ERRORLOG" ]; then
+ errorlines=$(wc -l "$LOGDIR/$ERRORLOG" | awk '{ print $1 }')
+ if [ "${errorlines:=0}" -gt $LINES ]; then
+ cat << EOF
+
+****************************************************************************
+* aide has returned many errors. *
+* the error log output has been truncated in this mail *
+****************************************************************************
+
+EOF
+ echo "Error output is $errorlines lines, truncated to $LINES."
+ head -$LINES "$LOGDIR/$ERRORLOG"
+ echo "The full output can be found in $LOGDIR/$ERRORLOG."
+ else
+ echo "Errors produced ($errorlines lines):"
+ cat "$LOGDIR/$ERRORLOG"
+ fi
+else
+ echo "AIDE produced no errors."
+fi
+
+# include de-noised log
+
+if [ -n "$NOISE" ]; then
+ NOISETMP=$(mktemp "aidenoise.XXXXXX")
+ NOISETMP2=$(mktemp "aidenoise.XXXXXX")
+ sed -n '1,/^Detailed information about changes:/p' "$LOGDIR/$LOGFILE" | \
+ grep '^\(changed\|removed\|added\):' | \
+ grep -v "^added: THERE WERE ALSO [0-9]\+ FILES ADDED UNDER THIS DIRECTORY" > "$NOISETMP2"
+
+ if [ -n "$NOISE" ]; then
+ < "$NOISETMP2" grep -v "^\(changed\|removed\|added\):$NOISE" > "$NOISETMP"
+ rm -f "$NOISETMP2"
+ echo "De-Noised output removes everything matching $NOISE."
+ else
+ mv "$NOISETMP2" "$NOISETMP"
+ echo "No noise expression was given."
+ fi
+
+ if [ -s "$NOISETMP" ]; then
+ loglines=$(< "$NOISETMP" wc -l | awk '{ print $1 }')
+ if [ "${loglines:=0}" -gt $LINES ]; then
+ cat << EOF
+
+****************************************************************************
+* aide has returned long output which has been truncated in this mail *
+****************************************************************************
+
+EOF
+ echo "De-Noised output is $loglines lines, truncated to $LINES."
+ < "$NOISETMP" head -$LINES
+ echo "The full output can be found in $LOGDIR/$LOGFILE."
+ else
+ echo "De-Noised output of the daily AIDE run ($loglines lines):"
+ cat "$NOISETMP"
+ fi
+ else
+ echo "AIDE detected no changes after removing noise."
+ fi
+ rm -f "$NOISETMP"
+ echo "============================================================================"
+fi
+
+# include non-de-noised log
+
+if [ -s "$LOGDIR/$LOGFILE" ]; then
+ loglines=$(wc -l "$LOGDIR/$LOGFILE" | awk '{ print $1 }')
+ if [ "${loglines:=0}" -gt $LINES ]; then
+ cat << EOF
+
+****************************************************************************
+* aide has returned long output which has been truncated in this mail *
+****************************************************************************
+
+EOF
+ echo "Output is $loglines lines, truncated to $LINES."
+ head -$LINES "$LOGDIR/$LOGFILE"
+ echo "The full output can be found in $LOGDIR/$LOGFILE."
+ else
+ echo "Output of the daily AIDE run ($loglines lines):"
+ cat "$LOGDIR/$LOGFILE"
+ fi
+else
+ echo "AIDE detected no changes."
+fi
+) > "${MAILTMP}"
+
+(
+cat <<EOF
+Subject: Daily AIDE report for $FQDN
+From: root@${FQDN}
+To: ${MAILTO}
+EOF
+cat "${MAILTMP}"
+) | /usr/sbin/sendmail $MAILTO
+
+rm -f "$MAILTMP"
diff --git a/net-misc/whois/Manifest b/net-misc/whois/Manifest
index 2ba008a3ee23..c62890ba9d08 100644
--- a/net-misc/whois/Manifest
+++ b/net-misc/whois/Manifest
@@ -1,2 +1,3 @@
DIST whois-5.5.10.tar.gz 102555 BLAKE2B 9f1236ceeaea839e5f2a33aa63b39fa7e0566eeb4d2131b88b47dd62f037639a5860719a645d9cc2d0707faa1e86c9822634dda37e1a7a8d3b31a78cf34ecce2 SHA512 5ee92c15146353e77dddcbeddb6e704e0c42d29b8c0ff899ecce80f8e39903e8c796daec7f3de3f197d382f88e7cd4abd470463ea6c13a01347d0cd15d99af28
DIST whois-5.5.11.tar.gz 102806 BLAKE2B be1a5f04ee5af4987224151116d1d7e37ad580b8cc00c3fd4752e10b2cbc1dc46a528591cf75e95a83a99884c961f20865802246e00508c90e338590e7e0be37 SHA512 a7e400a727dd88b4c8f1df2e850879ece882b9af1d5daaff22bb3e1c88be01b4e5430f74f9d4afd4c73538d87022536e40d5f3f63a501a95845396fe0be595b4
+DIST whois-5.5.12.tar.gz 103268 BLAKE2B f9e132a0de189ede87342383f4b869529efe4d99ffdb12450ab909f4df135dbab40319b16d889533803783ed7de4a518ff81d267d0939b3040bf2e25bff8b711 SHA512 f46065d6df0dc6f7d33996e33f456cef9b313e025515916e0476c36255df2919e49f2dcb7666b179393a4429572ac7e099c2783d72cff73222953ac093484786
diff --git a/net-misc/whois/whois-5.5.12.ebuild b/net-misc/whois/whois-5.5.12.ebuild
new file mode 100644
index 000000000000..7ddebc10e44a
--- /dev/null
+++ b/net-misc/whois/whois-5.5.12.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="Improved Whois Client"
+HOMEPAGE="https://github.com/rfc1036/whois"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rfc1036/whois.git"
+else
+ #SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.xz"
+ SRC_URI="https://github.com/rfc1036/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="iconv idn nls xcrypt"
+
+RDEPEND="iconv? ( virtual/libiconv )
+ idn? ( net-dns/libidn2:= )
+ nls? ( virtual/libintl )
+ xcrypt? ( >=sys-libs/libxcrypt-4.1:= )
+ !xcrypt? ( virtual/libcrypt:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils
+ >=dev-lang/perl-5
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+ "${FILESDIR}"/${PN}-5.3.0-libidn_automagic.patch
+ "${FILESDIR}"/${PN}-5.5.6-libxcrypt_automagic.patch
+)
+
+src_prepare() {
+ default
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile || die
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h || die
+
+ # don't generate po files when nls is disabled (bug #419889)
+ sed -i -e '/^all:/s/ pos//' \
+ -e '/^install:/s/ install-pos//' Makefile || die
+ fi
+}
+
+src_configure() { :; } # expected no-op
+
+src_compile() {
+ unset HAVE_ICONV HAVE_LIBIDN
+
+ use iconv && export HAVE_ICONV=1
+ use idn && export HAVE_LIBIDN=1
+ use xcrypt && export HAVE_XCRYPT=1
+
+ tc-export CC
+
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+ emake BASEDIR="${ED}" prefix=/usr install
+
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+
+ if ! use userland_GNU ; then
+ mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1 || die
+ mv "${ED}"/usr/bin/{whois,mdwhois} || die
+ fi
+}
diff --git a/sys-apps/flashrom/metadata.xml b/sys-apps/flashrom/metadata.xml
index 454e1bbd085b..efb5ba4405d1 100644
--- a/sys-apps/flashrom/metadata.xml
+++ b/sys-apps/flashrom/metadata.xml
@@ -41,7 +41,6 @@
<flag name="serprog">Enable Serial Flasher programmer</flag>
<flag name="tools">Install ich_descriptor_tool, a tool for reading descriptor-mode SPI-flash images for Intel chipsets</flag>
<flag name="usbblaster-spi">Enable support for Altera USB-Blaster dongles</flag>
- <flag name="wiki">Enable wiki informations, like supported devices etc.</flag>
</use>
<longdescription lang="en">
flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips. It is designed to flash BIOS/EFI/coreboot/firmware/optionROM images on mainboards, network/graphics/storage controller cards, and various other programmer devices.
diff --git a/sys-devel/icecream/Manifest b/sys-devel/icecream/Manifest
index 1b0adc19c2ea..7641b4101f3a 100644
--- a/sys-devel/icecream/Manifest
+++ b/sys-devel/icecream/Manifest
@@ -1,2 +1,2 @@
-DIST icecc-1.0.0.tar.bz2 485534 BLAKE2B 31a978a4a461f20716a95277426e79d4c298c212d36361dbbd68c5affcbbbe2f0c71f743cc7b731d86fbb5f09ab556182482f56e1382be8572d019f80a004fc8 SHA512 4292ecef6232112c3f4531cb2290a55f70c5c24095fef0865af2526d49fc10a043ffb06d22552e161f671c18ff1ab62795c3a63e2c8cb26f869cf65d0938af2a
DIST icecream-1.3.1.tar.gz 224068 BLAKE2B d7d66dadf27b0b88ab706bf217ce2b0d33b5db2ed95e48c4e9dcbd000931688ad6809ecbd4e14f0f3889bcebddc8543bd364c9dda09ba71e5dc04d0a5a2122d5 SHA512 d850394b4093defcf2c50bb3f9306348a45bf17d21f4730baeee7125998c2a548b7b3a7597785855d7e388e84830769bf0ec1c4136330a4c8e359cbdd111f5da
+DIST icecream-1.4.tar.gz 232707 BLAKE2B 5fdebea4d0eba4a99e8c7c01acab46ec323a887d3fe9944da23ae7089403a9ebf7bf9870ca61af49578af6adf49679341f7070f9e3da3e8c7c2f50d9d4e7c3fe SHA512 b77dd630c51b7b6b4d7fa06cd14a580891b974fe2d50074f7a3b129adc558fc7ce19b3a3716a6798c2fd0f7d0d3a1bc295bbedee3ed6dafa015f309c7c2590f5
diff --git a/sys-devel/icecream/icecream-1.0.0-r3.ebuild b/sys-devel/icecream/icecream-1.0.0-r3.ebuild
deleted file mode 100644
index 53e06f4ae2be..000000000000
--- a/sys-devel/icecream/icecream-1.0.0-r3.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P="${P/icecream/icecc}"
-
-DESCRIPTION="Distributed compiling of C(++) code across several machines; based on distcc"
-HOMEPAGE="https://github.com/icecc/icecream"
-SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
-
-DEPEND="sys-libs/libcap-ng"
-RDEPEND="
- ${DEPEND}
- acct-group/icecream
- acct-user/icecream
- dev-util/shadowman
-"
-
-PATCHES=( "${FILESDIR}/${P}-libcap-ng.patch" )
-
-src_configure() {
- local myeconfargs=(
- --enable-shared --disable-static
- --enable-clang-wrappers
- --enable-clang-rewrite-includes
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- newconfd suse/sysconfig.icecream icecream
- newinitd "${FILESDIR}"/icecream-r2 icecream
-
- insinto /etc/logrotate.d
- newins suse/logrotate icecream
-
- insinto /usr/share/shadowman/tools
- newins - icecc <<<'/usr/libexec/icecc/bin'
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_prerm() {
- if [[ -z ${REPLACED_BY_VERSION} && ${ROOT} == / ]]; then
- eselect compiler-shadow remove icecc
- fi
-}
-
-pkg_postinst() {
- if [[ ${ROOT} == / ]]; then
- eselect compiler-shadow update icecc
- fi
-}
diff --git a/sys-devel/icecream/icecream-1.4.ebuild b/sys-devel/icecream/icecream-1.4.ebuild
new file mode 100644
index 000000000000..8b29c30afdb4
--- /dev/null
+++ b/sys-devel/icecream/icecream-1.4.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+AT_NOELIBTOOLIZE="yes"
+inherit autotools systemd tmpfiles
+
+DESCRIPTION="Distributed compiler with a central scheduler to share build load"
+HOMEPAGE="https://github.com/icecc/icecream"
+SRC_URI="https://github.com/icecc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+
+DEPEND="app-arch/libarchive:=
+ app-arch/zstd:=
+ acct-user/icecream
+ acct-group/icecream
+ dev-libs/lzo:2
+ sys-libs/libcap-ng"
+RDEPEND="${DEPEND}
+ dev-util/shadowman"
+BDEPEND="app-text/docbook2X
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-clang-rewrite-includes \
+ --enable-clang-wrappers
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ systemd_dounit "${FILESDIR}"/iceccd.service
+ systemd_dounit "${FILESDIR}"/icecc-scheduler.service
+
+ newconfd suse/sysconfig.icecream icecream
+ newinitd "${FILESDIR}"/icecream.openrc icecream
+
+ keepdir /var/log/icecream
+ fowners icecream:icecream /var/log/icecream
+ fperms 0750 /var/log/icecream
+
+ newtmpfiles "${FILESDIR}"/icecream-tmpfiles.conf icecream.conf
+
+ insinto /etc/logrotate.d
+ newins suse/logrotate icecream
+
+ insinto /etc/firewalld/services
+ doins suse/iceccd.xml
+ doins suse/icecc-scheduler.xml
+
+ insinto /usr/share/shadowman/tools
+ newins - icecc <<<"${EPREFIX}"/usr/libexec/icecc/bin
+}
+
+pkg_prerm() {
+ if [[ -z ${REPLACED_BY_VERSION} && -z ${ROOT} ]] ; then
+ eselect compiler-shadow remove icecc
+ fi
+}
+
+pkg_postinst() {
+ tmpfiles_process icecream.conf
+
+ if [[ -z ${ROOT} ]] ; then
+ eselect compiler-shadow update icecc
+ fi
+}
diff --git a/x11-misc/xscreensaver/files/xscreensaver-6.03-without-gl-configure.patch b/x11-misc/xscreensaver/files/xscreensaver-6.03-without-gl-configure.patch
new file mode 100644
index 000000000000..e1996291bd3a
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-6.03-without-gl-configure.patch
@@ -0,0 +1,12 @@
+Upstream don't support this anymore (https://github.com/gentoo/gentoo/pull/24404#issuecomment-1061128526)
+but it's a trivial patch so let's keep it going for now.
+--- xscreensaver-6.03.orig/configure.ac 2022-03-04 11:23:24.415172769 -0700
++++ xscreensaver-6.03/configure.ac 2022-03-04 11:27:40.419205257 -0700
+@@ -4737,7 +4737,6 @@
+ CONF_STATUS=1
+ elif test "$with_gl_req" = no ; then
+ noteL 'The OpenGL 3D library is not being used.'
+- CONF_STATUS=1
+ else
+ noteL 'The OpenGL 3D library was not found.'
+ CONF_STATUS=1
diff --git a/x11-misc/xscreensaver/xscreensaver-6.03.ebuild b/x11-misc/xscreensaver/xscreensaver-6.03.ebuild
index 815313c79b32..c56932d1468c 100644
--- a/x11-misc/xscreensaver/xscreensaver-6.03.ebuild
+++ b/x11-misc/xscreensaver/xscreensaver-6.03.ebuild
@@ -91,6 +91,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.01-non-gtk-install.patch
"${FILESDIR}"/${PN}-6.01-gtk-detection.patch
"${FILESDIR}"/${PN}-6.01-configure-install_sh.patch
+ "${FILESDIR}"/${PN}-6.03-without-gl-configure.patch
)
DOCS=( README{,.hacking} )
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index 236b98b98dfd..e8fb708322f2 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -1,3 +1,4 @@
DIST xterm-367.tgz 1448562 BLAKE2B 29b38ba3b48c843ecbf22d209a05afb4e9a6d52cf8f14efa18ed5dd02b26cc11c107bfb17260cb62f68fc318cb08e5147b5f12e8779ca63151c7b712ada60b7e SHA512 86fd6ed4e4aa0201349edd67d8bf00d3b93a19640307372011f9bdcd26fdb453267d1ab092a0639902e419b00c175d793b196884b6e65e546650e1b83a4461c4
DIST xterm-370.tgz 1500208 BLAKE2B 973cda2511e761be64332746f004ed9ea716c8f5b7065cef2ef60d789e6186138b671920f23135b5c66d3226ce17c1d195db456350c94f5f0973e29610896b1a SHA512 24f1836c4f5aec175c45db77e9bc829b45ee2c93cf12c20252b22bee470392ef0637cfbbb6e90074b1c038ac023f74a4fb713bbd4abf2b5b86d064667caf38dd
DIST xterm-371.tgz 1507938 BLAKE2B 4ae16885bc07e7a0feb9aae29ef724f45e1170ba1eb7660c000df9a3f903c73063569d366383e7c30546480675b3fcd6513bb824ee3a5ee05155739e858360c5 SHA512 024c2cd8ab5a9da6585999907974a917497f693a0fb8cf4519c41c7e75ef2bfcc146c7078129590a836a322f7e59a550ad741b55dcbe98be6ee7988ccebe8903
+DIST xterm-372.tgz 1507107 BLAKE2B 256b99b13512740086203c4c05685cd170356118e11029a01d30b32f69c1fc5088efa0dabc955d8a24acf36f3e061faf7af9866c2302a4ac45405b97455384a0 SHA512 f65fee6227ca27be85569ec06f3701a6114489e036975d0fe37f3c71d7598d1b06c8689cfbda593a98418eec1417bd60b33e3978752b255989cfa0bb4ce332bf
diff --git a/x11-terms/xterm/xterm-372.ebuild b/x11-terms/xterm/xterm-372.ebuild
new file mode 100644
index 000000000000..9a982a2d7cbb
--- /dev/null
+++ b/x11-terms/xterm/xterm-372.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic toolchain-funcs
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="ftp://ftp.invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+DEPEND="
+ kernel_linux? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:0=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+src_configure() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+
+ # bug #454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${D}${DEFAULTS_DIR}"/XTerm-color || die
+}