summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-06-10 13:49:38 +0200
committerMichael Palimaka <kensington@gentoo.org>2017-06-11 17:19:43 +1000
commit09ea7a31f3299cb52435fd5e1bd9a6792232a1bd (patch)
tree9982f23a98eba66dae68bcde45e5bea0f146bf2d
parentmedia-video/vlc: Change URLs to https (diff)
downloadgentoo-09ea7a31f3299cb52435fd5e1bd9a6792232a1bd.tar.gz
gentoo-09ea7a31f3299cb52435fd5e1bd9a6792232a1bd.tar.bz2
gentoo-09ea7a31f3299cb52435fd5e1bd9a6792232a1bd.zip
app-admin/supervisor: bump to 3.3.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--app-admin/supervisor/Manifest1
-rw-r--r--app-admin/supervisor/supervisor-3.3.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index 7aec78a23b93..ffa74a78b33d 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -4,3 +4,4 @@ DIST supervisor-3.2.2.tar.gz 410884 SHA256 67b07b75bdf4529af0ed99f3940bac73d8bcd
DIST supervisor-3.2.3.tar.gz 411342 SHA256 3d6f0304c8ce74ab2100dfc4ab0f70050568504216f9508a81b8ed269aec9705 SHA512 53ced6e918aaf4cf780787378cf1559579c66760dc85fe07fe42554d42434ed01dc7f36b4b59bb3f56064523a51fe9f9b509bfc5d83c2306e2dcb523070c989a WHIRLPOOL 03d76d41a3c809305754e13087c183748a4c321b5e0ddf2b19a4869bffc457611946524749a80b33ee965dd52c9b9aa50212e669d87285c3201b736034b51a11
DIST supervisor-3.3.0.tar.gz 416329 SHA256 3176fb8a78c60164020e252e4a2b50b039cfec1f410b4562a843b66186188652 SHA512 cbb622522dde2bebfa98ae1eb47d747cc8e041b1a67b7708a9f1ddd50e2940af4e39fa859c02f4c431429896eb63d5be88b199921c68846ec774baad13244bb0 WHIRLPOOL 4ad6947c5ea4043785c7bd10d426c6d11ebac97e37622c0381d1f2cf62e41ae40301f48f340c2e2cfe28a24f28a6bac13ce8bc9e656b736e099725257384ad3a
DIST supervisor-3.3.1.tar.gz 415246 SHA256 fc3af22e5a7af2f6c3be787acf055c1c17777f5607cd4dc935fe633ab97061fd SHA512 e67d4e7b01f6f98a595e7524c5318e780b422a7f8f932f205c6a4d74c3c9e058b265b1732e944e5b467daa6ceffde7d1aae1f1af12c2b7c53728739edb10f740 WHIRLPOOL 744fd11df897ac25839138ce12bf194682b4d0576396b692ef2befecdffb658ed9c2a47aa2248793b082c674cb9a3dc39c0c38127e4a2da74028fb8606500336
+DIST supervisor-3.3.2.tar.gz 417348 SHA256 bbb870f5b59c5c4fd79f711553e343158b2c64688997a23a1bcb2ce643f57771 SHA512 959f045d8da5a263a6990fdc4a93154684c74cca5f49aeb733b86da046a8a3a56981062d16f0ab8177c0e0bb41f137c62e1ae6a52582e76bbe0adb2b8185202c WHIRLPOOL 2cd1bae59d187d9623089a4c9bcc11773a7fd371fc8725b34b28cd5b342391ddf92dd1c3d77f7eed53ab0209fd611fd3ce0e9b15e108b422189620d97cb37658
diff --git a/app-admin/supervisor/supervisor-3.3.2.ebuild b/app-admin/supervisor/supervisor-3.3.2.ebuild
new file mode 100644
index 000000000000..7297e311db18
--- /dev/null
+++ b/app-admin/supervisor/supervisor-3.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 ) # py2 only
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.python.org/pypi/supervisor"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/meld3[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ newinitd "${FILESDIR}/init.d-r1" supervisord
+ newconfd "${FILESDIR}/conf.d" supervisord
+ use doc && local HTML_DOCS=( docs/.build/html/. )
+ distutils-r1_python_install_all
+}