summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-02 08:33:09 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-03 23:56:35 +1300
commit0a7ec6c577185485c9c866988be0ba7ece104de7 (patch)
tree3849f90985e05c2ebc2188d28d851e5b8c8aa931
parentdev-perl/Readonly: Bump to version 2.50.0 (diff)
downloadgentoo-0a7ec6c577185485c9c866988be0ba7ece104de7.tar.gz
gentoo-0a7ec6c577185485c9c866988be0ba7ece104de7.tar.bz2
gentoo-0a7ec6c577185485c9c866988be0ba7ece104de7.zip
dev-perl/Redis: Bump to version 1.991.0
- EAPI6 - Enable tests ( Made noisy due to upstream issue ) - Add missing CPAN remote-id's Upstream: - croak when reconnecting while responses are pending - Support '0' in topic - Fix Pid=undef warnings when not connected - Don't attempt to close closed/undef sockets - Don't depend on locales for matching error messages - forbid continuing on socket after read timeout - Fix unexpected error condition 54 on freebsd - Relocate reconnection test to be independent Package-Manager: Portage-2.3.18, Repoman-2.3.6
-rw-r--r--dev-perl/Redis/Manifest1
-rw-r--r--dev-perl/Redis/Redis-1.991.0.ebuild71
-rw-r--r--dev-perl/Redis/metadata.xml7
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-perl/Redis/Manifest b/dev-perl/Redis/Manifest
index 545ad9a84104..7dee3346a318 100644
--- a/dev-perl/Redis/Manifest
+++ b/dev-perl/Redis/Manifest
@@ -1 +1,2 @@
DIST Redis-1.976.tar.gz 41598 BLAKE2B ba7d4bd844f22a0bc0c967ffc9d20635d8b406ed800e68cdf12f5193529a1b8566c293e895934983687088152216dd68f6e181810c7211ae3097ba8a02e0d265 SHA512 776ed8b1ce21dbe354c1ab1aa18a3f029899e18d764dece04d261fae029cebda064f29014391d067531befce585b604dac8b833a51db1497a3cef94212009e3b
+DIST Redis-1.991.tar.gz 47010 BLAKE2B cd8a0df3bd7781f55fda89bbb70564c5fe0640181f204e0503e1eef657cf4a6fc233677ff145fc903362782f25b17664df01d8768b01ee0a0eca03aa07242ccd SHA512 28e4c5d4c4275a9949cc25f239c1f8bdd3371bd5f5772e72e6d4c063ce1cbfec77d429e6efcf3836a397d76eb9b7351ca98585ee5697f6bfbf359c200ace7819
diff --git a/dev-perl/Redis/Redis-1.991.0.ebuild b/dev-perl/Redis/Redis-1.991.0.ebuild
new file mode 100644
index 000000000000..fd30cac11885
--- /dev/null
+++ b/dev-perl/Redis/Redis-1.991.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DAMS
+DIST_VERSION=1.991
+inherit perl-module
+
+DESCRIPTION="Perl binding for Redis database"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ >=dev-perl/IO-Socket-Timeout-0.290.0
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.39.0
+ test? (
+ !minimal? (
+ dev-db/redis
+ )
+ virtual/perl-Digest-SHA
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/IO-String
+ virtual/perl-IPC-Cmd
+ dev-perl/Test-Deep
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.980.0
+ dev-perl/Test-SharedFork
+ >=dev-perl/Test-TCP-1.190.0
+ )
+"
+
+DIST_TEST="do"
+
+src_test() {
+ local badfiles=(
+ "t/release-distmeta.t"
+ "t/release-pod-coverage.t"
+ )
+ if use minimal; then
+ einfo "Disabling Redis Server spawning tests (USE=minimal)"
+ badfiles+=(
+ t/01-basic.t
+ t/02-responses.t
+ t/03-pubsub.t
+ t/04-pipeline.t
+ t/05-nonblock.t
+ t/06-on-connect.t
+ t/07-reconnect.t
+ t/08-unix-socket.t
+ t/10-tie-list.t
+ t/11-timeout.t
+ t/20-tie-hash.t
+ t/30-scripts.t
+ t/42-client_cmds.t
+ t/44-no-unicode-bug.t
+ t/50-fork_safe.t
+ )
+ fi
+ perl_rm_files "${badfiles[@]}"
+ # https://github.com/PerlRedis/perl-redis/issues/127#issuecomment-354670681
+ export REDIS_DEBUG=1
+ perl-module_src_test
+}
diff --git a/dev-perl/Redis/metadata.xml b/dev-perl/Redis/metadata.xml
index 2b9a936fc0a1..ae11d6c57187 100644
--- a/dev-perl/Redis/metadata.xml
+++ b/dev-perl/Redis/metadata.xml
@@ -5,4 +5,11 @@
<email>perl@gentoo.org</email>
<name>Gentoo Perl Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="cpan">Redis</remote-id>
+ <remote-id type="cpan-module">Redis</remote-id>
+ <remote-id type="cpan-module">Redis::Hash</remote-id>
+ <remote-id type="cpan-module">Redis::List</remote-id>
+ <remote-id type="cpan-module">Redis::Sentinel</remote-id>
+ </upstream>
</pkgmetadata>