summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-30 03:31:20 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-30 03:32:08 +1200
commit0a85eb8118bde263cadc525af8aa030d6e7abc8f (patch)
tree35b2294f32fd8de3dd231d5c143924ac8d23fb2e
parentvirtual/perl-Time-Piece: Inherit ~riscv from dev-lang/perl (diff)
downloadgentoo-0a85eb8118bde263cadc525af8aa030d6e7abc8f.tar.gz
gentoo-0a85eb8118bde263cadc525af8aa030d6e7abc8f.tar.bz2
gentoo-0a85eb8118bde263cadc525af8aa030d6e7abc8f.zip
dev-perl/Cpanel-JSON-XS: Bump to version 4.190.0
- EAPI7 - Pass CFLAGS to make - Document optional test dependencies via wiki (WIP) - Document optional features via wiki (ugh) Upstream: - Deprecate UTF-{16,18} BOMs - Add Cpanel::JSON::XS::Type as 2nd optional encode argument - Don't call get() magic hooks twice in encode - Avoid setlocale race in threads with non-C locales when threads differ in LC_NUMERIC locale - Fix uselocale() - Various crash/fixes for Perl <5.22 - Add indent_length() setting to encoder - Add sereal support to cpanel_json_xs - Overload "ne" op for JSON::PP::Boolean - Fix bignum NaN/inf handling - Set decoded type - Add ->json_type_weaken - Add ->unblessed_bool property - Add seperate allow_dupkeys property in relaxed - Silence various -Wunused-value warnings - Fix incr_text refcounts - Rethrow error from eval_sv and eval_pv - Fix various memory corruptions (oh hai sam_c) - Add ->require_types - Allow encoding numeric values >2^64 w/ JSON_TYPE_INT/JSON_TYPE_FLOAT - Don't serialize objects when ->convert_blessed is not enabled - Use Perl_strtod to minimise discrepancy in string-to-float conversions - Add ->type_all_string for stable deterministic string types in result JSON - Fixed typed decode memory leak (hai again) Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild49
-rw-r--r--dev-perl/Cpanel-JSON-XS/Manifest1
-rw-r--r--dev-perl/Cpanel-JSON-XS/metadata.xml1
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild
new file mode 100644
index 000000000000..63619498e387
--- /dev/null
+++ b/dev-perl/Cpanel-JSON-XS/Cpanel-JSON-XS-4.190.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=RURBAN
+DIST_VERSION=4.19
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+DESCRIPTION="cPanel fork of JSON::XS, fast and correct serializing"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.160.0
+ virtual/perl-Carp
+ >=virtual/perl-Encode-1.980.100
+ virtual/perl-XSLoader
+ >=virtual/perl-podlators-2.80.0
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ virtual/perl-Time-Piece
+ )
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}
+src_test() {
+ ewarn "Comprehensive testing may require manual installation of dependencies"
+ ewarn " See: https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Tests"
+ perl-module_src_test
+}
+pkg_postinst() {
+ ewarn "This package provides 'cpanel_json_xs' in PATH, which includes optional features"
+ ewarn "otherwise not automatically made available yet. If you desire to use these,"
+ ewarn "please consult:"
+ ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Optional_Features"
+}
diff --git a/dev-perl/Cpanel-JSON-XS/Manifest b/dev-perl/Cpanel-JSON-XS/Manifest
index 2f8a6222e75e..fb2be6c27d73 100644
--- a/dev-perl/Cpanel-JSON-XS/Manifest
+++ b/dev-perl/Cpanel-JSON-XS/Manifest
@@ -1 +1,2 @@
DIST Cpanel-JSON-XS-3.0239.tar.gz 219371 BLAKE2B b03ad479cc1171d0aba84f0ba221caca14a0ac560712400632d90505e4fb74c50927cd9ad6453e91687e0b4c4f1fd2b50fa32d6355c7d46518bd63adda82734c SHA512 fee7b52f2bb48a4dc6314da4c274bb3456b6af2a0d891c1125425e5a0898e3115ea486a7dc057c25aaf7fc141bfebb5ea4341b17d00373b68a7388eb75f5bdb0
+DIST Cpanel-JSON-XS-4.19.tar.gz 251461 BLAKE2B fa22192d017fc41327e71b84f47e3939765b0c48586cc31876f744c2a51a93b36f6d41b8c9f92bba04875123604efe3fed6a486839dbfb39623cb2a4a4064087 SHA512 c67b62e8f95900cb3626357cfa9976f1553f84ffd10a977d47839ca3b317014473c3a6e48f6680478b89bbdc2ac177b22441ad5e49e7e8eb0344ef14a3c52b10
diff --git a/dev-perl/Cpanel-JSON-XS/metadata.xml b/dev-perl/Cpanel-JSON-XS/metadata.xml
index 67f963023f80..a3c4623686b0 100644
--- a/dev-perl/Cpanel-JSON-XS/metadata.xml
+++ b/dev-perl/Cpanel-JSON-XS/metadata.xml
@@ -8,5 +8,6 @@
<upstream>
<remote-id type="cpan">Cpanel-JSON-XS</remote-id>
<remote-id type="cpan-module">Cpanel::JSON::XS</remote-id>
+ <remote-id type="cpan-module">Cpanel::JSON::XS::Type</remote-id>
</upstream>
</pkgmetadata>