summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-02-02 14:28:51 -0500
committerMike Pagano <mpagano@gentoo.org>2020-02-02 14:28:51 -0500
commit0aa8735e280718890bc4b0cd4a3dccbfc177d639 (patch)
tree3a571d01698d08f3c8b2810aa44ec75f283050a5
parentapp-emulation/free42: 2.5.16 bump (diff)
downloadgentoo-0aa8735e280718890bc4b0cd4a3dccbfc177d639.tar.gz
gentoo-0aa8735e280718890bc4b0cd4a3dccbfc177d639.tar.bz2
gentoo-0aa8735e280718890bc4b0cd4a3dccbfc177d639.zip
dev-util/idea-community: Check for dir before running patchelf
Reported-by: Matt <matt@offtopica.uk> Closes: https://bugs.gentoo.org/707748 Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--dev-util/idea-community/idea-community-2019.3.2.193.6015.39.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-util/idea-community/idea-community-2019.3.2.193.6015.39.ebuild b/dev-util/idea-community/idea-community-2019.3.2.193.6015.39.ebuild
index cf7b3629f82e..b33ce52f9b75 100644
--- a/dev-util/idea-community/idea-community-2019.3.2.193.6015.39.ebuild
+++ b/dev-util/idea-community/idea-community-2019.3.2.193.6015.39.ebuild
@@ -89,10 +89,12 @@ src_prepare() {
rm -vrf "${S}"/lib/pty4j-native/linux/ppc64le || die
rm -vf "${S}"/bin/libdbm64* || die
- for file in "${S}"/"${JRE_DIR}"/lib/amd64/{libfxplugins.so,libjfxmedia.so}
- do
- patchelf --set-rpath '$ORIGIN' $file || die
- done
+ if [[ -f "${JRE_DIR}" ]]; then
+ for file in "${S}"/"${JRE_DIR}"/lib/amd64/{libfxplugins.so,libjfxmedia.so}
+ do
+ patchelf --set-rpath '$ORIGIN' $file || die
+ done
+ fi
patchelf --replace-needed liblldb.so liblldb.so.9 "${S}"/plugins/Kotlin/bin/linux/LLDBFrontend || die "Unable to patch LLDBFrontend for lldb"