summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Zero <zero-one@zer0-one.net>2020-07-06 22:58:43 -0700
committerJoonas Niilola <juippis@gentoo.org>2020-07-07 16:56:32 +0300
commit0e969fee81819f12d277177548d434ba697af02c (patch)
tree91ece888b0745ed2a3121c38bf664d3c7cfa6c9b
parentnet-misc/hylafaxplus: RedundantLongDescription (diff)
downloadgentoo-0e969fee81819f12d277177548d434ba697af02c.tar.gz
gentoo-0e969fee81819f12d277177548d434ba697af02c.tar.bz2
gentoo-0e969fee81819f12d277177548d434ba697af02c.zip
dev-libs/jansson: Version bump to 2.13.1
Signed-off-by: David Zero <zero-one@zer0-one.net> Closes: https://github.com/gentoo/gentoo/pull/16524 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/jansson/Manifest1
-rw-r--r--dev-libs/jansson/jansson-2.13.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/jansson/Manifest b/dev-libs/jansson/Manifest
index cbe7f39fe408..2064a0a73394 100644
--- a/dev-libs/jansson/Manifest
+++ b/dev-libs/jansson/Manifest
@@ -1,3 +1,4 @@
DIST jansson-2.10.tar.gz 487855 BLAKE2B b1d83ad1a37e66cb7c497284a7958882d5a7e13cec2260d9cc2b5eaef648feea66b70305dec9193f10cf77f37bdda17605277ea41735708ca6a9898b79fef807 SHA512 e331d5c097b4acb0b1df7d90d1d3453c26bd34bfe2e06af0027665bee9efecc2bc61cc7ab5b70dab1262bf80a3315ffb53b4176874fe07e20eee4b9ea7071d44
DIST jansson-2.11.tar.gz 483686 BLAKE2B 873283a1b41eef1c57fbcb3d4cdb8c33b850d95ee93c800cbcc009e3e9c9e87278beff11800e63894087e51c767dcbd555fbde48163376d53be2bf72b2eac72d SHA512 0ae77cf7ec264536313639458ba20b66e221078cddd209df3ce45c895b897799954abc1ca4b0d5993b974135652804be6bede2825503469d56303470888382f8
DIST jansson-2.12.tar.gz 489154 BLAKE2B cf6bc6d03daba921ec5e033bf57ff0055741cc935adb14d5d4a5f04056fa93c292bf88367db071ef7bb32fbc5d2d6f5f2ce658815a17939bd38ed5c0676ad091 SHA512 e40bdafdfa1fa663f71e00c06d7bfc98cff4ed3581a147894e5272e50fa5f9b9a7af6aaca41ff423a2ddd2554a192b36efcc32f6a3c98c727e9f819b955357cb
+DIST jansson-2.13.1.tar.gz 531924 BLAKE2B e627bd2ba69bf01b053ff13dee903056db86999f774d6863517e67cef7dc9ddcaa747f2edca9de86bd83f37940a394ac9907f7d58069607ee529af08d8514d57 SHA512 e32be6665e41cf1763608c2f1ac4ce0824d4d7ffa5f4a5824cefde279250fdd399d49ba93d8894e16a473731f629b846554654347f027ca9a0a96ed047f10192
diff --git a/dev-libs/jansson/jansson-2.13.1.ebuild b/dev-libs/jansson/jansson-2.13.1.ebuild
new file mode 100644
index 000000000000..d8f772c1fc15
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.13.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="https://www.digip.org/jansson/"
+SRC_URI="https://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc static-libs"
+
+BDEPEND="doc? ( <dev-python/sphinx-3.0.0 )"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake html
+ HTML_DOCS=( "${BUILD_DIR}"/doc/_build/html/. )
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}