summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-09-04 22:10:45 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-04 22:11:42 +0200
commit0eb6841a14d6e5bc5760af0f7fdbe805725b0ed7 (patch)
treead66e7832a5f8e930fb45b1e1fe8e05b04ac752e
parentx11-base/xorg-server: remove unused patch (diff)
downloadgentoo-0eb6841a14d6e5bc5760af0f7fdbe805725b0ed7.tar.gz
gentoo-0eb6841a14d6e5bc5760af0f7fdbe805725b0ed7.tar.bz2
gentoo-0eb6841a14d6e5bc5760af0f7fdbe805725b0ed7.zip
sys-apps/cpuid: Add missing sys/sysmacros.h include
Closes: https://bugs.gentoo.org/show_bug.cgi?id=604406 Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--sys-apps/cpuid/cpuid-20170122.ebuild27
-rw-r--r--sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch12
2 files changed, 27 insertions, 12 deletions
diff --git a/sys-apps/cpuid/cpuid-20170122.ebuild b/sys-apps/cpuid/cpuid-20170122.ebuild
index 3c76118816bc..90935677627f 100644
--- a/sys-apps/cpuid/cpuid-20170122.ebuild
+++ b/sys-apps/cpuid/cpuid-20170122.ebuild
@@ -3,28 +3,31 @@
EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="Utility to get detailed information about the CPU(s) using the
-CPUID instruction"
+DESCRIPTION="Utility to get detailed information about the CPU(s) using the CPUID instruction"
HOMEPAGE="http://www.etallen.com/cpuid.html"
SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
-KEYWORDS="~amd64 ~x86"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-20170122-Makefile.patch
- eapply_user
-}
+DEPEND="
+ app-arch/gzip
+ dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20170122-Makefile.patch
+ "${FILESDIR}"/${PN}-20170122-missing-include-sysmacros.patch
+)
-src_compile() {
+src_configure() {
tc-export CC
- emake || die "emake failed"
}
src_install() {
- emake BUILDROOT="${D}" install || die "email install failed"
+ emake BUILDROOT="${ED}" install
+ einstalldocs
}
diff --git a/sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch b/sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch
new file mode 100644
index 000000000000..bba18a3b3543
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20170122-missing-include-sysmacros.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=604406
+
+--- a/cpuid.c
++++ b/cpuid.c
+@@ -30,6 +30,7 @@
+ #define _GNU_SOURCE
+ #include <stdio.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+ #include <errno.h>