summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-12 11:57:13 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-12 16:25:34 +0100
commit0f69e6ab9b26f4de8c43077bfb5468422ad68f28 (patch)
treed02847dd1442d80990b8f2c2361199afe38696fc
parentsys-libs/libomp: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo (diff)
downloadgentoo-0f69e6ab9b26f4de8c43077bfb5468422ad68f28.tar.gz
gentoo-0f69e6ab9b26f4de8c43077bfb5468422ad68f28.tar.bz2
gentoo-0f69e6ab9b26f4de8c43077bfb5468422ad68f28.zip
sys-libs/llvm-libunwind: Switch to CMAKE_BUILD_TYPE=RelWithDebInfo
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
index 924684fecb92..5929692bc84d 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-9999.ebuild
@@ -5,6 +5,8 @@
EAPI=6
: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
inherit cmake-multilib git-r3
DESCRIPTION="C++ runtime stack unwinder from LLVM"
@@ -23,6 +25,9 @@ RDEPEND="!sys-libs/libunwind"
# (3.9.0 needed because cmake file install path changed)
DEPEND=">=sys-devel/llvm-3.9.0[${MULTILIB_USEDEP}]"
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
multilib_src_configure() {
local libdir=$(get_libdir)