summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-29 10:21:58 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-29 10:25:55 +0100
commit0ff25e14760c1f1cefe22f18bd0fdc5c827675d0 (patch)
tree254ab8660f47e995efb0f9d6ad037276a58bfcaf
parentsci-libs/clapack: EAPI 6 (diff)
downloadgentoo-0ff25e14760c1f1cefe22f18bd0fdc5c827675d0.tar.gz
gentoo-0ff25e14760c1f1cefe22f18bd0fdc5c827675d0.tar.bz2
gentoo-0ff25e14760c1f1cefe22f18bd0fdc5c827675d0.zip
sci-libs/clapack: Restrict tests
Gentoo-bug: 433806 Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r6.ebuild5
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r7.ebuild5
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r8.ebuild3
3 files changed, 11 insertions, 2 deletions
diff --git a/sci-libs/clapack/clapack-3.2.1-r6.ebuild b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
index b888bddf79ad..57fb494bff40 100644
--- a/sci-libs/clapack/clapack-3.2.1-r6.ebuild
+++ b/sci-libs/clapack/clapack-3.2.1-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,6 +29,9 @@ PATCHES=(
"${FILESDIR}/${P}-findblas-r6.patch"
)
+# bug 433806
+RESTRICT="test"
+
src_configure() {
filter-flags -ftree-vectorize
# causes an internal compiler error with gcc-4.6.2
diff --git a/sci-libs/clapack/clapack-3.2.1-r7.ebuild b/sci-libs/clapack/clapack-3.2.1-r7.ebuild
index e24e9fb15b1e..4004c079c2f7 100644
--- a/sci-libs/clapack/clapack-3.2.1-r7.ebuild
+++ b/sci-libs/clapack/clapack-3.2.1-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,6 +29,9 @@ PATCHES=(
"${FILESDIR}/${P}-findblas-r7.patch"
)
+# bug 433806
+RESTRICT="test"
+
src_configure() {
filter-flags -ftree-vectorize
# causes an internal compiler error with gcc-4.6.2
diff --git a/sci-libs/clapack/clapack-3.2.1-r8.ebuild b/sci-libs/clapack/clapack-3.2.1-r8.ebuild
index 8bbeb96229a7..1f7f055e6459 100644
--- a/sci-libs/clapack/clapack-3.2.1-r8.ebuild
+++ b/sci-libs/clapack/clapack-3.2.1-r8.ebuild
@@ -29,6 +29,9 @@ PATCHES=(
"${FILESDIR}/${P}-findblas-r7.patch"
)
+# bug 433806
+RESTRICT="test"
+
src_prepare() {
rm INCLUDE/f2c.h F2CLIBS/libf2c/f2c.h || die
cmake-utils_src_prepare