summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2020-12-16 13:03:58 +0100
committerUlrich Müller <ulm@gentoo.org>2020-12-16 13:09:12 +0100
commit1021d268b8b73b06b4409115af18655ea42dd7ff (patch)
tree873e4df4cff213e7573f816eca593a6b4b6edd33
parentsys-kernel/vanilla-sources: Automated version bump to {5.4.84,5.9.15} - remov... (diff)
downloadgentoo-1021d268b8b73b06b4409115af18655ea42dd7ff.tar.gz
gentoo-1021d268b8b73b06b4409115af18655ea42dd7ff.tar.bz2
gentoo-1021d268b8b73b06b4409115af18655ea42dd7ff.zip
app-admin/eselect: Version bump to 1.4.17.
Closes: https://bugs.gentoo.org/718920 Closes: https://bugs.gentoo.org/760081 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-admin/eselect/Manifest1
-rw-r--r--app-admin/eselect/eselect-1.4.17.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/eselect/Manifest b/app-admin/eselect/Manifest
index e30198740b37..ab23e24a614e 100644
--- a/app-admin/eselect/Manifest
+++ b/app-admin/eselect/Manifest
@@ -1,2 +1,3 @@
DIST eselect-1.4.15.tar.xz 178996 BLAKE2B 4354d975c8af2e1de0f0c6efe2badc92584e947f9b73c05aac144caf8f9d74c850d366c7c225112322a504262b5f285f6e2e8d32223f1b2d4bac87db740a148c SHA512 ceb55fecc2bf70e816679af9b20653b29aa9ce24ca2d4cd0c6e02ab214689459bc2ccd5b3968ac49249b8fb6613c6055e7e76598b86c6a114a9abf847c4a2b58
DIST eselect-1.4.16.tar.xz 178660 BLAKE2B dae97ee324cb67983c5395b5dc54c4b84d2da43f6a0c5c8ab81ff402ab211e9d1f1d3fe5c174b130ac1e11d3dd19e3812056274145415ee029e649cda880cd95 SHA512 264fb6122f5f7c9e73bb2250a94c3c0377e5263e2e5ae653ed58e08ebf6ed1b4aa165ae5c1d70b0156081c4db5672d1ec9d379782919d5b40a2f3e862378ce62
+DIST eselect-1.4.17.tar.xz 178980 BLAKE2B d905ac88bc009080912af75e64c7920d745788866fa3cb35466d68a652efbbd6984d6e1efeed76d9a344aed94705b74c85aa43e9c037d4d548d2e24afa69bd7a SHA512 35dc4c52f44c4f64db9c0dc2aec57b3055a6d36760b1bbbd094ad11b3f9e71a731444802632817b89c3b511f1dc9bb92046b59322d177e13fdc501ed767b591e
diff --git a/app-admin/eselect/eselect-1.4.17.ebuild b/app-admin/eselect/eselect-1.4.17.ebuild
new file mode 100644
index 000000000000..0ed9a1b499a1
--- /dev/null
+++ b/app-admin/eselect/eselect-1.4.17.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+SRC_URI="https://dev.gentoo.org/~ulm/eselect/${P}.tar.xz"
+
+LICENSE="GPL-2+ || ( GPL-2+ CC-BY-SA-4.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc emacs vim-syntax"
+
+DEPEND="sys-apps/sed
+ || (
+ sys-apps/coreutils
+ app-misc/realpath
+ )"
+RDEPEND="${DEPEND}
+ sys-apps/file
+ sys-libs/ncurses:0"
+BDEPEND="doc? ( dev-python/docutils )"
+PDEPEND="emacs? ( app-emacs/eselect-mode )
+ vim-syntax? ( app-vim/eselect-syntax )"
+
+src_compile() {
+ emake
+ use doc && emake html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ newbashcomp misc/${PN}.bashcomp ${PN}
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
+ if use doc; then
+ docinto html
+ dodoc *.html doc/*.html doc/*.css
+ fi
+
+ # needed by news module
+ keepdir /var/lib/gentoo/news
+ if ! use prefix; then
+ fowners root:portage /var/lib/gentoo/news
+ fperms g+w /var/lib/gentoo/news
+ fi
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for the portage group:
+ # merging changes the group back to root
+ if ! use prefix; then
+ chgrp portage "${EROOT}/var/lib/gentoo/news" \
+ && chmod g+w "${EROOT}/var/lib/gentoo/news"
+ fi
+}