summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-06-13 13:23:14 +0800
committerJason Zaman <perfinion@gentoo.org>2017-06-13 23:11:07 +0800
commit117180f8e0c02d8c734ebc06d8c4805e571d3c07 (patch)
tree59682554ba56a4db57e82bbc9daa5752b72f0df0
parentsys-apps/selinux-python: update live ebuild (diff)
downloadgentoo-117180f8e0c02d8c734ebc06d8c4805e571d3c07.tar.gz
gentoo-117180f8e0c02d8c734ebc06d8c4805e571d3c07.tar.bz2
gentoo-117180f8e0c02d8c734ebc06d8c4805e571d3c07.zip
sys-apps/mcstrans: bump to 2.7_rc1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--sys-apps/mcstrans/Manifest1
-rw-r--r--sys-apps/mcstrans/mcstrans-2.7_rc1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/mcstrans/Manifest b/sys-apps/mcstrans/Manifest
new file mode 100644
index 000000000000..b5986e55e0cf
--- /dev/null
+++ b/sys-apps/mcstrans/Manifest
@@ -0,0 +1 @@
+DIST mcstrans-2.7-rc1.tar.gz 41124 SHA256 5e80b7dc9fc0204a2d561941ea8b220193cf3d34dba9ac527878a7ee036be01d SHA512 c0db564a693e3dc81759df54ce1b3e4ce6fdb22f3b0a998f4f31919644bae086d22acf6f248d789df1de24fb3d1d3a17bc45f9c39f8ed5b02467ac05177529fa WHIRLPOOL b2164b2005a3d30963c86301bc1f76d39605d7d72e055e12cafd6cc645c2bcde54f773c41db842ab830becd69454519a628754bd6041d3a45b9a56ee55489740
diff --git a/sys-apps/mcstrans/mcstrans-2.7_rc1.ebuild b/sys-apps/mcstrans/mcstrans-2.7_rc1.ebuild
new file mode 100644
index 000000000000..b638a53b5ce0
--- /dev/null
+++ b/sys-apps/mcstrans/mcstrans-2.7_rc1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+MY_RELEASEDATE="20170609"
+
+MY_P="${P//_/-}"
+IUSE=""
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
+ S="${WORKDIR}/${MY_P}/${PN}"
+else
+ SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="SELinux context translation to human readable names"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-libs/libsepol-${PV}:=
+ >=sys-libs/libselinux-${PV}:=
+ dev-libs/libpcre:=
+ >=sys-libs/libcap-1.10-r10:="
+
+RDEPEND="${DEPEND}
+ !<sys-apps/policycoreutils-2.7_pre"
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror"
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ LIBDIR="\$(PREFIX)/$(get_libdir)" \
+ install
+
+ rm -rf "${D}/etc/rc.d" || die
+
+ newinitd "${FILESDIR}/mcstransd.init" mcstransd
+}