summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-19 09:22:28 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-20 00:43:28 +0100
commit12bf56877b66b78d488e1b2c763c3c7c4b17d433 (patch)
tree7190106de4236becc78c68c7efdee5d4035d122a
parentsys-power/phctool: python-single-r1, EAPI=6 (diff)
downloadgentoo-12bf56877b66b78d488e1b2c763c3c7c4b17d433.tar.gz
gentoo-12bf56877b66b78d488e1b2c763c3c7c4b17d433.tar.bz2
gentoo-12bf56877b66b78d488e1b2c763c3c7c4b17d433.zip
x11-misc/chgres: EAPI bump 4 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4029
-rw-r--r--x11-misc/chgres/chgres-0.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/chgres/chgres-0.1-r2.ebuild b/x11-misc/chgres/chgres-0.1-r2.ebuild
new file mode 100644
index 000000000000..774b0f55e6f2
--- /dev/null
+++ b/x11-misc/chgres/chgres-0.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A very simple command line utility for changing X resolutions"
+HOMEPAGE="http://hpwww.ec-lyon.fr/~vincent/"
+SRC_URI="http://hpwww.ec-lyon.fr/~vincent/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXxf86dga
+ x11-libs/libXext
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ x11-proto/xf86dgaproto"
+
+PATCHES=( "${FILESDIR}"/${P}-{flags,includes}.patch )
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_install() {
+ dobin chgres
+ einstalldocs
+}