summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-08-05 21:25:25 +1200
committerKent Fredric <kentnl@gentoo.org>2016-08-05 21:25:39 +1200
commit132450d0e56aba7fe7690aefffa766a01438c7bf (patch)
treeece271c31975a8df5fae9b55518109b272e53e06
parentdev-java/icedtea: Remove old 7.2.6.6 (diff)
downloadgentoo-132450d0e56aba7fe7690aefffa766a01438c7bf.tar.gz
gentoo-132450d0e56aba7fe7690aefffa766a01438c7bf.tar.bz2
gentoo-132450d0e56aba7fe7690aefffa766a01438c7bf.zip
dev-perl/XML-RSS: Remove POD/Author tests.
This is a little unusual because they've subclassed Module::Build to so some horrible things that mean there are *2* manifests, one for tests which it also pointlessly tests. So stock deleting the bad tests results in test failures. The only way to subjugate this bad behaviour is patch out the use of the test-specific sub-class to avoid those pointless testing shenanigans. Package-Manager: portage-2.3.0 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
-rw-r--r--dev-perl/XML-RSS/XML-RSS-1.540.0-r1.ebuild14
-rw-r--r--dev-perl/XML-RSS/XML-RSS-1.560.0.ebuild15
-rw-r--r--dev-perl/XML-RSS/XML-RSS-1.590.0.ebuild14
-rw-r--r--dev-perl/XML-RSS/files/nomanifest.patch26
4 files changed, 53 insertions, 16 deletions
diff --git a/dev-perl/XML-RSS/XML-RSS-1.540.0-r1.ebuild b/dev-perl/XML-RSS/XML-RSS-1.540.0-r1.ebuild
index 241bf3af8d9f..4bd6f1ee9a9f 100644
--- a/dev-perl/XML-RSS/XML-RSS-1.540.0-r1.ebuild
+++ b/dev-perl/XML-RSS/XML-RSS-1.540.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,7 +23,13 @@ RDEPEND="dev-perl/HTML-Parser
>=dev-perl/XML-Parser-2.30"
DEPEND="${RDEPEND}
dev-perl/Module-Build
- test? ( dev-perl/Test-Pod
- dev-perl/Test-Pod-Coverage
- >=dev-perl/Test-Manifest-0.9 )"
+ test? ( virtual/perl-Test-Simple )"
#dev-perl/Test-Differences
+
+PATCHES=(
+ "${FILESDIR}/nomanifest.patch"
+)
+src_test() {
+ perl_rm_files t/pod{,-coverage}.t t/cpan-changes.t t/style-trailing-space.t
+ perl-module_src_test
+}
diff --git a/dev-perl/XML-RSS/XML-RSS-1.560.0.ebuild b/dev-perl/XML-RSS/XML-RSS-1.560.0.ebuild
index 68cef289955b..20a82e89e0d0 100644
--- a/dev-perl/XML-RSS/XML-RSS-1.560.0.ebuild
+++ b/dev-perl/XML-RSS/XML-RSS-1.560.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,7 +23,14 @@ RDEPEND="dev-perl/HTML-Parser
>=dev-perl/XML-Parser-2.30"
DEPEND="${RDEPEND}
dev-perl/Module-Build
- test? ( dev-perl/Test-Pod
- dev-perl/Test-Pod-Coverage
- >=dev-perl/Test-Manifest-0.9 )"
+ test? ( virtual/perl-Test-Simple )"
#dev-perl/Test-Differences
+
+PATCHES=(
+ "${FILESDIR}/nomanifest.patch"
+)
+
+src_test() {
+ perl_rm_files t/pod{,-coverage}.t t/cpan-changes.t t/style-trailing-space.t
+ perl-module_src_test
+}
diff --git a/dev-perl/XML-RSS/XML-RSS-1.590.0.ebuild b/dev-perl/XML-RSS/XML-RSS-1.590.0.ebuild
index 27a292597433..27a6f75c528c 100644
--- a/dev-perl/XML-RSS/XML-RSS-1.590.0.ebuild
+++ b/dev-perl/XML-RSS/XML-RSS-1.590.0.ebuild
@@ -24,16 +24,14 @@ RDEPEND="
>=dev-perl/XML-Parser-2.230.0"
DEPEND="${RDEPEND}
>=dev-perl/Module-Build-0.360.0
- test? (
- >=dev-perl/Test-Manifest-0.900
- virtual/perl-Test-Simple
- )
+ test? ( virtual/perl-Test-Simple )
"
+
+PATCHES=(
+ "${FILESDIR}/nomanifest.patch"
+)
+
src_test() {
- # Ugh. Why does this havce to be so difficult.
perl_rm_files t/pod{,-coverage}.t t/cpan-changes.t t/style-trailing-space.t
- sed -i -e '/^pod.*t/d' "${S}/t/test_manifest" || die
- sed -i -e '/^cpan-changes\.t/d' "${S}/t/test_manifest" || die
- sed -i -e '/^style-trailing-space\.t/d' "${S}/t/test_manifest" || die
perl-module_src_test
}
diff --git a/dev-perl/XML-RSS/files/nomanifest.patch b/dev-perl/XML-RSS/files/nomanifest.patch
new file mode 100644
index 000000000000..fcade6be4cc0
--- /dev/null
+++ b/dev-perl/XML-RSS/files/nomanifest.patch
@@ -0,0 +1,26 @@
+diff --git a/Build.PL b/Build.PL
+index 010efb6..4559535 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -2,11 +2,10 @@ use strict;
+ use warnings;
+
+ use File::Spec;
+-use lib File::Spec->catdir(File::Spec->curdir(), "inc");
+
+-use Test::Run::Builder::Manifest;
++use Module::Build;
+
+-my $build = Test::Run::Builder::Manifest->new(
++my $build = Module::Build->new(
+ 'module_name' => "XML::RSS",
+ 'requires' =>
+ {
+@@ -19,7 +18,6 @@ my $build = Test::Run::Builder::Manifest->new(
+ },
+ build_requires =>
+ {
+- 'Test::Manifest' => '0.9',
+ 'Test::More' => 0,
+ },
+ configure_requires =>