summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2017-01-21 21:00:09 +0100
committerPacho Ramos <pacho@gentoo.org>2017-01-21 21:04:51 +0100
commit13587dfaa397142c61343c2ca631fa383f9f4ff8 (patch)
treeb088eb09847df4a3bdc0ba4adfac48a05d75ab8c
parentmedia-libs/freeimage: Add patches for CVE-2015-0852 and CVE-2016-5684 (diff)
downloadgentoo-13587dfaa397142c61343c2ca631fa383f9f4ff8.tar.gz
gentoo-13587dfaa397142c61343c2ca631fa383f9f4ff8.tar.bz2
gentoo-13587dfaa397142c61343c2ca631fa383f9f4ff8.zip
app-misc/tracker: Version bump, handle optional (and recommended, default on) seccomp support via USE flag as suggested by vapier in bug #602138.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-misc/tracker/Manifest1
-rw-r--r--app-misc/tracker/tracker-1.8.3.ebuild261
2 files changed, 262 insertions, 0 deletions
diff --git a/app-misc/tracker/Manifest b/app-misc/tracker/Manifest
index a6b0aba57f31..baa32f90732e 100644
--- a/app-misc/tracker/Manifest
+++ b/app-misc/tracker/Manifest
@@ -2,3 +2,4 @@ DIST tracker-1.10.1.tar.xz 5027912 SHA256 67ea78cca8ebbd6633dddcdd40b5205683cc88
DIST tracker-1.8.0.tar.xz 4961488 SHA256 a11f31a373bfec3abae38ae719d0a59f666f1f067d8789ade2ed7032a152907d SHA512 c7d0600cfcf5485188167d237e22a00a5777b97b96c8735ba3efcef67288a8d9db9476f05289cf1498c50432981a4bc932973241138ea116a18e421576ed3cdd WHIRLPOOL 2941ab228ccaae96abf8ad1387d898981aae9611aaaa64425df21fb941ca4f49e485dfb094b191b1ec46f1b83f5e248fbce700b18b232209866fdb248b4bba53
DIST tracker-1.8.1.tar.xz 4985828 SHA256 e3ed4cb384486ebc086adfad68b5d25f8b0424eb6eb1aca2252a508b757fbe51 SHA512 2a1fa2a7d516c33290a7db52e33bb2ab7133ac543985f81136169f211ce42bd9b2e8539826e4da8acf365d9d49eb57a13bb4fd88d6523308af674ddd856bd2d9 WHIRLPOOL 00fc951d3faa1ec20289699d112669ec62ae7c87ecaf560d52936cd14076355b1610259ab5abab5b88e8ae7e93c18e3bb08c5946fef7bd04afd0befee27de9c9
DIST tracker-1.8.2.tar.xz 4986908 SHA256 b93efbf077901315433a26b822ed6fb47a2592ee9d0fc7e054fe39a9968fa451 SHA512 6573597a847880d3f4fd1217a686ff47fbcfeee4da9019047362e111c1d196b420662dc5cbfad6f0d58605c8dee1ef50ffd6a5d9e7d0e1fc71c64780999a84c7 WHIRLPOOL 21737ba0b8b950dcb41b423d824b225e57fb62a5fff153417caf67be66287e72da8db906cc0b03d7928bd90540377f2713430d277440b4cdbd01cceb6087218a
+DIST tracker-1.8.3.tar.xz 4985156 SHA256 9bbf8c8525b3a1496716a350bc50ba06af5e880a4386506ca3e45d6779065c42 SHA512 122d84d88fb170c0b9f3db0038ada88b9cca75698d1d3bc6a70d019e97ad77a9b21e145b9ec23c0eb9f46778505438ff30f131b4719d3126178cd7ddd752eccd WHIRLPOOL 75a14ca80ceeb23a7d7985cf22f72c88e2c11a4e69c107cbe536575a6fbce335268dcb9fe8514da8f98ebfbbdf59a63d7253fc5de5abf9d64b3a508bd355843d
diff --git a/app-misc/tracker/tracker-1.8.3.ebuild b/app-misc/tracker/tracker-1.8.3.ebuild
new file mode 100644
index 000000000000..84c1b7dfad79
--- /dev/null
+++ b/app-misc/tracker/tracker-1.8.3.ebuild
@@ -0,0 +1,261 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_EAUTORECONF="yes" # See bug #367975
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools bash-completion-r1 gnome2 linux-info python-any-r1 vala versionator virtualx
+
+DESCRIPTION="A tagging metadata database, search tool and indexer"
+HOMEPAGE="https://wiki.gnome.org/Projects/Tracker"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0/100"
+# Once sys-power/upower-pm-utils is not needed by other reverse deps for
+# suspending, we can drop it from here as this doesn't rely on the dead
+# suspend support from old upower
+IUSE="cue elibc_glibc exif ffmpeg firefox-bookmarks flac gif gsf
+gstreamer gtk iptc +iso +jpeg libav +miner-fs mp3 nautilus networkmanager
+pdf playlist rss +seccomp stemmer test thunderbird +tiff upnp-av upower +vorbis +xml xmp xps"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+REQUIRED_USE="
+ ?? ( gstreamer ffmpeg )
+ cue? ( gstreamer )
+ upnp-av? ( gstreamer )
+ !miner-fs? ( !cue !exif !flac !gif !gsf !iptc !iso !jpeg !mp3 !pdf !playlist !tiff !vorbis !xml !xmp !xps )
+"
+
+# According to NEWS, introspection is non-optional
+# glibc-2.12 needed for SCHED_IDLE (see bug #385003)
+RDEPEND="
+ >=app-i18n/enca-1.9
+ >dev-db/sqlite-3.8.4.2:=
+ >=dev-libs/glib-2.40:2
+ >=dev-libs/gobject-introspection-0.9.5:=
+ >=dev-libs/icu-4.8.1.1:=
+ || (
+ >=media-gfx/imagemagick-5.2.1[png,jpeg?]
+ media-gfx/graphicsmagick[imagemagick,png,jpeg?] )
+ >=media-libs/libpng-1.2:0=
+ >=media-libs/libmediaart-1.9:2.0
+ sys-apps/util-linux
+ >=x11-libs/pango-1:=
+
+ cue? ( media-libs/libcue )
+ elibc_glibc? ( >=sys-libs/glibc-2.12 )
+ exif? ( >=media-libs/libexif-0.6 )
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ firefox-bookmarks? ( || (
+ >=www-client/firefox-4.0
+ >=www-client/firefox-bin-4.0 ) )
+ flac? ( >=media-libs/flac-1.2.1 )
+ gif? ( media-libs/giflib:= )
+ gsf? ( >=gnome-extra/libgsf-1.14.24:0= )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ gtk? (
+ >=dev-libs/libgee-0.3:0.8=
+ >=x11-libs/gtk+-3:3 )
+ iptc? ( media-libs/libiptcdata )
+ iso? ( >=sys-libs/libosinfo-0.2.9:= )
+ jpeg? ( virtual/jpeg:0 )
+ upower? ( || ( >=sys-power/upower-0.9 sys-power/upower-pm-utils ) )
+ mp3? ( >=media-libs/taglib-1.6 )
+ networkmanager? ( >=net-misc/networkmanager-0.8:= )
+ pdf? (
+ >=x11-libs/cairo-1:=
+ >=app-text/poppler-0.16:=[cairo,utils]
+ >=x11-libs/gtk+-2.12:2 )
+ playlist? ( >=dev-libs/totem-pl-parser-3:= )
+ rss? ( >=net-libs/libgrss-0.7:0 )
+ seccomp? ( >=sys-libs/libseccomp-2.0 )
+ stemmer? ( dev-libs/snowball-stemmer )
+ thunderbird? ( || (
+ >=mail-client/thunderbird-5.0
+ >=mail-client/thunderbird-bin-5.0 ) )
+ tiff? ( media-libs/tiff:0 )
+ upnp-av? ( >=media-libs/gupnp-dlna-0.9.4:2.0 )
+ vorbis? ( >=media-libs/libvorbis-0.22 )
+ xml? ( >=dev-libs/libxml2-2.6 )
+ xmp? ( >=media-libs/exempi-2.1:2 )
+ xps? ( app-text/libgxps )
+ !gstreamer? ( !ffmpeg? ( || ( media-video/totem media-video/mplayer ) ) )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/gdbus-codegen
+ >=dev-libs/libxslt-1
+ >=dev-util/gtk-doc-am-1.8
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ gtk? ( >=dev-libs/libgee-0.3:0.8 )
+ test? (
+ >=dev-libs/dbus-glib-0.82-r1
+ >=sys-apps/dbus-1.3.1[X] )
+"
+PDEPEND="nautilus? ( ~gnome-extra/nautilus-tracker-tags-${PV} )"
+
+function inotify_enabled() {
+ if linux_config_exists; then
+ if ! linux_chkconfig_present INOTIFY_USER; then
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify support for userland' under the 'File systems'"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
+ die 'missing CONFIG_INOTIFY'
+ fi
+ else
+ einfo "Could not check for INOTIFY support in your kernel."
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ inotify_enabled
+
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't run 'firefox --version' or 'thunderbird --version'; it results in
+ # access violations on some setups (bug #385347, #385495).
+ create_version_script "www-client/firefox" "Mozilla Firefox" firefox-version.sh
+ create_version_script "mail-client/thunderbird" "Mozilla Thunderbird" thunderbird-version.sh
+
+ # Looks like sorting got fixed but not test reference files, bug #????
+ sort "${S}"/tests/libtracker-data/functions/functions-tracker-1.out \
+ -o "${S}"/tests/libtracker-data/functions/functions-tracker-1.out || die
+ sort "${S}"/tests/libtracker-data/functions/functions-tracker-2.out \
+ -o "${S}"/tests/libtracker-data/functions/functions-tracker-2.out || die
+
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+
+ if use gstreamer ; then
+ myconf="${myconf} --enable-generic-media-extractor=gstreamer"
+ if use upnp-av; then
+ myconf="${myconf} --with-gstreamer-backend=gupnp-dlna"
+ else
+ myconf="${myconf} --with-gstreamer-backend=discoverer"
+ fi
+ elif use ffmpeg ; then
+ myconf="${myconf} --enable-generic-media-extractor=libav"
+ else
+ myconf="${myconf} --enable-generic-media-extractor=external"
+ fi
+
+ # unicode-support: libunistring, libicu or glib ?
+ # According to NEWS, introspection is required
+ # is not being generated
+ # nautilus extension is in a separate package, nautilus-tracker-tags
+ # miner-evolution disabled as it's incompatible with current eds
+ gnome2_src_configure \
+ --disable-hal \
+ --disable-miner-evolution \
+ --disable-nautilus-extension \
+ --disable-static \
+ --enable-abiword \
+ --enable-artwork \
+ --enable-cfg-man-pages \
+ --enable-dvi \
+ --enable-enca \
+ --enable-guarantee-metadata \
+ --enable-icon \
+ --enable-introspection \
+ --enable-libmediaart \
+ --enable-libpng \
+ --enable-miner-apps \
+ --enable-miner-user-guides \
+ --enable-ps \
+ --enable-text \
+ --enable-tracker-fts \
+ --enable-tracker-writeback \
+ --with-unicode-support=libicu \
+ --with-bash-completion-dir="$(get_bashcompdir)" \
+ $(use_enable cue libcue) \
+ $(use_enable exif libexif) \
+ $(use_enable firefox-bookmarks miner-firefox) \
+ $(use_with firefox-bookmarks firefox-plugin-dir "${EPREFIX}"/usr/$(get_libdir)/firefox/extensions) \
+ FIREFOX="${S}"/firefox-version.sh \
+ $(use_enable flac libflac) \
+ $(use_enable gif libgif) \
+ $(use_enable gsf libgsf) \
+ $(use_enable gtk tracker-needle) \
+ $(use_enable gtk tracker-preferences) \
+ $(use_enable iptc libiptcdata) \
+ $(use_enable iso libosinfo) \
+ $(use_enable jpeg libjpeg) \
+ $(use_enable upower upower) \
+ $(use_enable miner-fs) \
+ $(use_enable mp3 taglib) \
+ $(use_enable mp3) \
+ $(use_enable networkmanager network-manager) \
+ $(use_enable pdf poppler) \
+ $(use_enable playlist) \
+ $(use_enable rss miner-rss) \
+ $(use_enable stemmer libstemmer) \
+ $(use_enable test functional-tests) \
+ $(use_enable test unit-tests) \
+ $(use_enable thunderbird miner-thunderbird) \
+ $(use_with thunderbird thunderbird-plugin-dir "${EPREFIX}"/usr/$(get_libdir)/thunderbird/extensions) \
+ THUNDERBIRD="${S}"/thunderbird-version.sh \
+ $(use_enable tiff libtiff) \
+ $(use_enable vorbis libvorbis) \
+ $(use_enable xml libxml2) \
+ $(use_enable xmp exempi) \
+ $(use_enable xps libgxps) \
+ ${myconf}
+}
+
+src_test() {
+ # G_MESSAGES_DEBUG, upstream bug #699401#c1
+ virtx emake check TESTS_ENVIRONMENT="dbus-run-session" G_MESSAGES_DEBUG="all"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Manually symlink extensions for {firefox,thunderbird}-bin
+ if use firefox-bookmarks; then
+ dosym /usr/share/xul-ext/trackerfox \
+ /usr/$(get_libdir)/firefox-bin/extensions/trackerfox@bustany.org
+ fi
+
+ if use thunderbird; then
+ dosym /usr/share/xul-ext/trackerbird \
+ /usr/$(get_libdir)/thunderbird-bin/extensions/trackerbird@bustany.org
+ fi
+}
+
+create_version_script() {
+ # Create script $3 that prints "$2 MAX(VERSION($1), VERSION($1-bin))"
+
+ local v=$(best_version ${1})
+ v=${v#${1}-}
+ local vbin=$(best_version ${1}-bin)
+ vbin=${vbin#${1}-bin-}
+
+ if [[ -z ${v} ]]; then
+ v=${vbin}
+ else
+ version_compare ${v} ${vbin}
+ [[ $? -eq 1 ]] && v=${vbin}
+ fi
+
+ echo -e "#!/bin/sh\necho $2 $v" > "$3" || die
+ chmod +x "$3" || die
+}