summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-06-20 00:48:01 -0400
committerAaron Bauman <bman@gentoo.org>2020-06-20 00:48:01 -0400
commit157b2f4a82f1caa549c77eb070a1f2eae0c69811 (patch)
tree043cf11c0b250f640145bcd0d301fd2c9860b269
parentapp-shells/rssh: drop last-rited pkg (diff)
downloadgentoo-157b2f4a82f1caa549c77eb070a1f2eae0c69811.tar.gz
gentoo-157b2f4a82f1caa549c77eb070a1f2eae0c69811.tar.bz2
gentoo-157b2f4a82f1caa549c77eb070a1f2eae0c69811.zip
dev-python/restkit: drop last-rited pkg
Bug: https://bugs.gentoo.org/544228 Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-python/restkit/Manifest1
-rw-r--r--dev-python/restkit/files/setup.patch23
-rw-r--r--dev-python/restkit/metadata.xml12
-rw-r--r--dev-python/restkit/restkit-4.2.2.ebuild55
-rw-r--r--profiles/package.mask6
5 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/restkit/Manifest b/dev-python/restkit/Manifest
deleted file mode 100644
index 0ae02e7379f7..000000000000
--- a/dev-python/restkit/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST restkit-4.2.2.tar.gz 1275904 BLAKE2B 4ebfc3ad91265954c28712e4beadcb25a467fe7af8c68bb655016ddb20877ca63275136605400c59b462825526a59f69d69d4b687641816b4704b62623498734 SHA512 5ed08535e1a54b5594d97b059d8662ab4bc19c68e71a30719c4a533cba0f2d0e18872119752c62136563a32281e8f747414fbf843fd97dba138107ffcb5d1e4b
diff --git a/dev-python/restkit/files/setup.patch b/dev-python/restkit/files/setup.patch
deleted file mode 100644
index cfa8959539e1..000000000000
--- a/dev-python/restkit/files/setup.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -ur restkit-4.2.2.org/setup.py restkit-4.2.2/setup.py
---- setup.py 2013-08-30 23:07:36.000000000 +0800
-+++ setup.py 2015-01-16 21:38:04.342084550 +0800
-@@ -38,11 +38,6 @@
- with open(os.path.join(os.path.dirname(__file__), 'README.rst')) as f:
- long_description = f.read()
-
-- DATA_FILES = [
-- ('restkit', ["LICENSE", "MANIFEST.in", "NOTICE", "README.rst",
-- "THANKS", "TODO.txt"])
-- ]
--
- options=dict(
- name = 'restkit',
- version = version.__version__,
-@@ -54,7 +49,6 @@
- url = 'http://benoitc.github.com/restkit',
- classifiers = CLASSIFIERS,
- packages = find_packages(exclude=['tests']),
-- data_files = DATA_FILES,
- scripts = SCRIPTS,
- zip_safe = False,
- entry_points = {
diff --git a/dev-python/restkit/metadata.xml b/dev-python/restkit/metadata.xml
deleted file mode 100644
index 10ec59022ed9..000000000000
--- a/dev-python/restkit/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <use>
- <flag name="cli">Install the restcli command line interface/tool, based on <pkg>dev-python/ipython</pkg></flag>
- </use>
- <upstream>
- <remote-id type="pypi">restkit</remote-id>
- <remote-id type="github">benoitc/restkit</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/restkit/restkit-4.2.2.ebuild b/dev-python/restkit/restkit-4.2.2.ebuild
deleted file mode 100644
index bb7283b0aaa9..000000000000
--- a/dev-python/restkit/restkit-4.2.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="A HTTP ressource kit for Python"
-HOMEPAGE="https://github.com/benoitc/restkit"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ppc64 s390 x86"
-IUSE="+cli doc examples test"
-RESTRICT="!test? ( test )"
-
-PY27_USEDEP="$(python_gen_usedep python2_7)"
-RDEPEND="cli? ( dev-python/ipython[${PY27_USEDEP}] )
- dev-python/webob[${PYTHON_USEDEP}]
- >=dev-python/socketpool-0.5.3[${PYTHON_USEDEP}]
- >=dev-python/http-parser-0.8.3[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/epydoc[${PY27_USEDEP}] )
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-# prevent duplicate install of data files
-PATCHES=( "${FILESDIR}"/setup.patch )
-
-python_compile_all() {
- if use doc ; then
- pushd doc > /dev/null
- emake html
- popd > /dev/null
- fi
-}
-
-python_test() {
- nosetests tests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use cli || rm "${D}"/usr/bin/restcli* || die
- use doc && local HTML_DOCS=( doc/_build/html/. )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index 7c1b0c29f548..f98e227d59c3 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -263,12 +263,6 @@ dev-python/pygtksourceview
# Not useful anymore now that metasploit has been removed.
app-eselect/eselect-metasploit
-# Michał Górny <mgorny@gentoo.org> (2020-05-18)
-# Unmaintained and vulnerable. Last commit in 2015. Stuck on Python 2.
-# All reverse dependencies removed restkit support upstream.
-# Removal in 30 days. Bug #544228.
-dev-python/restkit
-
# Aaron W. Swenson <titanofold@gentoo.org> (2020-05-15)
# PostgreSQL 9.4 series is EOL. Migrate your database cluster to a more recent
# version.