summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-18 11:59:53 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-18 12:00:04 +0100
commit1632d5b06535a12223116ae0661259b80b8fc779 (patch)
tree55e28b83154199c854c94f1d70a9fb03c1dcb49d
parentdev-python/python-ddp: initial import; ebuild by me (diff)
downloadgentoo-1632d5b06535a12223116ae0661259b80b8fc779.tar.gz
gentoo-1632d5b06535a12223116ae0661259b80b8fc779.tar.bz2
gentoo-1632d5b06535a12223116ae0661259b80b8fc779.zip
dev-python/python-meteor: initial import; ebuild by me
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-python/python-meteor/Manifest1
-rw-r--r--dev-python/python-meteor/metadata.xml13
-rw-r--r--dev-python/python-meteor/python-meteor-0.1.6.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-meteor/Manifest b/dev-python/python-meteor/Manifest
new file mode 100644
index 000000000000..96bfb6f2525b
--- /dev/null
+++ b/dev-python/python-meteor/Manifest
@@ -0,0 +1 @@
+DIST python-meteor-0.1.6.tar.gz 7656 SHA256 014bd2fd61e73e8f67892a0114fbcb3185db3bc74f70990379aedb5b359a8667 SHA512 c654113714e7a4311d66d7390a996cce126bed2270e15f22791ddb8cec1afd5af321f24c8a83d8dc491c0959b8410fa91d43e2025534390486283f2da78a2233 WHIRLPOOL ab22fe7e64948b2c14aba8c67b36d1426b2183fb87a2c945521c81917f7d231a099101e1ff09a4d2a0e98565ad02947adebabf242ab11137e8a79f0bed2357ac
diff --git a/dev-python/python-meteor/metadata.xml b/dev-python/python-meteor/metadata.xml
new file mode 100644
index 000000000000..f2576bf50117
--- /dev/null
+++ b/dev-python/python-meteor/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-meteor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-meteor/python-meteor-0.1.6.ebuild b/dev-python/python-meteor/python-meteor-0.1.6.ebuild
new file mode 100644
index 000000000000..9c7cfa8a75f2
--- /dev/null
+++ b/dev-python/python-meteor/python-meteor-0.1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="An event driven meteor client"
+HOMEPAGE="https://pypi.python.org/pypi/python-meteor https://github.com/hharnisc/python-meteor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-python/python-ddp[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"