summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-01-04 21:39:26 +0100
committerMichał Górny <mgorny@gentoo.org>2018-01-04 22:50:34 +0100
commit164bf52e01120da2bf27b3cfffaf779c48d43293 (patch)
treec46c6c6ac14b3f275660934faf601dcd99e42e51
parentdev-python/jingo: Clean old up (diff)
downloadgentoo-164bf52e01120da2bf27b3cfffaf779c48d43293.tar.gz
gentoo-164bf52e01120da2bf27b3cfffaf779c48d43293.tar.bz2
gentoo-164bf52e01120da2bf27b3cfffaf779c48d43293.zip
dev-python/jinja: Clean old up
-rw-r--r--dev-python/jinja/Manifest2
-rw-r--r--dev-python/jinja/jinja-2.8.ebuild73
-rw-r--r--dev-python/jinja/jinja-2.9.6.ebuild72
3 files changed, 0 insertions, 147 deletions
diff --git a/dev-python/jinja/Manifest b/dev-python/jinja/Manifest
index d97b961e2bbc..3c0413ac2b68 100644
--- a/dev-python/jinja/Manifest
+++ b/dev-python/jinja/Manifest
@@ -1,4 +1,2 @@
-DIST Jinja2-2.8.tar.gz 357055 BLAKE2B dff1f706ccae2e63a973195d77ded0c59bd8042ba5e8e269031ed97c090eea1a69572a866f6fb9c8afbd7a0e2ab3e414786c6b7d0153da558bbad38e2847d5ce SHA512 2e80d6d9ad10dafcce1e6dd24493f5dffc43a17f71a30a650415638e12d3a3891738ebacc569701129214026d062d91a2b10e4f7a2c7b85d801dde26ded1bebb
DIST jinja-2.10.tar.gz 267508 BLAKE2B 3872a073bd3954a079aee74fb2f23815f75559a88a8ab6d849cc9855e158d096a1ac62c219ae7f48a54d082c3073e83749c8536439248c80494e882f6a18995f SHA512 bdfd3c4d01b39827c128cbd7f6ebc0ad1434748be41c5037ba1b23156eea1d28f805ffe2a051b4e9b5b38938615c35c8876095b0bf0bed2c139cf5ea49ae2420
DIST jinja-2.9.5.tar.gz 486763 BLAKE2B 680b8d58056b180295b52998a573da2fe86ac8b117a942e647626aef16d42c7af89a0ba7f5ab098fcdb29bd18940e316144fea1882e15d71f67bda945b4a6ab8 SHA512 15c1b79981c4d6fcbb7fa947fe0fd7e43973433c03d6549a84deec8ad70881f7fd0d3a35160bf6371361994f838da7eb478c577de2612e004679ae51bd97b121
-DIST jinja-2.9.6.tar.gz 487185 BLAKE2B 32f11030cec4fc085c6b866e0409a7b04f008720fc13e619f168e5fb5b4eee340beea7761c42940fcbe24a032548866ddf7938d7c06a6e38e6e898bc334af94c SHA512 934e253d9d621fd6d19302ea5e73b571a806c0e31e10ac29b54700ad6649fabf321b00cdc513bb3fb551ee28e83de7f163ce9ef88d232a6c178f4ee5dc2e69b5
diff --git a/dev-python/jinja/jinja-2.8.ebuild b/dev-python/jinja/jinja-2.8.ebuild
deleted file mode 100644
index 2c30af4afbf0..000000000000
--- a/dev-python/jinja/jinja-2.8.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit eutils distutils-r1
-
-MY_PN=Jinja2
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="A small but fast and easy to use stand-alone template engine written in pure Python"
-HOMEPAGE="http://jinja.pocoo.org/ https://pypi.python.org/pypi/Jinja2"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
-IUSE="doc examples"
-
-RDEPEND="
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- !dev-python/jinja:compat"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-# XXX: handle Babel better?
-
-S=${WORKDIR}/${MY_P}
-
-wrap_opts() {
- local mydistutilsargs=()
-
- if [[ ${EPYTHON} == python* ]]; then
- mydistutilargs+=( --with-debugsupport )
- fi
-
- "${@}"
-}
-
-python_compile() {
- wrap_opts distutils-r1_python_compile
- if [[ ${EPYTHON} == python3.2 ]]; then
- 2to3 --no-diffs -n -w -f unicode "${BUILD_DIR}/lib" || die
- fi
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles/syntax
- doins ext/Vim/*
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}
diff --git a/dev-python/jinja/jinja-2.9.6.ebuild b/dev-python/jinja/jinja-2.9.6.ebuild
deleted file mode 100644
index 35747dfc21a7..000000000000
--- a/dev-python/jinja/jinja-2.9.6.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit eutils distutils-r1
-
-DESCRIPTION="A full-featured template engine for Python"
-HOMEPAGE="http://jinja.pocoo.org/ https://pypi.python.org/pypi/Jinja2"
-
-# pypi tarball is missing tests
-SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/markupsafe[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- !dev-python/jinja:compat"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-# XXX: handle Babel better?
-
-wrap_opts() {
- local mydistutilsargs=()
-
- if [[ ${EPYTHON} == python* ]]; then
- mydistutilargs+=( --with-debugsupport )
- fi
-
- "${@}"
-}
-
-python_compile() {
- wrap_opts distutils-r1_python_compile
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- if use examples ; then
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-
- insinto /usr/share/vim/vimfiles/syntax
- doins ext/Vim/*
-}
-
-pkg_postinst() {
- if ! has_version dev-python/Babel; then
- elog "For i18n support, please emerge dev-python/Babel."
- fi
-}