summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-04-20 10:23:55 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-04-20 10:24:07 +0200
commit183c57f6f4d47dfbaa6c19b35d7d8bc9f63b6fd0 (patch)
tree01e6f8a71bd2d444b7b87685e21b4235c69ed7e2
parentprofiles/prefix: reorder to have base first, bug#574822 (diff)
downloadgentoo-183c57f6f4d47dfbaa6c19b35d7d8bc9f63b6fd0.tar.gz
gentoo-183c57f6f4d47dfbaa6c19b35d7d8bc9f63b6fd0.tar.bz2
gentoo-183c57f6f4d47dfbaa6c19b35d7d8bc9f63b6fd0.zip
dev-python/testify: Bump
Package-Manager: portage-2.2.28
-rw-r--r--dev-python/testify/Manifest1
-rw-r--r--dev-python/testify/testify-0.8.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/testify/Manifest b/dev-python/testify/Manifest
index 884d8e0516c8..9107644ffc2b 100644
--- a/dev-python/testify/Manifest
+++ b/dev-python/testify/Manifest
@@ -1,2 +1,3 @@
DIST testify-0.5.7.tar.gz 166954 SHA256 153796d3b20b2d8554e52af26a8c891e6f02dfd6cc7be29f9241dad244cff044 SHA512 410ac412306c11bba992b882624fcacdbff00e2865cd986c560d8b50ea8dff0ead8603b18f40414d8dbbe1f3ab9426e0f61170dc450927f6d2282e389800ff21 WHIRLPOOL 2cc958efea71bd475c698cee36e4f1bdb7197c8cb54c38efbf66927d5abc60e769a8995ae7fb4107fab8b74e4b05afcaf16e5c0aec9db3471ddbd771bafa3adf
DIST testify-0.7.2.tar.gz 102858 SHA256 7c209530fbb67344fe8985012056116d7d8eadd6ff126f91c93aa19208fd3ec9 SHA512 4b470aabe1ada88ddaf89145c77dbc5c2d000c8e0fab431535c08b4ff05a04c12f215d4c05d678ba718fdf3295be74fef23041d01d3c05e0b9e2c43c5ab0ed1e WHIRLPOOL 37ff8d7068ba4569215e3df440186ef3149a5fde0e12ec5efefc5b666adf2958b11f4db18995b46536cbf504dadec48f00b5f38e524ae09eb815c8170b8cf669
+DIST testify-0.8.0.tar.gz 68996 SHA256 065cb852110547892d6f971b66795e71ee032a4bcc23decb984878b3ba402aaf SHA512 c3a198fbf9d58c817e6eeffbfba282571e87b952f4d473118b13ec9f1451f94309032bea62bdba866eff0932233cc29be4f7731a56db99fae8fa1e2b3f12ecfc WHIRLPOOL c9e8d80ed802b3effd9c63595f1d2557e314f5d358991a6384c1f91c242b15fbb25a931d8f40171f6d4099584743e7eebe3c15ff30f7c8595318a7e490806da2
diff --git a/dev-python/testify/testify-0.8.0.ebuild b/dev-python/testify/testify-0.8.0.ebuild
new file mode 100644
index 000000000000..abd1101278be
--- /dev/null
+++ b/dev-python/testify/testify-0.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="A more pythonic replacement for the unittest module and nose"
+HOMEPAGE="https://github.com/Yelp/testify https://pypi.python.org/pypi/testify/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND} )"
+
+python_prepare_all() {
+ # Correct typo in setup.py
+ sed -e 's:mock,:mock:' -i setup.py || die
+
+ # Correct use of local importing in pertinent test_ files
+ sed -e s':from .test:from test:' \
+ -i test/test_runner_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ einfo; einfo "Output reporting exceptions \"ImportError: No module named <module>\""
+ einfo "are instances of exceptions expected to be raised, similar to xfails by nose"; einfo""
+ for test in test/test_*_test.py;
+ do
+ "${PYTHON}" $test || die "test $test failed under ${EPYTHON}"
+ done
+}