summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Miller <aidenn0@geocities.com>2016-08-08 10:35:18 -0700
committerMichael Palimaka <kensington@gentoo.org>2016-08-11 04:06:49 +1000
commit1a12b8300619c92eabcb63ab15e24422ce6ef892 (patch)
tree3915dfab1e30da1932d33182f1ace0fe1b8e03ab
parentsys-cluster/nova: bup (diff)
downloadgentoo-1a12b8300619c92eabcb63ab15e24422ce6ef892.tar.gz
gentoo-1a12b8300619c92eabcb63ab15e24422ce6ef892.tar.bz2
gentoo-1a12b8300619c92eabcb63ab15e24422ce6ef892.zip
www-servers/mongrel2: Fix build failure with mbedtls-2.3
* Patches the header-file include order. * This is not yet fixed upstream as upstream bundles the mbedtls * Also upgrade to EAPI 6 which allows use of eapply Gentoo-bug: 590512 Package-Manager: portage-2.2.26
-rw-r--r--www-servers/mongrel2/files/mongrel2-1.11.0-polarssl-platform-590512.patch22
-rw-r--r--www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild30
2 files changed, 52 insertions, 0 deletions
diff --git a/www-servers/mongrel2/files/mongrel2-1.11.0-polarssl-platform-590512.patch b/www-servers/mongrel2/files/mongrel2-1.11.0-polarssl-platform-590512.patch
new file mode 100644
index 000000000000..0e5957e551b8
--- /dev/null
+++ b/www-servers/mongrel2/files/mongrel2-1.11.0-polarssl-platform-590512.patch
@@ -0,0 +1,22 @@
+# Fix missing include for newer mbedtls
+--- a/src/io.h 2016-08-04 15:55:53.124890328 -0700
++++ b/src/io.h 2015-12-31 01:25:07.000000000 -0800
+@@ -6,6 +6,7 @@
+ #endif
+
+ #include <stdlib.h>
++#include <mbedtls/platform.h>
+ #include <mbedtls/x509.h>
+ #include <mbedtls/ssl.h>
+ #include "server.h"
+--- a/src/server.h 2016-08-04 15:54:49.539498093 -0700
++++ b/src/server.h 2015-12-31 01:25:07.000000000 -0800
+@@ -39,6 +39,7 @@
+ #include "adt/darray.h"
+ #include "host.h"
+ #include "routing.h"
++#include <mbedtls/platform.h>
+ #include <mbedtls/ssl.h>
+ #include <mbedtls/entropy.h>
+ #include <mbedtls/x509.h>
+
diff --git a/www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild b/www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild
new file mode 100644
index 000000000000..65f274ee6cd1
--- /dev/null
+++ b/www-servers/mongrel2/mongrel2-1.11.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A language agnostic web server focused on web applications"
+HOMEPAGE="http://mongrel2.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-libs/zeromq
+ >=net-libs/mbedtls-2.1[havege]
+ dev-db/sqlite:3"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp "${FILESDIR}/systemtls.mak" Makefile || die
+ eapply "${FILESDIR}/${P}-polarssl-platform-590512.patch"
+ eapply_user
+}
+
+src_install() {
+ emake install PREFIX=/usr DESTDIR="${D}"
+ dodoc README examples/configs/mongrel2.conf
+}