summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-11-01 14:40:54 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-01 14:40:54 +0200
commit1a3e247a338aa50fcbd509d4b472d214e123e403 (patch)
treee4909fdfeb0d9e8945774035ca73768b4609eb06
parentdev-libs/efl: bump to 1.23.2 (diff)
downloadgentoo-1a3e247a338aa50fcbd509d4b472d214e123e403.tar.gz
gentoo-1a3e247a338aa50fcbd509d4b472d214e123e403.tar.bz2
gentoo-1a3e247a338aa50fcbd509d4b472d214e123e403.zip
dev-libs/libvoikko: bump to 4.3
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-libs/libvoikko/Manifest1
-rw-r--r--dev-libs/libvoikko/libvoikko-4.3.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/libvoikko/Manifest b/dev-libs/libvoikko/Manifest
index af1e1f9445fa..25b636a3aed2 100644
--- a/dev-libs/libvoikko/Manifest
+++ b/dev-libs/libvoikko/Manifest
@@ -1 +1,2 @@
DIST libvoikko-4.2.tar.gz 653769 BLAKE2B 6c0e665d7b5eca394b49dbebf38a0815b1fe1ea328efa305e9d1574b551c633be6b2326b5b402bbc454557a559a821a28c668a1845b21a71c378d0e97103ca53 SHA512 483d3c259a52ae772d52f708789c3df39a4857188c7b9035ce5db8b16bfa4ef144e2ffd557dd6a0655e4c9a6984529784e4098bc949a1bc8a0a50529fee49656
+DIST libvoikko-4.3.tar.gz 655465 BLAKE2B a5c0cfd420d51f873bbd707dfddf2e20ea3df8285a88a13fd6a2af947183be42137aefd1ae088b7b01e938864b3fc9402b110cc8a577efb8331a7ea24f795c2e SHA512 804d55d34deca52f882580ff8699a548d0b62d79eb8e27f8f5783a9e0e57d1ab8986963084df2b5fc7ca9f45546e6e4d66e195a42cfbe0327ca02dc211563988
diff --git a/dev-libs/libvoikko/libvoikko-4.3.ebuild b/dev-libs/libvoikko/libvoikko-4.3.ebuild
new file mode 100644
index 000000000000..7bdff963650d
--- /dev/null
+++ b/dev-libs/libvoikko/libvoikko-4.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5..7}} )
+
+inherit python-r1
+
+DESCRIPTION="Spell checking, hyphenation and morphological analysis tool for Finnish language"
+HOMEPAGE="https://voikko.puimula.org/"
+SRC_URI="https://www.puimula.org/voikko-sources/${PN}/${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+expvfst +hfst"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test"
+
+DEPEND="${PYTHON_DEPS}
+ hfst? ( >=dev-util/hfstospell-0.5.0 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf=(
+ --prefix=/usr
+ --with-dictionary-path=/usr/share/voikko
+ $(use_enable expvfst)
+ )
+
+ if ! use hfst ; then
+ myconf+=( --disable-hfst )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ python_setup
+ default
+
+ python_foreach_impl python_domodule python/libvoikko.py
+}